Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-11-15 15:36:55

mouseboot
Member
Registered: 2019-11-15
Posts: 5

dialogue boxes huge and don't remember resize

hi xfce,

1st up thx for letting me/us use yr awesome env. i love it, it is rly rly fucking killer.

im run xfce on debian buster, and its up to date but still 4.12. i log in with light dm and i use the normal xfce wm.

my question is about dialogue boxes:

when i want to open or save something in writer, mousepad or firefox, my 'open' or 'save' dialogue box takes up about 80% of my screen. i can resize it to sth more manageable, which works for a while, maybe for that session, but then soon it is back to huge again. (after reboot, or resume? i dont know yet.)

i just tested it w texstudio, keepassxc and qpdf (which i think are all qt) and they are already correctly sized, ie not massive. i also notice that thunar (which is also killer!) also remembers its size no problems.

i wanted to ask if there is any settings where this can be modified, or if it is something that is supposed to just work. i have searched around online and in the docs without finding decent info, maybe because the nature of searching for "dialogue box" or "dialog box" isnt a v good filter. i'm capable w linux but not a super tech user, so i dont even know what parameter controls this.

i don't tend to save my session on logout. i prefer to boot to new session each time, with a minimum of programmes autostarting. dunno if that affects it?

any pointers appreciated.

Offline

#2 2019-11-15 16:29:19

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,046

Re: dialogue boxes huge and don't remember resize

Hello and welcome.

I'm not sure what "writer" is, but both mousepad and firefox are based on GTK3 and use GTK3's FileChooserDialog. You can manually set a default size using gsettings via a command like:

gsettings set org.gtk.Settings.FileChooser window-size '(1000, 1000)'

...and change the "1000, 1000" to the pixel size of the dialog that would like.

If the setting doesn't hold, then there probably is another program that is hard-coded to change that setting.

Offline

#3 2019-11-15 17:00:20

mouseboot
Member
Registered: 2019-11-15
Posts: 5

Re: dialogue boxes huge and don't remember resize

hi toz,

thx for yr reply. that setting works and changes them until i boot tor browser, which seems to revert the setting. hmm

is there a possible way to enforce the setting setting globally?


maybe i gotta tell the torproject. or cd it depend on how tor browser is installed perhaps.

Last edited by mouseboot (2019-11-15 17:14:35)

Offline

#4 2019-11-15 18:23:33

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,046

Re: dialogue boxes huge and don't remember resize

Try locking down the dconf channel (prevent resizing of the window). To do so (using root privileges):

  1. Set up the locking mechanism. Create the file /etc/dconf/profile/user with the following content:

    user-db:user
    system-db:local

    --

  2. Create an /etc/dconf/db/local.d/locks directory
    --

  3. Create an /etc/dconf/db/local.d/00-filechooser file with the following content:

    [org/gtk/settings/file-chooser]
    window-size=(500, 500)

    ...change the "(500, 500)" to the dimensions that you would like to force.
    --

  4. Create an /etc/dconf/db/local.d/locks/00-filechooser file with the following content:

    /org/gtk/settings/file-chooser/window-size

    --

  5. Update the dconf database:

    sudo dconf update

    --

  6. Log out and back in again

Reference: https://help.gnome.org/admin/system-adm … n#lockdown

Offline

#5 2019-11-23 21:39:06

mouseboot
Member
Registered: 2019-11-15
Posts: 5

Re: dialogue boxes huge and don't remember resize

hi toz,

just to say: thx a lot for your instructions. seems to work for me.

Offline

Board footer

Powered by FluxBB