Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-11-21 17:14:50

ChameleonScales
Member
Registered: 2019-11-21
Posts: 8

Disable rounded corners

I often accidentally close the window below the active one and this is how it happens:

  • the active window takes the whole screen but is not maximized, therefore it has rounded corners, causing a click in the top-right corner to operate outside that window

  • the window below IS maximized, so it doesn't have rounded corners and if I click in the top-right corner, it hits the X button.

Is there a way to disable rounded corners alltogether so this doesn't happen again?

Last edited by ChameleonScales (2019-11-21 17:15:32)

Offline

#2 2019-11-21 23:42:36

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,046

Re: Disable rounded corners

Hello and welcome.

You can use a window manager theme (Settings Manager > Window Manager > Style tab) that has square corners (e.g. Arc, Numix, Plata).

Offline

#3 2019-11-22 10:03:57

ChameleonScales
Member
Registered: 2019-11-21
Posts: 8

Re: Disable rounded corners

Thanks! and sorry, where are my manners? Hello everyone!
So Numix still has slightly rounded corners so it doesn't work but Ultimate-Plata prevents closing the window behind.
The best would be if a click in the corner would actually close the non-maximized window on top, which is not the case because the cursor changes to window resizing, which I don't need since I always resize windows using the Alt key (set in Window Manager Tweaks > Accessibility > Key used to grab and move windows). Do you know if there's a way to disable this cursor behavior when hovering on window borders?
It's no big deal though, the main issue is solved.

Last edited by ChameleonScales (2019-11-26 06:33:23)

Offline

#4 2019-11-22 12:18:31

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,046

Re: Disable rounded corners

ChameleonScales wrote:

Do you know if there's a way to disable this cursor behavior when hovering on window borders?

The mouse cursor behaves as such when it is hovered over a border. If there were no border, then the behaviour would not be present. It would just be a matter of deleting the left, right and bottom elements in the theme. Or, if you have no need for borders or a titlebar (if you are managing the windows with a keyboard) you could use a theme with no borders/titlebar. As an example:

mkdir -p ~/.themes/noborder/xfwm4
touch ~/.themes/noborder/xfwm4/themerc

...and change to the "noborder" theme in the settings manager.

Offline

#5 2019-11-25 07:32:40

ChameleonScales
Member
Registered: 2019-11-21
Posts: 8

Re: Disable rounded corners

Interesting. I would still like to have the top bar though, so I'll keep Ultimate Plata for the moment.

Last edited by ChameleonScales (2019-11-25 07:58:21)

Offline

#6 2019-11-25 13:29:25

ChameleonScales
Member
Registered: 2019-11-21
Posts: 8

Re: Disable rounded corners

Actually I'd like to disable the edges except keep the title bar if possible. I just asked in a new topic.

Offline

Board footer

Powered by FluxBB