Xfce Forum

Sub domains
 

You are not logged in.

#1 2019-11-22 12:41:04

Gree
Member
Registered: 2019-11-22
Posts: 3

Open windows don't toggle to non-full screen by double clicking anymor

Hello people, I use Fedora 31 with Xfce 4.14 and I can't decrease size/switch to non-full screen mode by double clicking the window name bar, anymore. It used to work by this way before. And I can't figure out what's the problem. Is there any solution?

Offline

#2 2019-11-22 12:48:19

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,046

Re: Open windows don't toggle to non-full screen by double clicking anymor

Hello and welcome.

If I'm understanding your request properly, you need to have two settings set:

1. Settings Manager > Window Manager > Advanced > Double Click Action, set to "Maximize Window"

2. Settings Manager > Window Manager Tweaks > Accessibility > "Hide title of Windows when Maximized", unchecked

Offline

#3 2019-11-22 19:01:28

Gree
Member
Registered: 2019-11-22
Posts: 3

Re: Open windows don't toggle to non-full screen by double clicking anymor

Thank you, sir. Double Click Action setting was the option Fill Window and setting that to Maximize solved it. Thank you again. Have a good day. I don't know if I have to edit and mark the post as Solved or as a moderator it's yours to do so.

Offline

#4 2019-11-23 17:19:23

Gree
Member
Registered: 2019-11-22
Posts: 3

Re: Open windows don't toggle to non-full screen by double clicking anymor

Update: After changing Double Click Action setting yesterday, it happened again. But I think I have found out why this happens. I use Okular too often and when I full-screened Okular my Double Click Action changes back to Fill. It's really strange I've tried to lock double_click_action parameter as maximize in the xfce4-settings-editor but I just can't. It's really strange bug. Okular is default document viewer for KDE, there might be some compability issues with Xfce, no other idea.

Offline

#5 2019-11-24 15:59:33

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,046

Re: Open windows don't toggle to non-full screen by double clicking anymor

Gree wrote:

I use Okular too often and when I full-screened Okular my Double Click Action changes back to Fill.

That is really strange. I have no idea why a KDE app would affect an Xfce setting - especially since it would need to be affected via an xfconf connection. Had a quick look through the Okular source code and there is nothing there that interfaces with xfwm4 or xfconf. Can you try this? In a terminal window, run the following:

xfconf-query -c xfwm4 -mv

...then start okular, full screen it, restore and quit. Check the terminal window to see if any configuration changes happened to the xfwm4 channel.

It's really strange I've tried to lock double_click_action parameter as maximize in the xfce4-settings-editor but I just can't.

No you can't. Those are indicators of kiosk mode locks. And I don't believe xfwm4 supports kiosk mode.

Offline

Board footer

Powered by FluxBB