Xfce Forum

Sub domains
 

You are not logged in.

#1 2020-01-04 09:11:25

FoxiMaxi
Member
Registered: 2019-02-23
Posts: 3

i am unable to make "xf.." windows Always-on-Top

Any other windows can be made "Always on Top", except windows of apps whose command-name start with "xf", ie. Settings Editor, Appearance, Window Manager, Window Manager Tweaks, Keyboard, Display, and so on.
(I can click on the option, but the window behavior remains the same, as well as the text.)

What is the cause? How can I repair it?
(Linux Mint 19.3 Xfce)

Edit:
Now I realize that EVEN MORE windows are affected. Not all, but not only "xf.."-windows. (further examples: Catfish File Search, Archive Manager, Cheese, Firewall Configuration, etc - they can't be made Always-on-Top, either.)
I switched from Cinnamon to Xfce a week ago... (By installing packages.)

Last edited by FoxiMaxi (2020-01-04 10:39:29)

Offline

#2 2020-01-04 14:53:05

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,158

Re: i am unable to make "xf.." windows Always-on-Top

I wonder if this is because the Xfce settings windows (manager, appearance, tweaks, keyboard, display) are dialogs and dialogs can't be set "Always on Top" by design. Catfish works for me, but I'm using the newer development version of it. The others I'm not familiar with.

You can use the following method to determine the windows type of any program. In a terminal window, run:

xprop | grep TYPE

...and then click on the window in question. Perhaps you can do that for the other apps you've listed.

For the Settings Manager apps, it might be a good idea to create a bug report (for the  Xfce Core > Xfce Settings > Settings Manager component) for this issue. If in fact these settings dialogs are not allowed to be set on top, then the option should be greyed out. If they are allowed to do so, then there is a bug preventing it.

Offline

#3 2020-01-04 17:08:33

FoxiMaxi
Member
Registered: 2019-02-23
Posts: 3

Re: i am unable to make "xf.." windows Always-on-Top

Wow. xprop helps. Now it is clear that the affected window-type is:
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_DIALOG

(...NORMAL is not affected.)
So, you say, that's not an issue, it is so "by design"?


ToZ wrote:

I wonder if this is because the Xfce settings windows (manager, appearance, tweaks, keyboard, display) are dialogs and dialogs can't be set "Always on Top" by design. Catfish works for me, but I'm using the newer development version of it. The others I'm not familiar with.

You can use the following method to determine the windows type of any program. In a terminal window, run:

xprop | grep TYPE

...and then click on the window in question. Perhaps you can do that for the other apps you've listed.

For the Settings Manager apps, it might be a good idea to create a bug report (for the  Xfce Core > Xfce Settings > Settings Manager component) for this issue. If in fact these settings dialogs are not allowed to be set on top, then the option should be greyed out. If they are allowed to do so, then there is a bug preventing it.

Last edited by FoxiMaxi (2020-01-04 17:10:33)

Offline

#4 2020-01-04 20:30:28

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 6,158

Re: i am unable to make "xf.." windows Always-on-Top

FoxiMaxi wrote:

(...NORMAL is not affected.)
So, you say, that's not an issue, it is so "by design"?

Well, I think Gtk3's GtkDialog is set to be modal by default, in which case doesn't allow "Always on Top" functionality. Xfce Dialogs borrow from GtkDialog. However, in such a case, the option should then be greyed out.

I think the best option forward is to create a bug report. We should either allow these windows to be set on top, or grey out the option if it is not available.

Offline

Board footer

Powered by FluxBB