Xfce Forum

Sub domains
 

You are not logged in.

#1 2006-09-06 13:59:13

ph0nc
Member
Registered: 2006-09-06
Posts: 2

Keyboard Hotkeys

Hi all,
last weekend i switched to xfce4, because i wanted to run Xgl and fluxbox my former displaymanager doesn't support Xgl. Xgl works very well and now i'm about customizing xfce. I want to use the special keys of my keyboard (e.g. mute sound etc).
First i got the appropriate keycodes by using xev. Then created a $HOME/.Xmodmap file and allocated the keycodes to F* - buttons (e.g. F13...). Then i did the graphical way for allocating these buttons to commands.
Menu
--> Settings
--> Window Manager Settings
--> Keyboard Tab
After creating a new keyboard profile i customized this profile and activated it. But it don't work   :-|

*edit:
if i change the focus model in the focus tab of the window manager settings it has also no effect :? it seems like the window manager settings/preferences are totaly ignored...

phonc@ground0 ~ $ cat .config/xfce4/mcs_settings/xfwm4_keys.xml
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE mcs-option SYSTEM "mcs-option.dtd">
<mcs-option>
   <option name="Xfwm/KeyThemeName" type="string" value="mine"/>
</mcs-option> 

phonc@ground0 ~ $ cat .themes/mine/xfwm4/keythemerc
close_window_key=Alt+F4
maximize_window_key=Alt+F5
maximize_vert_key=Alt+F6
maximize_horiz_key=Alt+F7
hide_window_key=Alt+F8
shade_window_key=Alt+F9
stick_window_key=Alt+F10
cycle_windows_key=Alt+Tab
move_window_up_key=Control+Shift+Alt+Up
move_window_down_key=Control+Shift+Alt+Down
move_window_left_key=Control+Shift+Alt+Left
move_window_right_key=Control+Shift+Alt+Right
resize_window_up_key=Shift+Alt+Up
resize_window_down_key=Shift+Alt+Down
resize_window_left_key=Shift+Alt+Left
resize_window_right_key=Shift+Alt+Right
raise_window_key=Shift+Alt+Page_Up
lower_window_key=Shift+Alt+Page_Down
move_window_next_workspace_key=Alt+Control+End
move_window_prev_workspace_key=Alt+Control+Home
move_window_up_workspace_key=None
move_window_down_workspace_key=None
move_window_left_workspace_key=None
move_window_right_workspace_key=None
move_window_workspace_1_key=Alt+Control+KP_1
move_window_workspace_2_key=Alt+Control+KP_2
move_window_workspace_3_key=Alt+Control+KP_3
move_window_workspace_4_key=Alt+Control+KP_4
move_window_workspace_5_key=Alt+Control+KP_5
move_window_workspace_6_key=Alt+Control+KP_6
move_window_workspace_7_key=Alt+Control+KP_7
move_window_workspace_8_key=Alt+Control+KP_8
move_window_workspace_9_key=Alt+Control+KP_9
fullscreen_key=Alt+F11
up_workspace_key=Control+Alt+Up
down_workspace_key=Control+Alt+Page_Down
next_workspace_key=Control+Alt+Right
prev_workspace_key=Control+Alt+Left
left_workspace_key=None
right_workspace_key=None
add_workspace_key=Alt+Insert
del_workspace_key=Alt+Delete
workspace_1_key=Control+F1
workspace_2_key=Control+F2
workspace_3_key=Control+F3
workspace_4_key=Control+F4
workspace_5_key=Control+F5
workspace_6_key=Control+F6
workspace_7_key=Control+F7
workspace_8_key=Control+F8
workspace_9_key=Control+F9
shortcut_1_key=F15
shortcut_1_exec=urxvt -depth 32 -fg grey90 -bg rgba:0000/0000/0000/dddd -fn 'xft:Bitstream Vera Sans Mono:pixelsize=15' +sb
shortcut_2_key=Alt+F2
shortcut_2_exec=xfrun4
shortcut_3_key=Alt+Control+Delete
shortcut_3_exec=xflock4
shortcut_4_key=F13
shortcut_4_exec=firefox -new-tab
shortcut_5_key=F17
shortcut_5_exec=amixer -c 0 sset 'Master',0 2%+
shortcut_6_key=F18
shortcut_6_exec=amixer -c 0 sset 'Master',0 2%-
shortcut_7_key=F19
shortcut_7_exec=amixer -c 0 sset 'Master',0 toggle
shortcut_8_key=F20
shortcut_8_exec=xmms
shortcut_10_key=F14
shortcut_10_exec=xfe 

As you can see, the keyboard profile is activated and configured. :?
Any idea why it doesn't work?!

thx

Offline

#2 2006-09-07 11:27:05

ph0nc
Member
Registered: 2006-09-06
Posts: 2

Re: Keyboard Hotkeys

some additions:
i'm using gentoo amd64, xfce-base/xfce4 version 4.2.3.2, xfce-base/xfce4-session version 4.2.3
According to the xfce4 documentation (http://www.xfce.org/documentation/docs-4.2/xfwm4.html) i have to run  xfwm4 --daemon in the background.

phonc@ground0 ~ $ xfwm4 --daemon

** (xfwm4:8436): WARNING **: Another Window Manager is already running

phonc@ground0 ~ $ ps -A | grep xf
8414 ?        00:00:00 xfce4-session
8421 ?        00:00:01 xfce-mcs-manage
8428 ?        00:00:03 xfce4-panel
8434 ?        00:00:03 xfdesktop

Does my configuration has no effect because of running xfce4 session? If so, why is this window settings menu in my menu dialog? And how can i configure my keyboard bindings using xfce4 session? If this is not possible, how to change to a non session xfce4?

any advise would be appreciated

Offline

#3 2006-09-25 17:03:28

MtheF
Member
Registered: 2004-03-21
Posts: 26

Re: Keyboard Hotkeys

Try run xbindkeys if you don't get it to work.

Offline

Board footer

Powered by FluxBB