Xfce Forum

Sub domains

You are not logged in.

#1 2007-02-06 19:52:02

Registered: 2007-02-06
Posts: 2

Thunar and NFS home dirs problem


I have FreeBSD 6.2 with today CVSup'ed and installed xorg and xfce4
ports. I added dbus, hald and polkitd in /etc/rc.conf and they starts.

Thunar works normally if a user has home directory on a local disk.

If a user has NFS mounted home directory, then Thunar sometimes
works correctly, but in most cases when it starts (from the terminal or
from Desktop) it freezes and outputs at the bottom of its window "Reading
folder contents...". And its window does not respond any more, also
Thunar does not send any error or warning messages to the console.

There is no difference if a user with NFS mounted home directory is
registered in /etc/passwd or it is registered in nss_ldap, pam_ldap.
I made several tests and I am sure here.

NFS home directories are exported from FreeBSD 6.1 and this server
and clients systems work together more than 1 year without problems.
Home directories are exported r/w without UID mapping and their file
systems are mounted without any options. Also on the server
and clients machines there is rpc.lockd and rpc.statd. User's home
directory is mounted only on one client machine.

Any ideas how to fix this problem?  What's wrong?



#2 2007-02-09 12:16:18

Registered: 2007-02-06
Posts: 2

Re: Thunar and NFS home dirs problem

I found out that this problem occurs only if rpc.lockd runs on a client machine.
If rpc.lockd does not run, then Thunar reports warning message on console,
that it cannot create or open some database file, but works without problems.

If rpc.lockd is running, then Thunar freezes and when I exit from xfce and logout,
then Thunar process continues running.

I repeat again, that I have this problem on FreeBSD 6.2, xfce-4.4.0 (installed
from Ports Collection) and for NFS  mounted home directory for locally registered
(/etc/password) or nss_ldap/pam_ldap registered users.

It's known that there are bugs in FreeBSD implementation of NFS locking, but in
my situation this is strange, because NFS file system is mounted only on one

Can somebody post here information if there are problems with Thunar for users
with NFS mounted home directories, when locking is enabled for NFS file system
on other systems.


Board footer

Powered by FluxBB