Xfce Forum

Sub domains

You are not logged in.

#1 2007-03-21 02:39:28

Registered: 2007-03-21
Posts: 2

Installer failing at GTK+ ---> GNUmake not found

Host OS is FreeBSD 6.2, currently with Gnome2 installed.

I'm trying to install xfce via the GUI, and have managed to get to the point where the installer is running.  However, installation fails at the first step (installing GTK+ Engine and Themes).  The error log reveals that GNUmake is not found. 

For instance:  checking for X... GNUmake: not found

## Building gtk-xfce-engine
GNUmake: not found
!! Failed to build gtk-xfce-engine, see the errors above
!! for details on the problem.

When the GUI is installing, it says GNUmake ... GNUmake which I assume means it exists.

Verifying file integrity... OK.
Extracting the installer... OK.
Checking for usable C compiler... gcc
Checking for usable C++ compiler... g++
Checking for GNU make... GNUmake
Checking for package config tool... pkg-config
Checking for GLib (GModule) >= 2.6.0... detected 2.12.4 in /usr/local
Checking for Gtk+ >= 2.6.0... detected 2.10.6 in /usr/local
Compiling installer-gui... OK.
Running installer-gui...

I went ahead and installed make++ which is supposed to be GNUmake. 

Tried the installer again, with the same result.

Am I missing something?

Thanks,  Roger


#2 2007-03-28 09:52:34

Registered: 2007-02-02
Posts: 15

Re: Installer failing at GTK+ ---> GNUmake not found

Looks like gmake package is not installed. The current version is gmake-3.81.1 . Check if it is installed, if so, reinstall it.


Board footer

Powered by FluxBB