Xfce Forum

Sub domains

You are not logged in.

#1 2008-05-19 22:41:49

Registered: 2008-05-19
Posts: 1

Xfce error: "could not look up internet address"

I also posted this in the ubuntu forums, it's a very aggravating problem...

I'm setting up a Ubuntu 8.04 server with xubuntu-desktop installed. (It needs to be administered by people new to Linux, so the GUI was installed.)

Sometime during the configuration, Xfce started giving an error message on login that it "could not look up internet address" for the machine's hostname, asking to try again or continue anyway. (After continuing, everything works OK.)

What I've found via searches is that this is usually caused by the hostname not being in the /etc/hosts file. However, this is not the case here, the hosts file reads: localhost myserver

Also, the /etc/hostname file reads:


Bind is installed, but not running. (We plan to set up local DNS later.) IPV6 is disabled by blacklisting the ipv6 module. The ethernet card has a static IP address. If this address is put into the hosts file instead of the loopback address, there is no change.

Curiously, if I take out the " myserver" line from /etc/hosts, not only does the error message come up on Xfce startup, but also every time a command is run from a terminal. When that /etc/hosts line is put back in there are no more complaints from terminal sessions, but Xfce still complains upon startup.

There are no other apparent network problems. The server can get out to the internet with no problem, and other systems on the network can access the Samba shares, ssh, etc. on the server OK. Also, from a terminal on the server I can ping "myserver" by name and get a response.

Any ideas? (Even if just a pointer to the source file that checks for various network conditions and decides to issue this error?)


#2 2008-05-20 22:59:42

From: Germany
Registered: 2006-05-18
Posts: 143

Re: Xfce error: "could not look up internet address"

try this:
/etc/hosts: localhost myserver.local myserver

and if you have avahi resolution in mind, apt-get install libnss-mdns
and make sure you have the following in /etc/nsswitch.conf

hosts:  files mdns4_minimal [NOTFOUND=return] dns mdns4




Board footer

Powered by FluxBB