Xfce Forum

Sub domains

You are not logged in.

#1 2008-10-20 08:56:14

Registered: 2008-10-20
Posts: 2

Problems compiling xfce-session-4.5.91

hi  ;D

i'm trying to compile the xfce4.6 beta-1 sources, I compiled nearly all packages, just least this one: xfce-session-4.5.91.tar.bz2

I have this error in the make :

make[3]: Entering directory `/home/cidoloco/Downloads/Xfce/xfce4-session-4.5.91/xfce4-session'
gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I..       -I/usr/include/xfce4 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/atk-1.0   -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include   -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/usr/include/libwnck-1.0 -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/startup-notification-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0   -I/usr/include/xfce4/xfconf-0 -I/usr/include/dbus-1.0 -I/usr/li
b/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -DDBUS_API_SUBJECT_TO_CHANGE -DWNCK_I_KNOW_THIS_IS_UNSTABLE -DLIBDIR=\"/usr//lib\" -DPACKAGE_LOCALE_DIR=\"/usr//share/locale\" -DSYSCONFDIR=\"/usr//etc\" -DXFSM_SHUTDOWN_HELPER=\"/usr//libexec/xfsm-shutdown-helper\" -g -O2 -MT xfce4_session-xfsm-manager.o -MD -MP -MF .deps/xfce4_session-xfsm-manager.Tpo -c -o xfce4_session-xfsm-manager.o `test -f 'xfsm-manager.c' || echo './'`xfsm-manager.c
In file included from xfsm-manager.c:55:
/usr/include/linux/ioprio.h: In function 'task_ioprio':
/usr/include/linux/ioprio.h:52: error: dereferencing pointer to incomplete type
/usr/include/linux/ioprio.h:53: error: dereferencing pointer to incomplete type
/usr/include/linux/ioprio.h: In function 'task_ioprio_class':
/usr/include/linux/ioprio.h:60: error: dereferencing pointer to incomplete type
/usr/include/linux/ioprio.h:61: error: dereferencing pointer to incomplete type
make[3]: *** [xfce4_session-xfsm-manager.o] Error 1
make[3]: Leaving directory `/home/cidoloco/Downloads/Xfce/xfce4-session-4.5.91/xfce4-session'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/cidoloco/Downloads/Xfce/xfce4-session-4.5.91/xfce4-session'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/cidoloco/Downloads/Xfce/xfce4-session-4.5.91'
make: *** [all] Error 2

I'm running slackware 12.1
this is my compiler and kernel information
bash-3.1# cat /proc/version
Linux version (root@midas) (gcc version 4.2.3) #2 SMP Wed Apr 30 13:41:38 CDT 2008

really geek part  :razz: :
I already tried to search for errors in the /usr/include/linux/ioprio.h file, but I didn't found anything wrong on it, except for the fact that it uses a task_struct struct that gcc says it don't have the ioprio member, but it have this member and the correct header is included :?
this struct is on the file /usr/include/linux/sched.h

I still trying to find the error, but if somebody have any ideas would be great big_smile

thanks  smile

(looks like i'm the only that have this problem on google  lol)


#2 2008-10-21 17:45:57

From: Germany
Registered: 2006-05-18
Posts: 143

Re: Problems compiling xfce-session-4.5.91

Your kernel 2.6.24-5 is from about january this year.

I'd fancy the guess that svn versions are built against the bleeding edge,
so upgrading from -5 to -21 might be of help.

Lets hope the release versions will be more kernel-revision-agnostic  ;D




#3 2008-10-21 18:37:40

Registered: 2008-10-20
Posts: 2

Re: Problems compiling xfce-session-4.5.91

humm, i didin't noticed that my kernel is that old  :-| (it's the default slack 12.1 kernel)
i'll compile the lastest version here and then i post here what happened  :razz:

edit -->
ok, i tried to compile it usind the last kernel from kernel.org (, and is gives the same error
changed the gcc version too, and no results =-\

i'm giving up =-P
i'll wait the final version package for slackware or the graphical installer and see if it compiles fine here

thanks for the tips, herd ;D


Board footer

Powered by FluxBB