Xfce Forum

Sub domains

You are not logged in.

#1 2009-01-05 21:43:00

Registered: 2009-01-05
Posts: 2

!! Failed to build exo

Hello everybody,

I have a error at the end of the script. I post the last part of the log which describes it :

gcc -DHAVE_CONFIG_H -I. -I.. -I.. -DDATADIR=\"/usr/local/share\" -DEXO_COMPILATION -DG_LOG_DOMAIN=\"exo\" -DLIBEXECDIR=\"/usr/local/libexec\" -DLIBEXO_VERSION_API=\"0.3\" -DPACKAGE_LOCALE_DIR=\"/usr/local/share/locale\" -I/usr/local/include -I/usr/include -I/usr/include -DHAVE_GNUC_VISIBILITY -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/local/include/xfce4 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/local/include -I/usr/include -I/usr/include -O2 -pipe -Wall -Werror -MT libexo_0_3_la-exo-icon-view.lo -MD -MP -MF .deps/libexo_0_3_la-exo-icon-view.Tpo -c exo-icon-view.c  -fPIC -DPIC -o .libs/libexo_0_3_la-exo-icon-view.o
cc1: warnings being treated as errors
exo-icon-view.c: In function 'exo_icon_view_layout_cols':
exo-icon-view.c:3195: warning: 'rows' may be used uninitialized in this function
gmake[3]: *** [libexo_0_3_la-exo-icon-view.lo] Erreur 1
gmake[3]: quittant le répertoire « /root/tmp/selfgz330322777/exo/exo »
gmake[2]: *** [all] Erreur 2
gmake[2]: quittant le répertoire « /root/tmp/selfgz330322777/exo/exo »
gmake[1]: *** [all-recursive] Erreur 1
gmake[1]: quittant le répertoire « /root/tmp/selfgz330322777/exo »
gmake: *** [all] Erreur 2
!! Failed to build exo, see the errors above
!! for details on the problem.

Thank you for all your replies


#2 2009-01-08 20:52:32

From: Sweden
Registered: 2008-07-30
Posts: 14

Re: !! Failed to build exo

The C-flag '-Werror' says that warnings should be treated as errors. The simple solution would be to remove that flag.

Try running make with

make CFLAGS='-O2 -pipe -Wall'


Board footer

Powered by FluxBB