Xfce Forum

Sub domains
 

You are not logged in.

#1 2009-03-03 21:50:56

cL0N31
Member
Registered: 2008-06-21
Posts: 2

missing icons in xfce4-4.6

i use graphical installers and i install in /opt/xfce4

i had xfce4-4.4.3 installed like this before and it had a Rodent icon theme shipped with it, so the icons were working just fine...
now when i fresh-installed xfce4-4.6 almost all of the icons were missing...
when i looked under settings -> appearance -> icons , there were no themes listed...
i looked under the xfce4-4.6's share/icons directory and saw that there was no Rodent or any other theme directory (except hicolor directory which doesn't have index.theme file in it)...
so what i did, i copied over the Rodent directory from xfce4-4.4.3 to xfce4-4.6 and many icons showed up... also, in settings -> appearance -> icons the Rodent icon theme appeared in the list...
but it doesn't have to be done that way, does it? what am i doing wrong?

btw, i do have hicolor-icon-theme installed... just because by default it sets itself to a hidden state, it never shows up in the settings -> appearance -> icons

Offline

#2 2009-03-03 23:58:02

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 94
Website

Re: missing icons in xfce4-4.6

HI.
I do not know what Linux distribution you use, but at least in Debian, there are two folders in which the icons are displayed in the selection list of icons:

1 - / usr / share / icons
2 - / home / user / .icons

Sure that the icons are some of these folders?


url: blog.desdelinux.net
twt: @elavdeveloper

Offline

#3 2009-03-05 05:42:36

cL0N31
Member
Registered: 2008-06-21
Posts: 2

Re: missing icons in xfce4-4.6

i don't like linux, i use freebsd... in freebsd it's the same thing, the icon themes get installed into /usr/share/icons ... what do you suggest, install some other icon theme and use it in xfce? it shouldn't be this way, as xfce always had it's own icons, at least so was before 4.6

Offline

#4 2009-03-05 12:27:29

xfcelav
Member
From: /var/www/xfcelav
Registered: 2008-04-10
Posts: 94
Website

Re: missing icons in xfce4-4.6

You may be right in what you say, but at least I did not use the icon theme Rodent and I was welcome to xfce 4.6 will not bear, as it allows the user to choose an icon theme to choose.


url: blog.desdelinux.net
twt: @elavdeveloper

Offline

#5 2009-03-05 18:24:27

budman
Member
Registered: 2009-03-05
Posts: 6

Re: missing icons in xfce4-4.6

Hi

I had the same issue - not sure if it may be related, seems the icon-theme.cache file was causing all the KDE icons to disappear.
I removed those files from /usr/share/icons and all the icons came back.  Also the fallback icon theme seems to work now.

Adding to the ~/.gtkrc-2.0 file
gtk-icon-theme-name = "Tango"


# this file should be placed in your home folder
# and name ".gtkrc-2.0"

#---------------------------------------------------------------
# Section "icon background colors"
#---------------------------------------------------------------
# The following two lines *should* be left uncommented
# if we want the XFCE desktop icon backgrounds to use
# alpha blending (e.g. invisible or some % thereof)

style "xfdesktop-icon-view" {
XfdesktopIconView::label-alpha = 0



#---------------------------------------------------------------
# Section "icon font colors"
#---------------------------------------------------------------

# The next three lines deal with the color of the desktop icon's
# text. You can comment them out if you want you use gtk theme
# colors. Below yields white un-selected normal, green selected,
# and blue when going to another window
#
# I chose three different colors so that you can see the level
# of customization we can do.

fg[NORMAL] = "#ffffff"        #this is white
fg[SELECTED] = "#00ff00"      # this is green
fg[ACTIVE] = "#0000ff"        # this is blue

## my blue fonts to use with nuvola theme & royal blue WM
# environment. a soft shark underbelly blue color if you will.
#fg[NORMAL] = "#528AC6"
#fg[SELECTED] = "#528AC6"
#fg[ACTIVE] = "#528AC6"

}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"



#---------------------------------------------------------------
# Section "xfce panel colors"
#---------------------------------------------------------------

# Use these to change the panel color.  Note this should
# be commented out entirely if you decide to use 
# Section "xfce panel background" below.

#style "panel"
#{
#this one here is grey
#bg[NORMAL] = "#909599"
# use this with nuvola theme
#bg[NORMAL] = "#64AEE0"
#xthickness = 0
#ythickness = 0
#}
#
#widget_class "*Panel*" style "panel"
#widget "*Panel*" style "panel"
#class "*Panel*" style "panel"



#---------------------------------------------------------------
# Section "xfce panel background"
#---------------------------------------------------------------

style "panel"
{
bg_pixmap[NORMAL] = "Panel/panel-bg.png"
}

# note I simply have a folder in my home called "Panel"
# with the file "panel-bg.png" in it. not sure if you 
# can hard code that to somewhere else.

widget_class "*Panel*" style "panel"
widget "*Panel*" style "panel"
class "*Panel*" style "panel"
widget_class "*List*"              style "colored"
class "*List*"                     style "colored"
widget_class "*Text*"              style "colored"
class "*Text*"                     style "colored"
widget_class "*Entry*"             style "colored"
class "*Entry*"                    style "colored"



#---------------------------------------------------------------
# Section "xfce icon fallback theme"
#---------------------------------------------------------------
#
# this is our fallback icon theme in case we launch 
# thunar in KDE or XFCE can't find an icon for your theme
# for some icon for some reason.
# a safe default is "Rodent" as it comes with Slackware 12's XFCE

gtk-icon-theme-name = "Tango"

Offline

#6 2009-03-16 17:01:28

shpenat
Member
Registered: 2009-03-16
Posts: 2

Re: missing icons in xfce4-4.6

Hi. I have the very same problem. I compiled Xfce4-4.6 manually but the source codes does not contained icon themes (no icons installed at all). So I used Rodent from Xfce4-4.4, but the names have already changed.

I do not know. Either Xfce expect Linux distributors to provide their own icons, or it has not yet been released.

Offline

#7 2009-03-16 20:30:50

s0ulslack
Moderator
From: Idaho
Registered: 2005-12-25
Posts: 291

Re: missing icons in xfce4-4.6

Rodent will hopefully be back, in the mean time you can install Tango, Industrial or GNOME Icons (hicolor) and Rodent will inherit missing icons from the theme.

There are a few decent icon sets that are full and complete on http://xfce-look.org if Tango/Industrial don't suit you smile

Offline

#8 2009-03-17 13:08:27

shpenat
Member
Registered: 2009-03-16
Posts: 2

Re: missing icons in xfce4-4.6

Thank you for info.

I already knew about these possibilities. But was really surpriped that Xfce-4.6 was released without its own icons.  And more surprising is the fact that xfce-icon-theme package in main repository seems to be unchanged for some time (But I may be wrong about this).

little OT: Is it possible to change from scalable (svg) to non-scalable (png) icons on panel? I somehow dont like how some icons are scaled up.

Offline

#9 2009-03-18 00:58:16

gfontaine
Member
From: Québec, Canada
Registered: 2008-06-15
Posts: 20
Website

Re: missing icons in xfce4-4.6

Hi !

Just to mention that I upgraded to 4.6 from 4.3. I was surprised some icons were missing, Rodent theme. I found this post which greatly helped me in fixing this issue.

Xfce4 4.6 still uses xfce4-icon-theme (Rodent) as by version 4.4.3. So I installed tango-icon-theme along with gnome-icon-theme. Now all icons are displayed, tango ones being used where Rodent icons are missing.

Please note that Xfce4 4.6 is installed in a Gentoo full testing environment (Funtoo variant). The desktop performs just well under xorg-server 1.5.3-r4 and xorg-x11 7.4.

Offline

#10 2009-05-09 13:45:19

huggybear
Member
Registered: 2009-05-09
Posts: 2

Re: missing icons in xfce4-4.6

i don't like linux, i use freebsd...

lmao

Offline

Board footer

Powered by FluxBB