Xfce Forum

Sub domains

You are not logged in.

#1 2009-03-29 22:16:42

Registered: 2009-03-05
Posts: 6

xfprint in xfce 4.6


I send print jobs to a remote cups print server.

When I try any of the apps that use xfprint, like mousepad, the print generates an error about device not present.
I checked the xfce printer sys config which is set to cups.  I checked the print manager, its empty.
I then checked the hp-toolbox, it shows the printer, but same device error.

error: Unable to communicate with device (code=12): hp:/usb/photosmart_7350?serial=MY31N440KP
error:  Unable to open device hp:/usb/photosmart_7350?serial=MY31N440KP.

The odd thing is, I configured the printer via the Cups web interface, setup the cups/client.conf file.
When I run lpstat and lpoptions from cmd line, it shows the printer as the default.
I then can send print jobs from cmd line using lpr, from the gui using any kde app, from open office
with no issues. 

Is there another config file I might be overlooking?

Should the device URI be different for remote printers?

(BTW, I unselected the apply filters option and clicked print - caused xfprint to hang)



#2 2009-03-31 00:53:58

Registered: 2009-03-05
Posts: 6

Re: xfprint in xfce 4.6


Here is a little more details

xfconf-query -c xfprint -p /printing-system

When I run xfprint4-manager from cmd line:

** (xfprint4-manager:5289): WARNING **: xfprint: XfPrint/system is not set

xfconf-query -c xfprint -p /system

Property "/system" does not exist on channel "xfprint"

This may explain why the print manager is empty.

When I try to run xfprint4         
** (xfprint4:5295): WARNING **: Unable to load printing system module cups_plugin.so

Running from cmd line I get a dialog with select file to print, even though the printer system is set to cups.
Running from desktop menu, I get the dialog, with the Print To: drop down set to the default printer.
From Mousepad -> Pressing Print -> client-error-bad-request  -> An error occurred while trying to print the file

xfprint_plugin.c:#define PROP_PRINTING_SYSTEM  "/printing-system"

main.c:  /* Load the printing system module */
main.c:    if (xfconf_channel_has_property (channel, "/XfPrint/system")) {



Board footer

Powered by FluxBB