Xfce Forum

Sub domains

You are not logged in.

#1 2009-11-03 17:03:36

Registered: 2009-07-05
Posts: 21

Can Not Find Sound Device [SOLVED]: Had to adduser <user> audio


When logged as root, I can access a sound recorder (not sure what package it is but it displays in help about gnom-sound-recorder 2.26.0) and record/playback audio. Similarly I can access an audio mixer (package xfce4-mixer) and select the volumes per each audio channel. Lastly I can run audacity -with which I have other problems but it does not complain-.

When I log as a regular (non super) user, if I launch the mixer it will complain: GStreamar was unable to detect any sound device. Some sound system specific GStreamer packages nay be missing]. It may be also a permission problem. If I launch the recorder it will complain: Your audio capture setting are invalid. Please correct them with "sound preferences" under the System-Preferences menu. If I launch Audacity and press "record", I get: Error while opening sound device. Please check the input device setting and the project sample rate. Lastly, VLC play movies w/o sound

Thank you in advance for your help



#2 2009-12-19 14:24:14

Registered: 2006-05-26
Posts: 3

Re: Can Not Find Sound Device [SOLVED]: Had to adduser <user> audio

If someone more got this problem, you can try see the permission, look at /dev/mixer and confirm user:group to root:audio, if not, do it

chown root.audio /dev/mixer

then, logout and login.


Board footer

Powered by FluxBB