Xfce Forum

Sub domains

You are not logged in.

#1 2009-12-28 22:43:18

Registered: 2009-12-28
Posts: 5

Cannot start XFCE4 as regular user

I have installed XFCE but I cannot run it in normal user. I have both dbus and hal up and running, but when I try to fire XFCE I come to this error:

Unable to load a failsafe session

Unable to determine failsafe session name.  Possible causes: xfconfd isn't running (D-Bus setup problem); environment variable $XDG_CONFIG_DIRS is set incorrectly (must include "/etc"), or xfce4-session is installed incorrectly.

I am running Gentoo Linux 10.0/desktop for AMD64 on a 2.6.31 Kernel
DBUS and HAL are both up and running, and my user is on both groups.$XDG_CONFIG_DIRS points to /etc/xdg

I have tried to find a solution googling and on some Linux forums, but most of the issues are referred to people not having either hal or dbus enabled, which is not my case.

If I run XFCE as root, I have no problems and the WM loads fine.

I try to start XFCE with XDM login manager and a .xsession file

Can anyone help me with that please?

Thanks in advance!


#2 2009-12-29 04:21:01

From: Idaho
Registered: 2005-12-25
Posts: 291

Re: Cannot start XFCE4 as regular user

Answered on the Gentoo Forums smile


Board footer

Powered by FluxBB