Xfce Forum

Sub domains

You are not logged in.

#1 2010-05-06 07:25:29

Registered: 2010-04-09
Posts: 1

Loading nm-applet

I currently have Xfce 4.6.1 running on Ubuntu Server 10.04 on my mini-itx machine.

I'd like to run nm-applet in order to simplify the business of creating and running VPNs, but having installed the package seem to be hitting problems with DBUS permissions:

sean@zoidberg:~$ nm-applet&
[1] 1294
** (nm-applet:1294): WARNING **: <WARN>  request_name(): Could not acquire the NetworkManagerUserSettings service.
  Error: (9) Connection ":1.41" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file

[1]+  Exit 1                  nm-applet

I have tried various solutions based around adding or amending policies in '/etc/dbus-1/system.d/NetworkManager.conf' and '/etc/dbus-1/system.d/nm-applet.conf', all to no avail. Starting nm-applet with sudo prodiuces nothing in terms of results or errors.

I have also tried installing xfapplet, but get nowhere with that as nm-applet is not available in the configuration dialogue - I am guessing that if won't run from the command line it won't run in another application either.

Has anyone else encountered this issue, or can anyone point me to where I should go next?




Board footer

Powered by FluxBB