Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-11-19 07:09:31

John_Jason_Jordan
Member
From: USA, left coast
Registered: 2011-11-13
Posts: 106

How do I stop programs from launching at startup?

Every time the desktop comes up Claws Mail and Firefox are launched. They are not listed in Settings Manager > Session and Startup > Application Autostart, there are no saved sessions, Logout Settings boxes are unchecked, and I always shut down all programs before logging out or shutting down. I have never added either one to Application Autostart, although when I first installed Xfce the "Automatically save session on logout" box was checked by default. I unchecked it and have always exited with no programs running.

There must be a file somewhere that Xfce is using to decide what to launch on startup. Apparently I'll have to edit the file manually. Can someone please tell me where the file is?

Also, as soon as the desktop comes up I hear a very loud voice say "welcome to <unintelligible>." I don't want the sound turned off, but this is unacceptable. Often I need to start up my computer in class or in the library. Can someone please tell me where the setting is to turn this off?

Last edited by John_Jason_Jordan (2011-11-19 07:17:43)


Linguistics on Linux!

Offline

#2 2011-11-19 07:22:06

ManOfSteel
Member
Registered: 2005-10-06
Posts: 104

Re: How do I stop programs from launching at startup?

For the first issue, have you tried closing the applications and actually saving a session?

EDIT: one more thing, you may want to check the contents of ~/.cache, ~/.config/autostart, etc.

Last edited by ManOfSteel (2011-11-19 07:27:30)

Offline

#3 2011-11-19 17:31:27

John_Jason_Jordan
Member
From: USA, left coast
Registered: 2011-11-13
Posts: 106

Re: How do I stop programs from launching at startup?

I finally managed to get it to stop loading Firefox, and Claws Mail. In Settings Manager > Session and Startup they were listed in the Session tab, even though at the time they were not running. I suspect a bug. At the time they were not running but they had been running previously in that session. So they were not removed when I closed them down. I had saved sessions previously, but this time I manually deleted them from the Session tab and saved the session again. They no longer launch automatically at startup.

I still haven't figured out where the sound clip is coming from. The programs launching were annoying, but the sound clip is VERY LOUD and totally unacceptable. And I don't who who to blame - Xfce or Fedora or Gnome. It happens after the Xfce desktop has finished loading. I looked in /var/log/messages, and I found numerous lines referring to pulseaudio starting, but I didn't find anything that looked like an audio file was being played.


Linguistics on Linux!

Offline

#4 2011-11-19 17:35:15

stqn
Member
Registered: 2010-10-11
Posts: 174

Re: How do I stop programs from launching at startup?

You could try to search for the sound file itself:

sudo find / -iname "welcome*" 2>/dev/null

for example...

Offline

#5 2011-11-19 18:09:00

John_Jason_Jordan
Member
From: USA, left coast
Registered: 2011-11-13
Posts: 106

Re: How do I stop programs from launching at startup?

I have made progress. The sound is speech, badly synthesized, but I could hear "welcome to" and then it sounded a bit like "orca," although that meant nothing to me. So I googled on "welcome to orca" and, sure enough, it turns out that orca is a text to speech utility for the visually impaired. For some reason it is being launched on startup, although I have 20-20 vision and never enabled it, at least not deliberately. I don't find any references to it in Session and Startup, but yum said that orca was installed. It is no longer installed. Hopefully, that will resolve the issue.


Linguistics on Linux!

Offline

Board footer

Powered by FluxBB