Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-04-02 19:04:27

wkr
Member
Registered: 2011-01-01
Posts: 88

Problem installing xfce4-session-4-9-0

Hi all,
I have tried to install Xfce 4.10 pre1 on Xubuntu 11.10. Following wiki instructions, I have set $PREFIX to $HOME/local. Install was easy for all components but "make install" failed for xfce4-session-4-9-0 with the following error message at the end :

make[2]: Rien à faire pour « install-exec-am ».
test -z "/usr/share/xsessions" || /bin/mkdir -p "/usr/share/xsessions"
/usr/bin/install -c -m 644 xfce.desktop '/usr/share/xsessions'
/usr/bin/install: impossible de supprimer «/usr/share/xsessions/xfce.desktop»: Permission non accordée
make[2]: *** [install-desktopDATA] Erreur 1
make[2]: quittant le répertoire « /home/wkr/local/xfce4-session-4.9.0 »
make[1]: *** [install-am] Erreur 2
make[1]: quittant le répertoire « /home/wkr/local/xfce4-session-4.9.0 »
make: *** [install-recursive] Erreur 1

Edit : Translation of  impossible de supprimer «/usr/share/xsessions/xfce.desktop»: Permission non accordée: ---->
Cannot delete «/usr/share/xsessions/xfce.desktop» permission denied

So I need some help :-)

By advance, thanks

Last edited by wkr (2012-04-02 19:11:52)

Offline

#2 2012-04-03 06:01:35

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Problem installing xfce4-session-4-9-0

sudo make install?

Or use --with-xsession-prefix=/somewhere/you/can/write/to

Offline

#3 2012-04-03 13:15:23

wkr
Member
Registered: 2011-01-01
Posts: 88

Re: Problem installing xfce4-session-4-9-0

Thanks for your help Nick smile

The error message above occurs with make install
sudo make install also fails but the error message is different :

test -z "/usr/local/lib/xfce4/session/splash-engines" || /bin/mkdir -p "/usr/local/lib/xfce4/session/splash-engines"
 /bin/bash ../../libtool   --mode=install /usr/bin/install -c   libbalou.la '/usr/local/lib/xfce4/session/splash-engines'
libtool: install: error: cannot install `libbalou.la' to a directory not ending in /home/karim/local/lib/xfce4/session/splash-engines
make[4]: *** [install-balouLTLIBRARIES] Erreur 1

With ./configure --with-xsession-prefix=/home/wkr/local it another error message !

/usr/bin/install: cann/usr/bin/install: cannot remove `/usr/local/lib/libxfsm-4.6.so.0.0.0': Permission denied
make[2]: *** [install-libLTLIBRARIES] Erreur 1
ot remove `/usr/local/lib/libxfsm-4.6.so.0.0.0': Permission denied
make[2]: *** [install-libLTLIBRARIES] Erreur 1

When I run ./configure with default option (/usr/local I think), sudo make installl works and it generates a startxfce4 file in /usr/local/bin/, but running this file in console launches my good old xfce4.8. It's as if doesn't look for my stuff in ~/local/ where are installed other Xfce4.10 components. And I unsuccessfully googled for that sad

Offline

Board footer

Powered by FluxBB