Xfce Forum

Sub domains

You are not logged in.

#1 2012-06-29 08:32:49

Registered: 2012-06-29
Posts: 1

Startup problem, can't start any terminal emulators


I'm using XFCE as an alternative desktop/window manager, because my usual one (Enlightenment E16) is not exactly modern and has compatibility issues with some applications.

Until recently, I just started XFCE from a text console via startx xfce4-session -- :1, and it worked like a charm.

Now, though, I only get a partial session restore (only ever restores gamix, not other applications) and one xterm with xfce startup info, and can not start any extra terminals (xterm, Eterm, Konsole, xfterm4) - they only pop up for a split second and then are gone again. Other X apps (Thunar, Gimp, gamix, wireshark etc.) work without any apparent problems, though. And it's not the terminals themselves, or, AFAICT, my shell startup scripts, as they all work properly over in Enlightenment-land.

I tried googling and searching the forums, but didn't find anything useful, also blowing away ~/.config/xfce4, and even starting xfce from a freshly-generated user that doesn't have any config files, but to no avail.

The output in the sole xterm is:

xfdesktop[14306]: starting up

(polkit-gnome-authentication-agent-1:14317): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:14317): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkOptionMenu::indicator-size' of type `GtkRequisition' from rc file value "0" of type `glong'
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkOptionMenu::indicator-spacing' of type `GtkBorder' from rc file value "0" of type `glong'

HP Linux Imaging and Printing System (ver. 3.10.6)
System Tray Status Service ver. 2.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: No hp: or hpfax: devices found in any installed CUPS queue. Exiting.

System is Debian Squeeze (with some stuff from backports), 32bit, kernel 2.6.39-bpo.2-686-pae, with XFCE4 packages:

~ $ dpkg -l | grep xfce
ii  gtk2-engines-xfce                        2.6.0-2                              A GTK+-2.0 theme engine for Xfce
ii  libxfce4menu-0.1-0                       4.6.2-1                              freedesktop.org compliant menu implementation for Xfce
ii  libxfce4util-bin                         4.6.2-1                              tools for libxfce4util
ii  libxfce4util-common                      4.6.2-1                              common files for libxfce4util
ii  libxfce4util4                            4.6.2-1                              Utility functions library for Xfce4
ii  libxfcegui4-4                            4.6.4-1                              Basic GUI C functions for Xfce4
ii  xfce-keyboard-shortcuts                  4.6.4-1                              xfce keyboard shortcuts configuration
ii  xfce4                                    4.6.2                                Meta-package for the Xfce Lightweight Desktop Environment
ii  xfce4-appfinder                          4.6.2-1                              Application finder for the Xfce4 Desktop Environment
rc  xfce4-mcs-manager                                         Settings manager for Xfce4
ii  xfce4-mixer                              4.6.1-2+b1                           Xfce mixer application
ii  xfce4-panel                              4.6.4-1                              The Xfce4 desktop environment panel
ii  xfce4-session                            4.6.2-3                              Xfce4 Session Manager
ii  xfce4-settings                           4.6.5-2                              graphical application for managing Xfce settings
ii  xfce4-utils                              4.6.2-1                              Various tools for Xfce
ii  xfdesktop4                               4.6.2-1+b1                           xfce desktop background, icons and root menu manager
ii  xfdesktop4-data                          4.6.2-1                              xfce desktop background, icons and root menu (common files)

Any hints on how I could get xfce going again? I really need my terminals as I'm an old fart who starts applications by typing and giving them arguments, not by clicking in menus wink

Kind regards,


#2 2012-10-04 18:17:38

Keith Hedger
From: Torrington,Devon,UK
Registered: 2012-04-01
Posts: 46

Re: Startup problem, can't start any terminal emulators


Board footer

Powered by FluxBB