Xfce Forum

Sub domains

You are not logged in.

#1 2012-09-13 19:20:11

Registered: 2012-08-26
Posts: 2

How can a custom-mounted drive show on desktop as mounted


I have posted this on a couple of mailing lists with no conclusive answer, so I'm trying here: 

On Xubuntu 12.04.1, I have written a "udev" rule that calls a custom shell script to mount a USB ext4fs drive with custom mount options.  The drive gets mounted correctly so that the "mount" command shows the drive and the correct options.  On the XFCE desktop, however, the drive icon is grayed out, and the icon's right-click menu has an option for "Mount Volume."

Is there a way to have XFCE update the icon automatically, as soon as the USB drive is inserted, to show that the volume is already mounted?  This happens, as expected, with other volumes (ones that are not affected by my "udev" rule). 

I have tried:

thunar-volman --device-added /sys$DEVPATH

where $DEVPATH is the sysfs path of the newly added device.  This command doesn't seem to do anything, including when I run the command in a terminal window (even with superuser privileges).

Installed versions include xfdesktop 4.8.3, thunar-volman 0.6.1

The issue seems to be the same one as in http://forum.xfce.org/viewtopic.php?pid=25671#p25671

Is this known to work in XFCE 4.10?  The Xubuntu 12.10 (Quantal) release is planned to have XFCE 4.10; maybe what I am trying to do will be easier there. 

Thanks for any insight.



Board footer

Powered by FluxBB