Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-02-21 19:41:07

rollhax
Member
Registered: 2013-02-21
Posts: 1

Unable to bind Super+Return to keyboard shortcut

Hello all!

I'm relatively new to XFCE. I would consider myself between an intermediate and advanced linux user. I'm using XFCE version 4.8.1.

At home I use AwesomeWM and have gotten used to pressing Mod4+Enter (<Super>+Enter/<Super>+Return) to open a new terminal.

At work, however, my system is a RHEL6 system and after many hours of failing to build AwesomeWM on the machine, I switched to XFCE (not a fan of gnome or KDE).

I am unable to bind <Super>+Enter to my terminal command. I was able to bind <Super>+t to the same command and it works just fine.

What happens when I try to bind <Super>+Enter to a command:

I go to Menu > Applications > Preferences > Keyboard > Shortcuts > Add New. I type in my command (in this case "urxvt256c -geometry 320x89+0+0"), click Next, and when it asks for my keyboard shortcut I do <Super>+Enter. Now "<Super>+Enter" appears on the dialog for a short time and then it seems to think I'm clicking the Cancel button.

So I tried to edit my ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml file, killed xfconfd afterwards. It is now showing up in my Keyboard Shortcuts GUI, but the shortcut itself is still not working (note: Super+t still works fine).

I'm at a loss. Is it safe to say this just isn't a binding that XFCE will accept?

Offline

#2 2013-03-13 12:39:56

fdelente
Member
Registered: 2012-12-30
Posts: 7

Re: Unable to bind Super+Return to keyboard shortcut

Old post, but anyway: you could try installing xbindkeys, it should allow you to bind any key combination to any arbitrary command.

Offline

#3 2013-03-13 21:17:28

jeromeg
Moderator
From: France
Registered: 2010-11-11
Posts: 131
Website

Re: Unable to bind Super+Return to keyboard shortcut

This is fixed is the git master branch of libxfce4ui // xfce4-settings but is very hard to backport in a stable release.

Offline

Board footer

Powered by FluxBB