Xfce Forum

Sub domains

You are not logged in.

#1 2013-03-19 11:43:10

Registered: 2013-03-19
Posts: 2

Triple monitor setup being overridden by XFCE & theme missing.

System info:
Xubuntu 12.04 with ubuntu-dev/xfce-4.10 PPA added and upgraded.
AMD catalyst drivers installed.
3 monitors side by side.

  I have setup the 3 monitors through catalyst and they all work properly as far as the login screen. Once logged in the layout gets changed from:

Monitor1 - Monitor2 - Monitor3


Monitor1 - Monitor2 - Clone of Monitor1

  In this state the selected theme is not being used and a lot of icons are missing or replaced by a single grey square.

  None of the options in settings>hardware>display work. If I re-arrange the configuration in catalyst then it will work as expected for the rest of that session.
  If I remove the xorg.conf that catalyst generates then I end up with all 3 monitors displaying the same image, but the theme works.
  Whilst trying to figure out what was happening I think I came across an issue in setttings editor>displays where there were 6 display entries, 3 from catalyst and 3 with different names. All 6 were enabled, so I disabled the 3 non catalyst entries and then after a logout/login I ended up with 3 monitors arranged correctly with the theme applied. Unfortunately after a power cycle I ended up with the same broken layout as described above.

Can I stop XFCE from making any chages to my monitor layout?
Why is the theme disappearing?

Any help would be great as it is very annoying to have to set the monitors up by hand every time I log in.


#2 2013-03-19 11:50:04

Registered: 2013-03-19
Posts: 2

Re: Triple monitor setup being overridden by XFCE & theme missing.

Ive just tried a quick hack with an xrandr script in session>autostart and it still doesnt work!!
Something is overriding my settings - I have to open a terminal and run the script by hand -aaargh!
What is doing this???


#3 2013-04-25 15:28:07

Registered: 2013-04-25
Posts: 1

Re: Triple monitor setup being overridden by XFCE & theme missing.


I have the exact same problem. I use openSUSE 12.2 with XFCE 4.10, two nvidia graphic cards, four screens (Xinerama enabled) and screen 3 is always a clone of screen1.

I cannot run settings>hardware>display because I have no RandR support (due to Xinerama).

How can I disable this cloning? It worked perfectly for me with XFCE 4.8. I've tried different settings as to the position of the screens with nvidia-settings, but to no avail.  Running

xfconf-query -c displays -l

outputs nothing.

I'm not afraid of editing some config files, so if anybody has got a solution to this, please share...

(one dirty workaround to disable cloning is to disable composite (xorg.conf), but I would like to keep that enabled).




Board footer

Powered by FluxBB