Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-10-07 20:57:39

jejuba
Member
Registered: 2013-10-07
Posts: 10

[Solved] xfce4 and wmctrl

Dear all,

I would like to set a terminal as background image. I remember that some time ago (2 or 3 years maybe) i used to be able to, using xfce. However, i recently found out that wmctrl does not seem to work anymore with xfce4.

It would appear I am not the only one with this issue, but I have not found a way around it yet. For instance see at "http://forum.xfce.org/viewtopic.php?id=6874".

Is this me, or is it just not possible to use wmctrl?

for instance, when typing this line of code, the terminal window does not resize, nor does it position where it should:


xfce4-terminal --hide-menubar --hide-borders --hide-toolbars --title=descon && wmctrl -r descon -e 0,10,10,720,720

any help would be greatly appreciated,


thanks,

Offline

#2 2013-10-07 23:02:32

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,061

Re: [Solved] xfce4 and wmctrl

This thread over at the arch forums works for me. I used his simpler second script and added my parameters in at the top of the script. Also, note that I'm using 4.10 and if I want the terminal window to cover the whole screen, I have to check "Don't reserve space on borders" for each panel in the panel properties. You can do this with earlier versions of Xfce using xfconf-query to manage the struts property.

Offline

#3 2013-10-12 09:35:19

jejuba
Member
Registered: 2013-10-07
Posts: 10

Re: [Solved] xfce4 and wmctrl

thanks,

i have managed to get a terminal running with properties I wanted. However, I am still not able to start it on log-in.
I located the scripts into ~/scripts/
I added that directory to my path (at least echo $PATH shows the directory)
but it's not starting on log in
properties of the file are: -rwxr-xr-x

it is working if I execute it though

any idea?

Offline

#4 2013-10-12 12:50:37

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,061

Re: [Solved] xfce4 and wmctrl

Are you adding it to the list of startup apps (Settings Manager -> Session and startup -> Application Autostart)? If so, try setting the command with the full path to the executable:

/home/you/scripts/my_script .....

You might even want to try adding a small delay to the beginning of the script.

Offline

#5 2013-10-13 06:59:20

jejuba
Member
Registered: 2013-10-07
Posts: 10

Re: [Solved] xfce4 and wmctrl

OK thanks it worked. Just for me, which is the file that is modified by doing this? and of course where is it?

Offline

#6 2013-10-13 10:09:04

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,061

Re: [Solved] xfce4 and wmctrl

Look for a .desktop file in ~/.config/autostart that is the same name as you gave it when you created the autostart entry.

Offline

#7 2013-10-14 18:51:58

jejuba
Member
Registered: 2013-10-07
Posts: 10

Re: [Solved] xfce4 and wmctrl

thanks,

Offline

Board footer

Powered by FluxBB