Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-10-24 19:27:51

lw1471
Member
Registered: 2013-09-11
Posts: 10

nvidia-settings-rc issue

I'm using Debian 7 64 bit, Xfce 4.8.0.3, on a quad core AMD machine with the inbuilt nVidia graphics (7025). I've just switched to the proprietary driver but cannot get the nvidia-settings to stick. I'm wondering if there is a different procedure for Xfce. I've tried putting nvidia-settings --load-config-only in the Sessions and Startup > Applications Autostart using the same procedure I had used before for Redshift. I have my .nvidia-settings-rc file in my /home folder as generated by nvidia-settings. If I run nVidia-settings manually the colour alterations I chose finally happen, but there is no autostart for me so far.

Does .nvidia-settings-rc need to be made executable? (I am half aware of how to do this.) My rc file for Mutt just works when sitting in my /home folder without any chmod business so I'm assuming any rc file is the same?

I have tried rebooting with an .xinitrc file with the same command in, to no avail. If I merely put nvidia-settings in the Autostart box I do get my colours but of course the gui for nVidia-settings starts too.

I have googled of course, but all material I find involves Gnome and KDE. Often they're having, for example, exec gnome-session in an .xinitrc file but my desktop environment is starting via lightdm so I'm assuming the extra command is irrelevant.

Thanks for any help. Not keen to use the Debian forum because of the hairtrigger sociopathy there...

Last edited by lw1471 (2013-10-24 20:22:00)

Offline

#2 2013-10-24 20:34:50

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,040

Re: nvidia-settings-rc issue

In the Autostart box, try:

bash -c 'nvidia-settings --load-config-only'

If still not working, try squeezing in a delay:

bash -c 'sleep 1 && nvidia-settings --load-config-only'

...adjust the sleep value if necessary.

Offline

#3 2013-10-24 21:02:43

lw1471
Member
Registered: 2013-09-11
Posts: 10

Re: nvidia-settings-rc issue

Thanks for some input there, I was hopeful. That hasn't worked. What I did try was to try another window manager and use an .xinitrc file to see if it kicked in. I used DWM but I didn't get my colours. I don't feel like giving up yet but I may have to go back to using Redshift for the colours. I'm sure the driver is working because program windows are no longer jumpy as they were with the Nouveau driver, but obviously Redshift won't deal with other variables that nvidia-settings does. It seems this isn't an Xfce problem going by my little experiment, so I imagine it's not good to go on asking here, but if anyone should know a solution I'd be grateful. Presumably anyway Xfce ignores an .xinitrc file. (Still, an Autostart line beginning 'bash -c' was new knowledge for me, which is nice...)

Offline

#4 2013-10-24 22:21:10

Sideburns
Member
From: Camarillo, CA
Registered: 2011-03-30
Posts: 279
Website

Re: nvidia-settings-rc issue

One thing you need to know is that if you're using the binary drivers from nVidia, you'll have to boot into runlevel 3 and reinstall them after every kernel update.  Fedora has an easier, far more sane way of doing this (They've repackaged the driver and xorg support files into packages that can be updated along with the kernel, making it "fire and forget.") and Ubuntu will do the reinstall and reboot for you if you let it.  I don't know how, if at all, Debian handles this, but unless they've automated the process, you're going to have to remember to  do it yourself, and that brings up a question: have you been reinstalling the binary blob after every kernel update, or just assuming that it's been done for you?


Registered Linux user #470359
Permanently recovered BOFH
Any advice in this post is worth exactly what you paid for it.

Offline

#5 2013-10-25 08:43:07

lw1471
Member
Registered: 2013-09-11
Posts: 10

Re: nvidia-settings-rc issue

Yes Debian has something beginning with D to take care of this - is it dkns or something? I remember seeing this in the wiki anyway. I may move to Fedora Xfce anyway for various reasons.

Offline

#6 2013-10-25 17:27:10

poltiser
Member
Registered: 2011-05-14
Posts: 9

Re: nvidia-settings-rc issue

It would not make a difference as I tried and same settings for my NVIDIA 9500 GT card. Using linux from Debian trough Sabayone, Salix, Slack, Vector, Fedora, Centos... and xUbuntu different flavors (Mint as well) - there is no difference in graphic card performance - it is always set back automatically to its basic set of configuration. XFCE is fine but in almost 8 years with linux & NVIDIA I did not manage to permanently change settings of the card. I think it is NVIDIA driver which does not let you change anything. I have looked around for some instructions but whatever I tried did not work. I think somebody clever should write a script setting all possible parameters of the driver with explanation how it would look like on the screen. My way is to copy same xorg.config file for last 8 years - no matter which distro I am actually using. I hope you have more luck.
Regards.

Offline

Board footer

Powered by FluxBB