Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-03-15 16:34:04

Digby
Member
Registered: 2014-03-14
Posts: 3

[Solved] Keyboard layout: English (US, international with dead keys).

Hello,

I am using XFCE 4.8 with Debian Wheezy.

I like this setup but have one difficulty.

I cannot specify the keyboard layout variant: English (US, international with dead keys).

In Settings | Keyboard | (Layouts tab) the bottom  window allows keyboard layouts to be added.
There is also a column for "Variant" but it is always empty.

I don't mind editing conf files and have already found:
/etc/default/keyboard
which contains an empty XKBVARIANT="" parameter.
I have tried altering this to "intl" and lo and behold!
It works but only outside of XFCE (e.g. on say, terminal tty2)

As soon as I'm back in XFCE it doesn' t work anymore so presumably the
value I changed gets overridden... sad

If anyone could throw any light on this I would much appreciate it.
Meanwhile I'll just keep searching...

Thanks,

Dig.

Offline

#2 2014-03-15 21:13:20

Digby
Member
Registered: 2014-03-14
Posts: 3

Re: [Solved] Keyboard layout: English (US, international with dead keys).

It was a reference in the Arch Linux wiki which put me on to the answer:
"The most obvious and easiest way (to modify Xconf settings) is to go to "Settings" in the main menu and select the category you want to customize.
However, not all customization options are available this way.
Customization can be done completely from the command line using the program xfconf-query. See the XFCE online documentation. http://docs.xfce.org/xfce/xfconf/xfconf-query".
...and they're right. It's all there. Just a question of finding it smile.
Dig.

Offline

Board footer

Powered by FluxBB