Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-06-02 08:53:48

kkaranth
Member
Registered: 2014-06-02
Posts: 3

How to remove entries from sound menu

I am using XFCE v4.10 on Xubuntu 14.04.

When I open the sound menu in the Indicator plugin in the panel, I get the media controls for VLC, gmusicbrowser and banshee. I need to know how to remove these entries since I've uninstalled gmusicbrowser, use the notification area plugin for banshee, and generally have no need to control VLC via the sound menu.

Also, the "Sound Settings" option doesn't function. (Running pavucontrol from the terminal works however. So only the button in the sound menu is glitched)

Offline

#2 2014-06-02 10:41:18

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,135

Re: How to remove entries from sound menu

kkaranth wrote:

When I open the sound menu in the Indicator plugin in the panel, I get the media controls for VLC, gmusicbrowser and banshee. I need to know how to remove these entries since I've uninstalled gmusicbrowser, use the notification area plugin for banshee, and generally have no need to control VLC via the sound menu.

Install dconf-tools from the repositories then run:

dconf-editor

Traverse to com >> canonical >> indicator >> sound. There are two proprties there that you need to edit:

1. blacklisted media players -> add the ones you want blacklisted here in the format:

['gmusicbrowser','vlc']

2. interested-media-players -> remove gmusicbrowser and vlc from that list if they exist.

Also, the "Sound Settings" option doesn't function. (Running pavucontrol from the terminal works however. So only the button in the sound menu is glitched)

Might have to file a bug report at launchpad.net for this one. But first, open a terminal window and run:

tail -f ~/.cache/upstart/startxfce4.log

...and click on the "Sound Settings" button. Do any error messages appear in the terminal window?

You might also consider re-installing the indicator plugin:

sudo apt-get install --reinstall xfce4-indicator-plugin

...to see if that helps.

Offline

#3 2014-06-02 22:12:07

kkaranth
Member
Registered: 2014-06-02
Posts: 3

Re: How to remove entries from sound menu

Install dconf-tools from the repositories then run:
dconf-editor
Traverse to com >> canonical >> indicator >> sound. There are two proprties there that you need to edit:
1. blacklisted media players -> add the ones you want blacklisted here in the format:
['gmusicbrowser','vlc']
2. interested-media-players -> remove gmusicbrowser and vlc from that list if they exist.

The dconf-editor application got rid of gmusicbrowser. However, vlc and banshee still shows up in the sound menu whenever I use the respective applications(not otherwise). Its not an inconvenience as such, it is more of a redundancy since I use indicator plugin for my media controls.

Might have to file a bug report at launchpad.net for this one. But first, open a terminal window and run:
tail -f ~/.cache/upstart/startxfce4.log
...and click on the "Sound Settings" button. Do any error messages appear in the terminal window?
You might also consider re-installing the indicator plugin:
sudo apt-get install --reinstall xfce4-indicator-plugin
...to see if that helps.

No error messages appeared. Reinstall didn't cause normal functioning either. Probably a bug then.

Offline

#4 2014-06-02 22:45:55

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,135

Re: How to remove entries from sound menu

kkaranth wrote:

The dconf-editor application got rid of gmusicbrowser. However, vlc and banshee still shows up in the sound menu whenever I use the respective applications(not otherwise). Its not an inconvenience as such, it is more of a redundancy since I use indicator plugin for my media controls.

Hmmm, I can't replicate this on my system. vlc no longer shows up (whether its running or not). Can you post back the results of these commands (to show those dconf settings):

gsettings get com.canonical.indicator.sound blacklisted-media-players
gsettings get com.canonical.indicator.sound interested-media-players

Last edited by ToZ (2014-06-02 22:46:07)

Offline

#5 2014-06-03 20:44:05

kkaranth
Member
Registered: 2014-06-02
Posts: 3

Re: How to remove entries from sound menu

Here's the output:

$gsettings get com.canonical.indicator.sound interested-media-players
['banshee.desktop', 'vlc.desktop']
$ gsettings get com.canonical.indicator.sound interested-media-players
['banshee.desktop', 'vlc.desktop']

Everytime I remove the two from the interested-media-players list they get added again once I start the respective programs.

Offline

#6 2014-06-06 01:50:27

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,135

Re: How to remove entries from sound menu

You repeated the same command twice. What does the following one return?

gsettings get com.canonical.indicator.sound blacklisted-media-players

Offline

#7 2014-06-06 15:44:56

jsalpha2
Member
Registered: 2013-07-25
Posts: 12

Re: How to remove entries from sound menu

I just right clicked on the speaker and selected delete.  Then using the software manager I installed synaptic.  Then using synaptic I installed Xfce4 and Xfce4goodies and un-install gmusicbrowser.  Then I went back to the panel and selected panel preferences and added back the volume control.   When you click on the new volume icon it behaves normally.

Last edited by jsalpha2 (2014-06-06 15:45:26)

Offline

#8 2014-07-09 02:32:28

leomcsnarf
Member
Registered: 2014-07-07
Posts: 2

Re: How to remove entries from sound menu

I am able to get rid of the entries in the sound manager but they always come back. If i run pithos it makes the volume control disappear altogether. Annoying... this is the last little problem that I have with Xfce.

Offline

Board footer

Powered by FluxBB