Xfce Forum

Sub domains
 

You are not logged in.

#1 2015-02-17 17:56:41

electrovalent
Member
Registered: 2015-02-17
Posts: 2

Screen tearing

Hi to all.
I am experiencing screen tearing when i move windows and watching video.
Tested with three different machines (Laptop, Netbook, Desktop), with different graphic cards (Intel, NVidia).
Versions of XFCE: 4.8 through 4.10.1
Is there a fix for that.
Thank you

Offline

#2 2015-02-18 13:16:56

ungutknut
Member
Registered: 2014-04-12
Posts: 52

Re: Screen tearing

This is an issue that I have since I use XFCE (for several years now). There are some workarounds... most of them don't seem to do the job (at least for me) and with some graphics cards (amd with catalyst driver) I never managed to get rid of the screen tearing in xfce.

What seems to help:

)Turning off the compositor: Go to settings->window manager tweaks->compositor and uncheck "enable display compositing". There's also an option to "synchronize drawing to the vertical blank" in the compositor settings (window manager tweaks) that's supposed to eliminate tearing in some way if you want to use the compositor. I think this option is not available (or not working) in xfce 4.8 - so updating to a newer version could probably help (see launchpad link below).

)Using compton: this is the only way for me to eliminate tearing to a minimum (still there but almost good enough): http://ubuntuforums.org/showthread.php?t=2144468 Moving windows is a bit sluggish now but at least tearing is better.

)Using the nvidia driver instead of the nouveau driver and activate vsync in the driver settings. In case of amd/ati, the radeon driver worked better than catalyst in terms of vsync.

)Try using Display Port or HDMI or DVI... I had a case where tearing was worse with HDMI, so I switched to DP.

)New since xfwm 4.11.3: Activating compositor again and check "synchronize drawing to the vertical blank". It seems that turning the compositor off doesn't do the job anymore. Several nasty bugs have finally been fixed with 4.11.3 but it seems that tearing got worse again. So there's at least a chance that vsync gets even better with compositor on.

)Installing your graphics driver the right way. I had to re-install the nvidia-driver using this guide http://askubuntu.com/a/451248 until I did it the right way and tearing got better. Check if glxinfo and glxgears is working. Maybe the installing-issue just affects very newish nvidia cards (I use a gtx970) so you can probably just install it the normal way.

)edit: If compton doesn't work for you, you can also try compiz. I just tried it once and it was buggy as hell but people say it does quite well when it comes to vsync.

What distribution are you using? What graphics card? What's your display? Have you set the correct refresh-rate for your display?

If you're on ubuntu check this out:
https://launchpad.net/~xubuntu-dev/+arc … /xfce-4.12
(and read the ppa-description carefully!)

@devs: Is the XFCE-team actually aware of the tearing issue? I know several linux users that would like to use xfce, but some of them avoid it because of the tearing. Most threads I can find concerning tearing seem to relate to some old xfce-versions.

Last edited by ungutknut (2015-02-18 13:29:43)

Offline

#3 2015-02-18 20:51:56

sixsixfive
Member
From: behind you
Registered: 2012-04-08
Posts: 578
Website

Re: Screen tearing

afaik - it is not possible to run a x server without tearing - but you can reduce it by enabling vsync

Offline

#4 2015-02-19 17:56:06

electrovalent
Member
Registered: 2015-02-17
Posts: 2

Re: Screen tearing

ungutknut wrote:

This is an issue that I have since I use XFCE (for several years now). There are some workarounds... most of them don't seem to do the job (at least for me) and with some graphics cards (amd with catalyst driver) I never managed to get rid of the screen tearing in xfce.

What seems to help:

)Turning off the compositor: Go to settings->window manager tweaks->compositor and uncheck "enable display compositing". There's also an option to "synchronize drawing to the vertical blank" in the compositor settings (window manager tweaks) that's supposed to eliminate tearing in some way if you want to use the compositor. I think this option is not available (or not working) in xfce 4.8 - so updating to a newer version could probably help (see launchpad link below).

)Using compton: this is the only way for me to eliminate tearing to a minimum (still there but almost good enough): http://ubuntuforums.org/showthread.php?t=2144468 Moving windows is a bit sluggish now but at least tearing is better.

)Using the nvidia driver instead of the nouveau driver and activate vsync in the driver settings. In case of amd/ati, the radeon driver worked better than catalyst in terms of vsync.

)Try using Display Port or HDMI or DVI... I had a case where tearing was worse with HDMI, so I switched to DP.

)New since xfwm 4.11.3: Activating compositor again and check "synchronize drawing to the vertical blank". It seems that turning the compositor off doesn't do the job anymore. Several nasty bugs have finally been fixed with 4.11.3 but it seems that tearing got worse again. So there's at least a chance that vsync gets even better with compositor on.

)Installing your graphics driver the right way. I had to re-install the nvidia-driver using this guide http://askubuntu.com/a/451248 until I did it the right way and tearing got better. Check if glxinfo and glxgears is working. Maybe the installing-issue just affects very newish nvidia cards (I use a gtx970) so you can probably just install it the normal way.

)edit: If compton doesn't work for you, you can also try compiz. I just tried it once and it was buggy as hell but people say it does quite well when it comes to vsync.

What distribution are you using? What graphics card? What's your display? Have you set the correct refresh-rate for your display?

If you're on ubuntu check this out:
https://launchpad.net/~xubuntu-dev/+arc … /xfce-4.12
(and read the ppa-description carefully!)

@devs: Is the XFCE-team actually aware of the tearing issue? I know several linux users that would like to use xfce, but some of them avoid it because of the tearing. Most threads I can find concerning tearing seem to relate to some old xfce-versions.

It seems that you gather all the available workarounds for that smile. Thank you for your suggestions.
Unfortunately only compton makes the difference but not enough. On desktop i have a nvidia 9800GT but i try all combinations including drivers and settings with no success. Neither on laptops with intel GMA 4500.
OS tested are xubuntu 14.10, debian stable and debian testing.

Offline

#5 2015-02-23 20:47:29

lottin
Member
Registered: 2014-08-12
Posts: 9

Re: Screen tearing

If you use the X.org radeon driver (not the closed-source one) with the XFCE compositor the tearing problem goes away if you enable the EXAVSync option in your xorg.conf.

Offline

#6 2015-02-25 11:38:44

ungutknut
Member
Registered: 2014-04-12
Posts: 52

Re: Screen tearing

BTW, I just stubled across another thread about tearing-removal for XFCE:
https://forum.manjaro.org/index.php?topic=10840.0

Maybe give those tips a try?

Also a new nvidia-driver has been released recently; maybe they fixed something related to vsync?
http://www.phoronix.com/scan.php?page=n … nux-Driver

edit:

Unfortunately only compton makes the difference but not enough.

I've had a look at my .compton.conf and suddenly I remembered that I had to change it to make vsync better. Here are the lines that I've changed:

backend = "glx";
#paint-on-overlay = true;
#glx-no-stencil = true;
#glx-no-rebind-pixmap = true;
vsync = "opengl-swc"; 

(according to that ubuntuforum-link I posted before)

Maybe playing with those compton-settings a little bit will do the job for you. When I've had a look at the compton manual I found out that there's a load of options that influence vsync in some way or another.

Last edited by ungutknut (2015-02-25 11:51:52)

Offline

#7 2015-03-14 03:20:37

High Flier
Member
Registered: 2015-03-14
Posts: 3

Re: Screen tearing

Hey guys.

This is my first post here, I just installed linux for the first time ever. It's the newest Darla (Korora 21) using the XFCe desktop.

My machine is an HP Pavilion g6 laptop, i5, 4 gb RAM, Intel 4000 integrated graphics.

I'm getting an insane amount of screen tearing during video playback, and also while scrolling up and down webpages. This was never an issue for me under Windows 8.1, though I decided to go linux because of many other difficulties with Windows.

I know I'm brand new to linux, so I'm trying to keep an open mind, but I was kind of shocked to see this continuous tearing since videos and web browsing is all I use my system for, and XFCe is supposed to be uber-'light'. I already installed all current updates using the YUM expander and Pharlap. Oh, and another thing with Pharlap: one of the system packages it recommends I select and click "apply changes", but after a short loading period and a quick dialogue screen flashes by, it is still not checked as "loaded". It's one of the Intel Bus controllers or something. Can someone help me out, or should I just make this a new post?

-noob who would REALLY appreciate some help.

Last edited by High Flier (2015-03-14 03:21:43)

Offline

#8 2015-03-14 04:02:58

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,042

Re: Screen tearing

High Flier wrote:

This is my first post here, I just installed linux for the first time ever. It's the newest Darla (Korora 21) using the XFCe desktop.

My machine is an HP Pavilion g6 laptop, i5, 4 gb RAM, Intel 4000 integrated graphics.

I'm getting an insane amount of screen tearing during video playback, and also while scrolling up and down webpages. This was never an issue for me under Windows 8.1, though I decided to go linux because of many other difficulties with Windows.

When I typed "Korora 21 tearing" (sans quotation marks) into the Googlemonster, the very first result I got was titled "Intel Graphics screen tearing VLC - Korora Project" and its address was

https://kororaproject.org/support/engage/problem/intel-graphics-screen-tearing-vlc

...so perhaps you are not alone. Unfortunately, when I tried to visit that link, I was not able to access it.

Maybe you would find specific help at the Korora forum - if you can find it. According to Google, it is supposed to be at

https://kororaproject.org/forum/

but that is a "404 Error" page roll

The only thing I could find - and access, lol - that dealt with tearing on a system comparable to yours was this page:

https://kororaproject.org/support/engage/question/intel-graphics-screen-tearing-vlc

which appears to state that the issue is caused by using UXA acceleration instead of the newer SNA (or, possibly, vice versa; IDK) and at one point mentions making specific changes to your /etc/X11/xorg.conf.d/10-intel.conf file. Which might help. I don't really know, since I don't use that distro (or have noticeable tearing issues).

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#9 2015-03-14 04:31:40

High Flier
Member
Registered: 2015-03-14
Posts: 3

Re: Screen tearing

Many thanks for the quick response, friend.

In my VLC there's about 5 different options for hardware acceleration, I might as well start going through each one of those... Saw a comment where a guy said that 'totem' media player works for him, I YUM'd it and installed it but it's not showing up on my menu... Apparently it's only for GNOME and won't work on XFCe...

Yeah I noticed that on many linux sites their servers will go down every once in a while and pop back up in an hour or so. Maintenance or server load maybe? Can't blame 'em.

I loved DOS when I was younger, and used to know some Basic/C... But getting into the whole linux kernel/console is gonna take some work now hahaha.

I can't help but wonder... is it because my DE is 'lightweight' that I'm not even getting enough performance for smooth video? Should I bite the bullet and use Cinnamon? It's still not as heavy as Windows... But I heard some horror stories about its glitchiness...

Anyways I'll spare you my rambling, I need to get some sleep. I shall report to you tomorrow, good sir, in high hopes of busting through this problem by any means necessary. I know for sure that choppy video is not a linux thing, that would be impossible...

Last edited by High Flier (2015-03-14 04:32:56)

Offline

#10 2015-03-14 04:45:19

MountainDewManiac
Member
From: Where Mr. Bankruptcy is Prez
Registered: 2013-03-24
Posts: 1,042

Re: Screen tearing

High Flier wrote:

In my VLC there's about 5 different options for hardware acceleration, I might as well start going through each one of those.

I would guess that with a modern CPU and a lightweight DE, that hardware-accelerated graphics would not be an absolute requirement. In any event, if it were me experiencing your issue, I'd probably try copy&pasting that modification to the file in the link I posted first (after making a backup copy, of course, so that you can replace your edited copy if it doesn't solve your problem after rebooting).

High Flier wrote:

Saw a comment where a guy said that 'totem' media player works for him, I YUM'd it and installed it but it's not showing up on my menu... Apparently it's only for GNOME and won't work on XFCe.

I just ran a terminal and typed totem (I was too lazy to check in Synaptic Package Manager to see if it was installed) - it runs fine for me.

High Flier wrote:

Yeah I noticed that on many linux sites their servers will go down every once in a while and pop back up in an hour or so. Maintenance or server load maybe? Can't blame 'em.

IDK. I didn't get a server busy message or a long delay followed by a timeout; I got a KororaProject "Hmmmm, a 404?! ... I think we're lost. Please check the URL for any errors and try again, or let us know. Maybe click your heels three times and return Home." message along with one of those goofy penguin graphics. Maybe they no longer have a forum, lol?

High Flier wrote:

I can't help but wonder... is it because my DE is 'lightweight' that I'm not even getting enough performance for smooth video?

No, you've got that backwards.

High Flier wrote:

Should I bite the bullet and use Cinnamon?

On a system in which you're experiencing graphics issues, lol? <SHUDDERS> Last I heard, Cinnamon pretty much requires hardware-accelerated graphics just to run the desktop. That could be... interesting. (IMHO)

Regards,
MDM


Mountain Dew Maniac

How to Ask for Help <=== Click on this link

Offline

#11 2015-03-14 13:21:59

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,049

Re: Screen tearing

Just a few points to add here:

1. There is a "Synchronize drawing to the vertical blank" setting in Settings Manager >> Window Manager Tweaks >> Compositor tab. Does selecting that, and logging out and back in again, make a difference?

2. You can also specify a "TearFree" option in the X server configuration file. More information about this configuration file can be found here.

3. Some have had success using Compton instead of xfwm4 as the window manager when it comes to tearing. Search these forums for "Compton" to get more information.

Offline

#12 2015-03-14 14:45:56

sixsixfive
Member
From: behind you
Registered: 2012-04-08
Posts: 578
Website

Re: Screen tearing

ToZ wrote:

You can also specify a "TearFree" option in the X server configuration file

this works only with intel cards and you need to switch sna acceleration(>=sandy bridge, its also not available on the newer glamor)
Here is a list of options you can use with an intel card


another option as said, would be to use a wm/shell such as http://i.imgur.com/WfRfvT6.jpg (= to get rid of that (other ones would be, KWin, Muffin)

Offline

#13 2015-03-14 15:11:42

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 5,049

Re: Screen tearing

sixsixfive wrote:
ToZ wrote:

You can also specify a "TearFree" option in the X server configuration file

this works only with intel cards and you need to switch sna acceleration(>=sandy bridge, its also not available on the newer glamor)
Here is a list of options you can use with an intel card

Thanks for the links to the comprehensive list. I notice a "vsync" option. Do you know if this is enabled by default?

Offline

#14 2015-03-14 16:37:27

sixsixfive
Member
From: behind you
Registered: 2012-04-08
Posts: 578
Website

Re: Screen tearing

afaik no, its also one of those if options(disabled with some drivers/cards) eg if you use DRI extension you need to enable/disable it in your drirc

http://dri.freedesktop.org/wiki/Configu … astructure

Last edited by sixsixfive (2015-03-14 16:39:59)

Offline

#15 2015-03-14 20:48:16

High Flier
Member
Registered: 2015-03-14
Posts: 3

Re: Screen tearing

Just wanted to say I appreciate all the help I've gotten here.

Apparently I just jumped in with not enough preparation... I tried downloading 'compton' but I couldn't find it in the YUM interface, and the command script I found didn't work... Did some more messing around and just said "forget it, I'm gonna go ahead and try Cinnamon." Everything is running pretty much perfectly now. I haven't yet opened over a hundred tabs in my browser like I did in Windows 8.1, so I'm not sure yet how much overhead I have exactly, but I guess I'll cross that bridge when I get there.

Offline

#16 2015-03-18 15:39:58

stqn
Member
Registered: 2010-10-11
Posts: 174

Re: Screen tearing

I have used Compton for almost two years, first on my first gen Core i3 (Intel HD Graphics) and now on my GTX 660, and it has worked perfectly with Xfce and removes tearing everywhere (including videos and games).

Just disable Xfce’s compositor, then launch Compton like this (for example):

compton -c -f -o 1.0 -I 0.1 -O 0.1 -C -i 0.95 -z --vsync opengl-swc --paint-on-overlay --backend glx --shadow-exclude "! name~=''" -b --use-ewmh-active-win --glx-no-stencil

It might slow things a little bit if you are on an oldish integrated GPU, perhaps you’ll have to play with the options (like glx-no-stencil and paint-on-overlay; to be honest I have no idea what they do).

I can’t help with finding Compton for Fedora/Korora but I’m sure there’s a way to install it!

Offline

#17 2015-03-21 18:27:28

bremsstrahlung
Member
From: Central Europe
Registered: 2012-08-31
Posts: 9

Re: Screen tearing

Here are my two cents straigt from the wallet:

I've got an NVidia GeForce 520 GT with passive cooling and use the proprietary NVidia drivers. Enabling "sync to VBlank" in "NVidia Server Settings" -> "Open GL Settings" gets rid of tearing - but only when I disable compositing in XFCE.

Whilst working, I was not happy with continuously switching compositing on and off, but another setting solved the issue for me:

In xorg.conf, under section "screen", I added the option:

Option         "metamodes" "DVI-I-1: nvidia-auto-select { ForceCompositionPipeline = On }"

As a result, I'm finally able to have both compositing turned on and tearing-free videos on both Mplayer and Firefox with Flash plugin.

b.


Man's achievements rest upon the use of symbols - Alfred Korzybski

Offline

#18 2015-03-30 10:31:58

ungutknut
Member
Registered: 2014-04-12
Posts: 52

Re: Screen tearing

Good news!

Looks like the great Olivier Fourdan has implemented a new "vsync using OpenGL" option three days ago. Can't wait to test it in the next point release of xfwm (hope release cycle will be as fast as the last one).

http://git.xfce.org/xfce/xfwm4/commit/? … 4160f23d99

I'm really excited about this since I hate using compton (which has some negative side-effects on some video-applications and with dragging windows). If someone is eager enough to compile it by himselve It'd be nice to have some feedback.

Offline

#19 2015-07-31 05:37:39

axioma
Member
Registered: 2015-07-31
Posts: 1

Re: Screen tearing

What solved the screen tearing for me was replacing xfmw4 with xfmw4-git.
Not sure if the Git packages are available in all distros but it is in the Arch repository.

Offline

#20 2015-07-31 13:16:20

stqn
Member
Registered: 2010-10-11
Posts: 174

Re: Screen tearing

axioma wrote:

What solved the screen tearing for me was replacing xfmw4 with xfmw4-git.

Interesting! Looking at the git commits I see Olivier Fourdan has worked on tearing in Xfwm this year and GLX support has been added smile. Apparently it’s been working since June 15th (on nvidia).
I’ll keep on using compton anyway, I think… As long as it works. Or until the next stable Xfwm release on Gentoo.

Last edited by stqn (2015-07-31 13:17:47)

Offline

#21 2015-08-23 08:37:31

adrdown
Member
Registered: 2015-08-23
Posts: 1

Re: Screen tearing

Here at first tip below already solved the problem, thank @ungutknut !!!

ungutknut wrote:

Turning off the compositor: Go to settings->window manager tweaks->compositor and uncheck "enable display compositing". There's also an option to "synchronize drawing to the vertical blank" in the compositor settings (window manager tweaks) that's supposed to eliminate tearing in some way if you want to use the compositor. I think this option is not available (or not working) in xfce 4.8 - so updating to a newer version could probably help (see launchpad link below).

I'm using Korora 22 XFCE, I highly recommend it !!!

System:   Host:notesony Kernel: 4.1.5-200.fc22.x86_64 x86_64 (64 bit)
               Desktop: Xfce 4.12.3 Distro: Korora release 22 (Selina)
Machine: System: Sony product: VPCEE23EB v: C8001M2T
               Mobo: Sony model: VAIO Bios: Insyde v: R0210Z5 date: 03/02/2011
CPU:       Dual core AMD Athlon II P320 (-MCP-) speed/max: 1500/2100 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
               Display Server: Fedora X.org 117.2 drivers: ati,radeon (unloaded: fbdev,vesa)
               Resolution: 1366x768@59.97hz
               GLX Renderer: Gallium 0.4 on AMD RS880
               GLX Version: 3.0 Mesa 10.6.3 (git-ccef890)
Network:  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
               driver: r8169
              Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
               driver: ath9k
Drives:  HDD Total Size: 320.1GB (2.1% used)
Info:      Processes: 190 Uptime: 1:06 Memory: 1225.4/7727.9MB
           Client: Shell (bash) inxi: 2.2.25

Offline

#22 2016-01-03 01:49:45

Ikem
Member
Registered: 2016-01-03
Posts: 1

Re: Screen tearing

ungutknut wrote:

I hate using compton (which has some negative side-effects on some video-applications and with dragging windows).

I had that with VLC.

I had to open the ATI Catalyst Control Center and had to enable "Tear Free".

I had to edit the "compton.conf" and changing the line:

unredir-if-possible = true;

to

unredir-if-possible = false;

That fixed it for me.

Last edited by Ikem (2016-01-05 13:28:29)

Offline

#23 2016-03-11 16:46:48

FadedGrape
Member
Registered: 2016-03-10
Posts: 1

Re: Screen tearing

axioma wrote:

What solved the screen tearing for me to click here for phen375 and was replacing xfmw4 with xfmw4-git.
Not sure if the Git packages are available in all distros but it is in the Arch repository.

I tried that but it didn't work for me, so strange.

Last edited by FadedGrape (2017-01-15 10:04:32)

Offline

#24 2016-03-14 15:27:31

ungutknut
Member
Registered: 2014-04-12
Posts: 52

Re: Screen tearing

Ikem wrote:
ungutknut wrote:

I hate using compton (which has some negative side-effects on some video-applications and with dragging windows).

I had that with VLC.

I had to open the ATI Catalyst Control Center and had to enable "Tear Free".

For me it was the case with every windowed program. But I got this fixed as well after I changed the compton.conf to:

backend = "glx";
paint-on-overlay = true;
#glx-no-stencil = true;
#glx-no-rebind-pixmap = true;
vsync = "opengl"; 

Shadow and fading are disabled - but just because I don't want it... don't know if it affects tearing.

So for me the compton solution is almost perfect now - and it seems to be working with nvidia (GTX970, proprietary drivers) and ATI (R9 270, OSS drivers - but different parameters in compton.conf if I remember right).

Only downside at the moment is that it uses a small percentage of CPU power.

Offline

#25 2018-12-30 11:25:22

dowx
Member
Registered: 2018-12-29
Posts: 23

Re: Screen tearing

Anything changed in this subject or we still have to install Compton to solve tearing issue? I wasn't aware of this problem before because I used integrated Intel's graphics. Now I have only Nvidia 1060 without iGPU and tearing is just very bad when scrolling pages. Anything changed after 3 years? I tried turning vsync on in window manager's option - no results. Nvidia-390 drivers option vsync doesn't work too.

Last edited by dowx (2018-12-30 11:27:06)

Offline

Board footer

Powered by FluxBB