Xfce Forum

Sub domains
 

You are not logged in.

#1 2015-05-22 10:02:18

nomko
Member
From: The Netherlands
Registered: 2013-10-17
Posts: 36
Website

Caps lock: how to disable?

Hi,

Subject must be clear enough: how do i disable the CAPS lock under Xfce?
I just can't find the correct settings menu...

Any help will be very much appreciated!


My laptop:
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*128 GiB SSD/1 TB HDD

My Linux website!

Offline

#2 2015-05-22 10:19:12

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,435

Re: Caps lock: how to disable?

You would do that at the X Windows level. See: http://unix.stackexchange.com/questions … sabling-it.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2015-05-22 12:41:33

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 147

Re: Caps lock: how to disable?

I got this from soneone else, I forget who but it works for me.

For the Xfce Edition
Xfce was tricky to get working. While theoretically, adding the shell script (as shown above) to the list of Startup Applications should get it working, it doesn't in practice (version 4.6). Nevertheless, there is a solution.

1) Open the settings manager. To do this, go to Menu > Settings > Xfce 4 Settings Manager

2) Click the Keyboard selection

3) Click the Layout tab.

4) Verify that the checkbox labeled Use system defaults is checked.

xubuntu5) Open Thunar (the file manager), and view your home folder.

6) Select View > Show Hidden Files

7) Look for a file named .Xmodmap if it does not exist, create it. To create the file, right click an empty space in the folder, select Create Document > Empty File. Name the new file .Xmodmap

8) Open the file .Xmodmap with a text editor, like Mousepad. To do this, right click the file, and select Open With "Mousepad"

9) In the opened file, insert the following text:

remove Lock = Caps_Lock
keycode 66 = BackSpace

10) Save the file.

You will have to log out, and then log back in to see the change.

Notice that you can use this to change CapsLock to be any other key of your choice, but it would take some knowledge of what the codes for the keys are. If you wish to apply a different function to Backspace, first research what the key is called before assigning CapsLock the new value.

Offline

#4 2015-05-22 16:40:01

Mellowbob
Member
Registered: 2011-10-16
Posts: 99

Re: Caps lock: how to disable?

There is something wrong with either ubuntu or xfce4. As I pointed out in another thread https://forum.xfce.org/viewtopic.php?id=9611 it's relatively easy to change the keyboard settings. But, at least on my system, the settings don't stick.

Some other application seems to be resetting my keyboard so that capslock works sad

Offline

#5 2015-05-22 21:20:33

nomko
Member
From: The Netherlands
Registered: 2013-10-17
Posts: 36
Website

Re: Caps lock: how to disable?

I'm running Linux Mint 17.1. Not Ubuntu. Does that make any difference?


My laptop:
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*128 GiB SSD/1 TB HDD

My Linux website!

Offline

#6 2015-05-23 19:08:49

nomko
Member
From: The Netherlands
Registered: 2013-10-17
Posts: 36
Website

Re: Caps lock: how to disable?

cmcanulty wrote:

I got this from soneone else, I forget who but it works for me.

For the Xfce Edition
Xfce was tricky to get working. While theoretically, adding the shell script (as shown above) to the list of Startup Applications should get it working, it doesn't in practice (version 4.6). Nevertheless, there is a solution.

Sorry to say but this didn't worked for me.


My laptop:
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*128 GiB SSD/1 TB HDD

My Linux website!

Offline

#7 2015-06-09 16:18:32

MekkaGodzilla
Member
Registered: 2011-03-05
Posts: 9

Re: Caps lock: how to disable?

If you have trouble with the .Xmodmap file not being applied, it might be caused by lightdm if it is set to autologin.

Do you have to type your password before getting to your desktop or not?

Offline

#8 2015-06-09 22:24:59

cmcanulty
Member
From: Beulah, Michigan
Registered: 2014-05-10
Posts: 147

Re: Caps lock: how to disable?

no I have it set to auto login

Offline

#9 2015-06-10 11:10:22

nomko
Member
From: The Netherlands
Registered: 2013-10-17
Posts: 36
Website

Re: Caps lock: how to disable?

MekkaGodzilla wrote:

If you have trouble with the .Xmodmap file not being applied, it might be caused by lightdm if it is set to autologin.

Do you have to type your password before getting to your desktop or not?

I have my login set up in such way that i do need to fill in my password.

Last edited by nomko (2015-06-10 11:10:53)


My laptop:
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*128 GiB SSD/1 TB HDD

My Linux website!

Offline

#10 2015-06-14 23:44:18

gargamon
Member
Registered: 2015-06-14
Posts: 1

Re: Caps lock: how to disable?

I struggled with this one for a long time and finally found the answer a couple of years ago. My laptop died and I'm configuring the new one and needed the solution again and found this thread.

The answer was to remove an xfce keyboard module. I believe it was xfce4-xkb-plugin. It will also automatically remove xfce4-goodies, but that's only a placeholder. All the other goodies remain.

I've removed it and did the .Xmodmap changes above but only time will tell if it's permanent.

If this is the right module to remove maybe somebody should write a bug report on xfce4-xkb-plugin. This issue has been around for years.

Edit: I checked my debian desktop and I had also added a command to applications/settings and startup/application autostart. The command I added was: setxkbmap -option caps:none

I believe this was needed because the .Xmodmap change above only affects shell commands.

Last edited by gargamon (2015-06-15 10:12:57)

Offline

#11 2015-06-15 14:24:33

nomko
Member
From: The Netherlands
Registered: 2013-10-17
Posts: 36
Website

Re: Caps lock: how to disable?

gargamon wrote:

I struggled with this one for a long time and finally found the answer a couple of years ago. My laptop died and I'm configuring the new one and needed the solution again and found this thread.
(..........)
I believe this was needed because the .Xmodmap change above only affects shell commands.

Good thinking! I'll try this solution!


My laptop:
MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*128 GiB SSD/1 TB HDD

My Linux website!

Offline

#12 2016-10-25 21:03:46

ukw
Member
Registered: 2016-10-25
Posts: 1

Re: Caps lock: how to disable?

Hey  - are you serious? is there no option to disable the Capslock?

Its not a bug its a reason to run rm -r

any suggestions?

Offline

#13 2016-10-25 22:19:41

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,435

Re: Caps lock: how to disable?

Try creating the file 10-nocaps.conf with the following content:

Section "InputClass"
        Identifier             "keyboard-layout"
        MatchIsKeyboard        "on"
        Option "XkbOptions"    "ctrl:nocaps"
EndSection

...and place it in either /etc/X11/xorg.conf.d or /usr/share/X11/xorg.conf.d (depending on which folder your distro uses) and log out and back in again to test.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#14 2017-01-18 23:10:15

utu
Member
From: Columbia MD USA
Registered: 2017-01-18
Posts: 2

Re: Caps lock: how to disable?

I'm using Xubuntu 16.10 using Xfce4 and very pleased with this desktop.

Regarding nomko's original caps_lock question...
I use Xfce4's Session & Startup GUI to tweak a few things on my laptop.
The nocaps approach can easily be set up this way.

I hope the indicated png indicates how this may be done.
https://postimg.org/image/vm7vbujv9/17848f51/


64-bit Xubuntu 16.10 LiveUSB on Win-7-era Dell 1545 Inspiron laptop

Offline

Board footer

Powered by FluxBB