Xfce Forum

Sub domains
 

You are not logged in.

#1 2006-07-31 08:26:46

cwwilson721
Member
Registered: 2006-07-31
Posts: 3

Error while compiling exo

I am getting the following error when trying to configure exo for xfce 4.4:

checking for perl5... no
checking for perl... perl
checking for perl module URI::Escape... no
checking for perl module URI::file... no
checking for perl module URI::URL... no
configure: error: Atleast one of the required Perl modules (URI::Escape, URI::file and URI::URL) was not found on your system

Looks like I need those perl modules.
Where do I get them?
How do I install them?

Running Slackware -current

Offline

#2 2006-07-31 16:31:19

cwwilson721
Member
Registered: 2006-07-31
Posts: 3

Re: Error while compiling exo

Nevermind. Got the perl modules and installed them, compiled exo, and it works.

Offline

#3 2006-08-05 21:31:51

gras
Member
From: Germany
Registered: 2005-10-30
Posts: 33
Website

Re: Error while compiling exo


[img]http://www.us.debian.org/logos/button-mini.png[/img]

Offline

#4 2006-08-12 21:28:49

masa
Member
Registered: 2006-01-03
Posts: 2

Re: Error while compiling exo

hi. i have follow problem with exo

Making all in reference
make[3]: Entering directory `/usr/src/xfce4/trunk/libexo/docs/reference'
xsltproc -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl exo-csource.xml
warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
cannot parse http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
make[3]: *** [exo-csource.1] Error 4
make[3]: Leaving directory `/usr/src/xfce4/trunk/libexo/docs/reference'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/xfce4/trunk/libexo/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/xfce4/trunk/libexo'
make: *** [all] Error 2

what's this?

system: slackware-current

Offline

#5 2006-08-12 22:32:28

masa
Member
Registered: 2006-01-03
Posts: 2

Re: Error while compiling exo

old version compiling successful, but in this case i see it while compiling thunar

*** The required package exo-0.3 was found on your system,
*** but the installed version (0.3.1.8beta2) is too old.
*** Please upgrade exo-0.3 to atleast version 0.3.1.9, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.

any suggestion?

UPD: i copy reference dir from older version and compile with it. it works for me smile

Offline

#6 2006-09-01 12:39:06

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: Error while compiling exo

http://thunar.xfce.org/download.html and download the latest version.

Offline

Board footer

Powered by FluxBB