Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-01-23 16:36:33

mail693070
Member
Registered: 2007-01-23
Posts: 3

can't install on ubuntu edgy

Tried to install 4.4, got this error:

HI -- Trying to upgrade to feisty. but update manager gives error "Authentication error" after clicking upgrade button.  What can I do?

$ sudo ./xfce4-4.4.0-installer.run
Password:
Verifying file integrity... OK.
Extracting the installer... OK.
Checking for usable C compiler... gcc
Checking for usable C++ compiler... g++
Checking for GNU make... make
Checking for package config tool... pkg-config
Checking for GLib (GModule) >= 2.6.0... not found, see /home/jerryb1/.xfce4.installer-log for details
Cleaning up... OK.

Here's the log:

## Started installation of xfce4 at 11:00h
##
## Visit http://forum.xfce.org/ if you have problems using this installer.
##

# Environment variables
PATH is set to "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/bin:/usr/bin:/usr/local/ssl/bin:/usr/local/bin:/opt/openssl/bin:/usr/local/openssl/bin:/usr/pkg/bin:/usr/ucb:/usr/X11R6/bin:/usr/X11R6/bin:/usr/openwin/bin:/usr/local/bin:/opt/local/bin:/usr/pkg/bin:/opt/gnome2/bin:/opt/gnome/bin:/opt/xfce4/bin:/opt/xfce/bin:/home/jerryb1/local/bin:/home/jerryb1/xfce/bin:/home/jerryb1/xfce4/bin"
PKG_CONFIG_PATH is set to ":/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:/usr/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/local/lib/pkgconfig"

## Checking for usable C compiler
gcc --version
gcc (GCC) 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## Checking for usable C++ compiler
g++ --version
g++ (GCC) 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## Checking for GNU make
gmake --version
make --version
GNU Make 3.81
Copyright (C) 2006  Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

This program built for i486-pc-linux-gnu

## Checking for package config tool
pkg-config --version
0.20

## Checking for GLib (GModule) >= 2.6.0
pkg-config --atleast-version=2.6.0 glib-2.0 gmodule-2.0
!! Please install GLib 2.6.0 or above and the GLib development files. It is
!! important that you install GModule, which is part of GLib as well. GLib
!! can be downloaded from http://www.gtk.org/.


Here's the debug output of pkg-config:

$ pkg-config --debug --atleast-version=2.6.0 glib-2.0 gmodule-2.0q
Option --debug seen
Option --atleast-version seen
Error printing disabled by default, value of --print-errors: 0
Error printing disabled
Adding virtual 'pkg-config' package to list of known packages
Scanning directory '/usr/local/lib/pkgconfig'
Ignoring file '.' in search directory; not a .pc file
Ignoring file '..' in search directory; not a .pc file
File 'glib-2.0.pc' appears to be a .pc file
Will find package 'glib-2.0' in file '/usr/local/lib/pkgconfig/glib-2.0.pc'
File 'gmodule-2.0.pc' appears to be a .pc file
Will find package 'gmodule-2.0' in file '/usr/local/lib/pkgconfig/gmodule-2.0.pc'
File 'gthread-2.0.pc' appears to be a .pc file
Will find package 'gthread-2.0' in file '/usr/local/lib/pkgconfig/gthread-2.0.pc'
File 'gobject-2.0.pc' appears to be a .pc file
Will find package 'gobject-2.0' in file '/usr/local/lib/pkgconfig/gobject-2.0.pc'
Cannot open directory '/usr/local/lib/pkgconfig/i486-linux-gnu' in package search path: No such file or directory
Cannot open directory '/usr/local/share/pkgconfig' in package search path: No such file or directory
Scanning directory '/usr/lib/pkgconfig'
Ignoring file '.' in search directory; not a .pc file
Ignoring file '..' in search directory; not a .pc file
File 'gnome-mime-data-2.0.pc' appears to be a .pc file
Will find package 'gnome-mime-data-2.0' in file '/usr/lib/pkgconfig/gnome-mime-data-2.0.pc'
File 'deskbar-applet.pc' appears to be a .pc file
Will find package 'deskbar-applet' in file '/usr/lib/pkgconfig/deskbar-applet.pc'
File 'xml2po.pc' appears to be a .pc file
Will find package 'xml2po' in file '/usr/lib/pkgconfig/xml2po.pc'
File 'glib-2.0.pc' appears to be a .pc file
File 'glib-2.0.pc' ignored, we already know about package 'glib-2.0'
File 'glib-sharp-2.0.pc' appears to be a .pc file
Will find package 'glib-sharp-2.0' in file '/usr/lib/pkgconfig/glib-sharp-2.0.pc'
File 'gmime-sharp.pc' appears to be a .pc file
Will find package 'gmime-sharp' in file '/usr/lib/pkgconfig/gmime-sharp.pc'
File 'gmodule-no-export-2.0.pc' appears to be a .pc file
Will find package 'gmodule-no-export-2.0' in file '/usr/lib/pkgconfig/gmodule-no-export-2.0.pc'
File 'gst-python-0.10.pc' appears to be a .pc file
Will find package 'gst-python-0.10' in file '/usr/lib/pkgconfig/gst-python-0.10.pc'
File 'fontutil.pc' appears to be a .pc file
Will find package 'fontutil' in file '/usr/lib/pkgconfig/fontutil.pc'
File 'dbus-sharp.pc' appears to be a .pc file
Will find package 'dbus-sharp' in file '/usr/lib/pkgconfig/dbus-sharp.pc'
File 'tomboy-plugins.pc' appears to be a .pc file
Will find package 'tomboy-plugins' in file '/usr/lib/pkgconfig/tomboy-plugins.pc'
File 'mono-cairo.pc' appears to be a .pc file
Will find package 'mono-cairo' in file '/usr/lib/pkgconfig/mono-cairo.pc'
File 'gnome-doc-utils.pc' appears to be a .pc file
Will find package 'gnome-doc-utils' in file '/usr/lib/pkgconfig/gnome-doc-utils.pc'
File 'gnome-sharp-2.0.pc' appears to be a .pc file
Will find package 'gnome-sharp-2.0' in file '/usr/lib/pkgconfig/gnome-sharp-2.0.pc'
File 'gmodule-export-2.0.pc' appears to be a .pc file
Will find package 'gmodule-export-2.0' in file '/usr/lib/pkgconfig/gmodule-export-2.0.pc'
File 'gtkhtml-sharp-2.0.pc' appears to be a .pc file
Will find package 'gtkhtml-sharp-2.0' in file '/usr/lib/pkgconfig/gtkhtml-sharp-2.0.pc'
File 'gnome-vfs-sharp-2.0.pc' appears to be a .pc file
Will find package 'gnome-vfs-sharp-2.0' in file '/usr/lib/pkgconfig/gnome-vfs-sharp-2.0.pc'
File 'gok-1.0.pc' appears to be a .pc file
Will find package 'gok-1.0' in file '/usr/lib/pkgconfig/gok-1.0.pc'
File 'art-sharp-2.0.pc' appears to be a .pc file
Will find package 'art-sharp-2.0' in file '/usr/lib/pkgconfig/art-sharp-2.0.pc'
File 'gtk-dotnet-2.0.pc' appears to be a .pc file
Will find package 'gtk-dotnet-2.0' in file '/usr/lib/pkgconfig/gtk-dotnet-2.0.pc'
File 'rsvg-sharp-2.0.pc' appears to be a .pc file
Will find package 'rsvg-sharp-2.0' in file '/usr/lib/pkgconfig/rsvg-sharp-2.0.pc'
File 'gmodule-2.0.pc' appears to be a .pc file
File 'gmodule-2.0.pc' ignored, we already know about package 'gmodule-2.0'
Ignoring file 'python2.4' in search directory; not a .pc file
Ignoring file 'python2.5' in search directory; not a .pc file
File 'shared-mime-info.pc' appears to be a .pc file
Will find package 'shared-mime-info' in file '/usr/lib/pkgconfig/shared-mime-info.pc'
File 'glade-sharp-2.0.pc' appears to be a .pc file
Will find package 'glade-sharp-2.0' in file '/usr/lib/pkgconfig/glade-sharp-2.0.pc'
File 'gnome-screensaver.pc' appears to be a .pc file
Will find package 'gnome-screensaver' in file '/usr/lib/pkgconfig/gnome-screensaver.pc'
File 'gthread-2.0.pc' appears to be a .pc file
File 'gthread-2.0.pc' ignored, we already know about package 'gthread-2.0'
File 'gnome-system-tools.pc' appears to be a .pc file
Will find package 'gnome-system-tools' in file '/usr/lib/pkgconfig/gnome-system-tools.pc'
File 'gconf-sharp-2.0.pc' appears to be a .pc file
Will find package 'gconf-sharp-2.0' in file '/usr/lib/pkgconfig/gconf-sharp-2.0.pc'
File 'gtk-sharp-2.0.pc' appears to be a .pc file
Will find package 'gtk-sharp-2.0' in file '/usr/lib/pkgconfig/gtk-sharp-2.0.pc'
File 'xbitmaps.pc' appears to be a .pc file
Will find package 'xbitmaps' in file '/usr/lib/pkgconfig/xbitmaps.pc'
File 'gdict-1.0.pc' appears to be a .pc file
Will find package 'gdict-1.0' in file '/usr/lib/pkgconfig/gdict-1.0.pc'
File 'gst-python-0.8.pc' appears to be a .pc file
Will find package 'gst-python-0.8' in file '/usr/lib/pkgconfig/gst-python-0.8.pc'
File 'gnopernicus-1.0.pc' appears to be a .pc file
Will find package 'gnopernicus-1.0' in file '/usr/lib/pkgconfig/gnopernicus-1.0.pc'
File 'gobject-2.0.pc' appears to be a .pc file
File 'gobject-2.0.pc' ignored, we already know about package 'gobject-2.0'
Cannot open directory '/usr/lib/pkgconfig/i486-linux-gnu' in package search path: No such file or directory
Scanning directory '/usr/share/pkgconfig'
Ignoring file '.' in search directory; not a .pc file
Ignoring file '..' in search directory; not a .pc file
File 'gnome-icon-theme.pc' appears to be a .pc file
Will find package 'gnome-icon-theme' in file '/usr/share/pkgconfig/gnome-icon-theme.pc'
File 'iso-codes.pc' appears to be a .pc file
Will find package 'iso-codes' in file '/usr/share/pkgconfig/iso-codes.pc'
Looking for package 'glib-2.0'
Looking for package 'glib-2.0-uninstalled'
Reading 'glib-2.0' from file '/usr/local/lib/pkgconfig/glib-2.0.pc'
Parsing package file '/usr/local/lib/pkgconfig/glib-2.0.pc'
  line>prefix=/usr/local
Variable declaration, 'prefix' has value '/usr/local'
  line>exec_prefix=${prefix}
Variable declaration, 'exec_prefix' has value '/usr/local'
  line>libdir=${exec_prefix}/lib
Variable declaration, 'libdir' has value '/usr/local/lib'
  line>includedir=${prefix}/include
Variable declaration, 'includedir' has value '/usr/local/include'
  line>
  line>glib_genmarshal=glib-genmarshal
Variable declaration, 'glib_genmarshal' has value 'glib-genmarshal'
  line>gobject_query=gobject-query
Variable declaration, 'gobject_query' has value 'gobject-query'
  line>glib_mkenums=glib-mkenums
Variable declaration, 'glib_mkenums' has value 'glib-mkenums'
  line>
  line>Name: GLib
  line>Description: C Utility Library
  line>Version: 2.2.0
  line>Libs: -L${libdir} -lglib-2.0   
  line>Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include
  line>
Path position of 'GLib' is 1
Adding 'glib-2.0' to list of known packages, returning as package 'glib-2.0'
Looking for package 'gmodule-2.0q'
Looking for package 'gmodule-2.0q-uninstalled'
Looking for 'gmodule-2.0q' using legacy -config scripts
Calling gnome-config


Here's what I have installed for glib:

aptitude search glib
p   bglibs-dev                      - BG Libraries Collection                   
p   bglibs-doc                      - BG Libraries Collection (documentation)   
v   glibc-2.3.5-3                   -                                           
v   glibc-2.3.6-2                   -                                           
p   glibc-doc                       - GNU C Library: Documentation             
p   glibc-doc-reference             - GNU C Library: Documentation             
v   glibc-pic                       -                                           
p   guile-gnome0-glib               - Guile bindings for GLib                   
p   libarts1-mpeglib                - mpeglib plugin for aRts, supporting mp3 an
p   libavahi-glib-dev               - Development headers for the Avahi glib int
i   libavahi-glib1                  - Avahi glib integration library           
c   libdbus-glib-1-1                - simple interprocess messaging system (GLib
i   libdbus-glib-1-2                - simple interprocess messaging system (GLib
p   libdbus-glib-1-dev              - simple interprocess messaging system (GLib
p   libg++2.8.1.3-glibc2.2          - The GNU C++ extension library - runtime ve
p   libglib-cil                     - CLI binding for the GLib utility library 
v   libglib-dev                     -                                           
p   libglib-java                    - GLIB bindings for Java                   
p   libglib-java-doc                - GLIB bindings for Java (API documentation)
p   libglib-java-gcj                - GLIB bindings for Java (native code for us
i   libglib-perl                    - Perl interface to the GLib and GObject lib
v   libglib1.1-dev                  -                                           
i   libglib1.2                      - The GLib library of C routines           
p   libglib1.2-dbg                  - GLib libraries and debugging symbols     
p   libglib1.2-dev                  - Development files for GLib library       
p   libglib1.2-doc                  - Documentation files for the GLib library v
p   libglib2-ruby                   - Glib 2 bindings for the Ruby language     
i   libglib2.0-0                    - The GLib library of C routines           
p   libglib2.0-0-dbg                - The GLib libraries and debugging symbols 
i   libglib2.0-cil                  - CLI binding for the GLib utility library 2
i   libglib2.0-data                 - Common files for GLib library             
i   libglib2.0-dev                  - Development files for the GLib library   
p   libglib2.0-doc                  - Documentation files for the GLib library 
p   libglibmm-2.4-1c2a              - C++ wrapper for the GLib toolkit (shared l
p   libglibmm-2.4-dev               - C++ wrapper for the GLib toolkit (developm
p   libmissinglib-ocaml-dev         - Library of utility functions for OCaml   
p   libnm-glib-dev                  - network management framework (GLib interfa
p   libnm-glib0                     - network management framework (GLib shared
p   libpoppler-glib-dev             - PDF rendering library -- development files
i   libpoppler0c2-glib              - PDF rendering library (GLib-based shared l
i   libpoppler1-glib                - PDF rendering library (GLib-based shared l
p   libsofia-sip-ua-glib-dev        - Sofia-SIP library glib/gobject interface d
p   libsofia-sip-ua-glib0           - Sofia-SIP library glib/gobject interfaces
p   libstdc++2.10-glibc2.2          - The GNU stdc++ library                   
p   mpeglib                         - mp3 and mpeg I audio and video library

Offline

#2 2007-01-23 18:10:40

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: can't install on ubuntu edgy

There are no errors in the log, so can you post the exact warning? You can also try to uninstall the old version and then install a fresh one.

Offline

#3 2007-01-23 20:50:42

mail693070
Member
Registered: 2007-01-23
Posts: 3

Re: can't install on ubuntu edgy

I posted the exact contents of the log.  The crucial error messages are:

Checking for GLib (GModule) >= 2.6.0... not found, see /home/jerryb1/.xfce4.installer-log for details

and from the log:

!! Please install GLib 2.6.0 or above and the GLib development files. It is
!! important that you install GModule, which is part of GLib as well. GLib
!! can be downloaded from http://www.gtk.org/.


BTW this is the first time I have attempted to install xfce on this particular machine

Offline

#4 2007-01-23 21:47:33

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: can't install on ubuntu edgy

Mm missed that, well do you have the gtk and gtk-devel package?

Offline

#5 2007-01-24 14:58:10

mail693070
Member
Registered: 2007-01-23
Posts: 3

Re: can't install on ubuntu edgy

I have gtk, but not gtk-devel since it isn't listed in the dependencies at

http://www.xfce.org/documentation/requirements

Offline

#6 2007-01-24 17:50:21

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,143
Website

Re: can't install on ubuntu edgy

Well you need the devel package when you compile the desktop environment, you need ALL the devel packages from the packages on the requirements page, because else pkg-config can't find it...

Offline

Board footer

Powered by FluxBB