Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-02-06 18:56:04

Pindakoe
Member
From: NL
Registered: 2003-11-26
Posts: 110

Notification-daemon-xfce-0.3.6 (4.4.0) conflicts with version of RC2?) [SOLVED]

I cannot completely upgrade from RC2 (4.3.99.2) to 4.4.0 final -- my package manager (urpmi; I run mandriva) refuses to install these two packages:

libnotify1-0.4.3-2mdv2007.0.i586
notification-daemon-xfce-0.3.6-5mdv2007.0.i586

The error message is that notification-daemon-xfce (version 0.3.5) conflicts with notification-daemon-xfce-0.3.6-5mdv2007.0.i586. The 0.3.5 version of teh package came with 4.3.99.2; the 0.3.6 came with 4.4.0. A number of key gnome applications (evolution, gdm) depend on notification-daemon-0.3.5.

Is this a packaging error, or is 0.3.6 truely different from 0.3.5? Thanks for any insights.

Offline

#2 2007-02-06 18:59:53

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: Notification-daemon-xfce-0.3.6 (4.4.0) conflicts with version of RC2?) [SOLVED]

I did some renaming of the binaries in 0.3.6, but that was to avoid conflicts. Btw you only need 1 daemon (or the gnome or the Xfce one), the real application dependency is libnotify.

Offline

#3 2007-02-07 20:09:14

Pindakoe
Member
From: NL
Registered: 2003-11-26
Posts: 110

Re: Notification-daemon-xfce-0.3.6 (4.4.0) conflicts with version of RC2?) [SOLVED]

Thanks Nick. I have got libnotify1-0.4.2 installed (cannot install libnotify1-0.4.3.2 as that requires notification-daemon-xfce-0.3.6 which concflicts with notification-daemon-0.3.5).

Could this lead to problems with auto-mouting of USB-keys and/or CD's? I notice that with 4.4.0 tehse do not automatically mount, whereas 4.4.RC2 auto-mounted (at least) USB keys without problem (open, thunar, click on Icon which appears in Thunar shortcuts and you'll see all files). Now I get the following message instead:

Failed to mount "sda1".
exo-mount: Cannot mount by HAL device UDI, because HAL support was disabled for this build.

Have been seraching for help, found these posts but am none the wiser.

Offline

#4 2007-02-07 21:18:08

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: Notification-daemon-xfce-0.3.6 (4.4.0) conflicts with version of RC2?) [SOLVED]

If you get a notification, one of the 2 daemons in running, which is good enough. The notifications have nothing to do with the mount part of exo, it's an optional option.

And the warning is quite obvious: hal support was not enabled or no hal devel package was found during the configure stage of exo. (So you probably don't have the libexo-hal.so library.

Offline

#5 2007-02-08 18:16:52

Pindakoe
Member
From: NL
Registered: 2003-11-26
Posts: 110

Re: Notification-daemon-xfce-0.3.6 (4.4.0) conflicts with version of RC2?) [SOLVED]

I do have /usr/lib/libexo-hal-0.3.so.0 and /usr/lib/libexo-hal-0.3.so.0.4.0. These come from libexo, versions 0.3.1.8 and 0.3.2. My guess is that the the 0.3.2 version was built differently than the 0.3.1.8 version -- such is progress (and the concept of building from source is becoming another step more attractive, may be this is the time to check the Os-cillation installer). Will do some further digging and probably file a report with Mandriva

Offline

#6 2007-02-08 18:46:13

Pindakoe
Member
From: NL
Registered: 2003-11-26
Posts: 110

Re: Notification-daemon-xfce-0.3.6 (4.4.0) conflicts with version of RC2?) [SOLVED]

Got it!

I replaced the folowing packages from Mandriva's standard install by the ones prepared by Charles Edwards:

  • thunar-0.8.0

  • libthunar1_2-0.8.0

  • exo-0.3.2

  • libexo-0.3_0

These packages apparently have been compiled with HAL support; clicking on the USB-key icon mounts it (provided a directory /mnt/key exists, but that is something I can fix). Note that just replacing exo and libexo was [i]not/i] sufficient.

Offline

Board footer

Powered by FluxBB