Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-03-16 18:00:33

jorgynh0
Member
Registered: 2007-03-10
Posts: 4

Cups doesn't appear in Xfprint selection of print system

Since I've upgrade my Xfce Desktop to 4.4 the CUPS printing system has dissapeared from the selection menu of print system.

I only can select: None or BSD-LPR.

In Xfce 4 I had CUPS selectes and my printer worked fine.

I've read in Xfce documentation about a Configuration Information:

" Configuration Information
--enable-cups / --disable-cups: enable or disable support for CUPS."

But I don't know how to enable it (if it's what I need to do...).

I'm new on Xubuntu and Xfce, so I'd be granted if someone could help me.

Thanks in advance.

Offline

#2 2007-03-25 18:52:30

MagnusBerg
Member
Registered: 2004-12-17
Posts: 44

Re: Cups doesn't appear in Xfprint selection of print system

The xfprint4 application allows the user to print files of many different types and to set the printing options. For this it makes use of the a2ps application.

Offline

#3 2007-03-26 02:16:22

RGRagosta
Member
From: Virginia, USA
Registered: 2004-05-09
Posts: 12

Re: Cups doesn't appear in Xfprint selection of print system

Had the same "missing" CUPS option a while back in my numerous Xfce upgrades. One thing which DID consistently solve this issue was- make sure that you have the "libcups" devel package installed and with proper library pathing...


Mageia 3 / Xce 4.10
"Which is better- Artificial intelligence or REAL stupidity...?"

Offline

#4 2007-03-26 16:19:14

MagnusBerg
Member
Registered: 2004-12-17
Posts: 44

Re: Cups doesn't appear in Xfprint selection of print system

You compile your Xfce4 package yourself becuase you need the libcups dev package. Don't you???

Offline

#5 2007-03-26 18:41:32

RGRagosta
Member
From: Virginia, USA
Registered: 2004-05-09
Posts: 12

Re: Cups doesn't appear in Xfprint selection of print system

MagnusBerg wrote:

You compile your Xfce4 package yourself becuase you need the libcups dev package. Don't you???

Well actually I don't really directly compile from source code myself, rather I have used the Binary Installer approach in my last few Xfce version upgrades.

Since my preferred base System is Mandriva, there just wasn't really any up-to-date RPMs out there for the latest Xfce version releases. Using the Binary Installer method, I soon discovered that there are definite implicit dependencies for some aspects of Xfce functionality; which are not overtly documented.

A key discovery directly pertinent to this issue is that- not having the libcups devel package(s) installed before compile-install will result in NO CUPS support in Xfce.


Mageia 3 / Xce 4.10
"Which is better- Artificial intelligence or REAL stupidity...?"

Offline

#6 2007-03-27 10:38:48

jorgynh0
Member
Registered: 2007-03-10
Posts: 4

Re: Cups doesn't appear in Xfprint selection of print system

I installed the "libcups" devel package and compile-install xfprint4.

Now I have CUPS printing system selected in the selection menu of print system.

BUT I can´t print yet...

It seems that Xfce (or Thunar with its support for usb devices) doesn't recognice my printer (conected by usb)...

Should I do somenthing else?

My printer worked before updating Xfce.
After the update, i had problems to mount usb devices. I had to re-install with all the dependencies needed to activate thunar volman. Now usb device ount/unmount well.

So...I don't know what happens with the printer.
When I try to print anything, CUPS always says: Printer not conected...

I hope someone can help me...
Thanks in advance.

Offline

#7 2007-03-27 10:49:30

jorgynh0
Member
Registered: 2007-03-10
Posts: 4

Re: Cups doesn't appear in Xfprint selection of print system

I´m looking for info over the net...i'm not very sure but:

May it has something to see with writing permissions on dev/usb/ or something like that??

Should I see any directory when i turn on the printer? Where and which?

Offline

#8 2007-04-02 19:05:41

jorgynh0
Member
Registered: 2007-03-10
Posts: 4

Re: Cups doesn't appear in Xfprint selection of print system

More info for the case someone can help me...

When I type " tail -f /var/log/messages", the output is:

Apr  2 20:58:13 antec kernel: [17226442.392000]   Vendor:           Model:                   Rev:     
Apr  2 20:58:13 antec kernel: [17226442.392000]   Type:   Direct-Access                      ANSI SCSI revision: 00
Apr  2 20:58:13 antec kernel: [17226442.400000] SCSI device sdb: 1019617 512-byte hdwr sectors (522 MB)
Apr  2 20:58:13 antec kernel: [17226442.400000] sdb: Write Protect is off
Apr  2 20:58:13 antec kernel: [17226442.412000] SCSI device sdb: 1019617 512-byte hdwr sectors (522 MB)
Apr  2 20:58:13 antec kernel: [17226442.416000] sdb: Write Protect is off
Apr  2 20:58:13 antec kernel: [17226442.416000]  sdb: unknown partition table
Apr  2 20:58:13 antec kernel: [17226442.444000] sd 11:0:0:0: Attached scsi removable disk sdb
Apr  2 20:58:13 antec kernel: [17226442.444000] sd 11:0:0:0: Attached scsi generic sg1 type 0
Apr  2 21:00:58 antec kernel: [17226607.040000] usb 3-2: USB disconnect, address 7
Apr  2 21:02:11 antec kernel: [17226680.436000] usb 5-4: new high speed USB device using ehci_hcd and address 12
Apr  2 21:02:11 antec kernel: [17226680.584000] usb 5-4: configuration #1 chosen from 1 choice
Apr  2 21:02:11 antec kernel: [17226680.664000] drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 12 if 1 alt 0 proto 2 vid 0x04A9 pid 0x1714
Apr  2 21:02:11 antec kernel: [17226680.664000] usbcore: registered new driver usblp
Apr  2 21:02:11 antec kernel: [17226680.664000] drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver


And if I type "dmesg", the output is:

Apr  2 20:58:13 antec kernel: [17226442.392000]   Vendor:           Model:                   Rev:     
Apr  2 20:58:13 antec kernel: [17226442.392000]   Type:   Direct-Access                      ANSI SCSI revision: 00
Apr  2 20:58:13 antec kernel: [17226442.400000] SCSI device sdb: 1019617 512-byte hdwr sectors (522 MB)
Apr  2 20:58:13 antec kernel: [17226442.400000] sdb: Write Protect is off
Apr  2 20:58:13 antec kernel: [17226442.412000] SCSI device sdb: 1019617 512-byte hdwr sectors (522 MB)
Apr  2 20:58:13 antec kernel: [17226442.416000] sdb: Write Protect is off
Apr  2 20:58:13 antec kernel: [17226442.416000]  sdb: unknown partition table
Apr  2 20:58:13 antec kernel: [17226442.444000] sd 11:0:0:0: Attached scsi removable disk sdb
Apr  2 20:58:13 antec kernel: [17226442.444000] sd 11:0:0:0: Attached scsi generic sg1 type 0
Apr  2 21:00:58 antec kernel: [17226607.040000] usb 3-2: USB disconnect, address 7
Apr  2 21:02:11 antec kernel: [17226680.436000] usb 5-4: new high speed USB device using ehci_hcd and address 12
Apr  2 21:02:11 antec kernel: [17226680.584000] usb 5-4: configuration #1 chosen from 1 choice
Apr  2 21:02:11 antec kernel: [17226680.664000] drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 12 if 1 alt 0 proto 2 vid 0x04A9 pid 0x1714
Apr  2 21:02:11 antec kernel: [17226680.664000] usbcore: registered new driver usblp
Apr  2 21:02:11 antec kernel: [17226680.664000] drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver



I hope this can be usefull for somebody to help me

Thanks in advance

Offline

Board footer

Powered by FluxBB