Xfce Forum

Sub domains
 

You are not logged in.

#1 2007-03-22 04:33:09

blackdisk
Member
Registered: 2006-03-30
Posts: 21

How [to] make NumLock be on at start?

BIOS starts it, but it's off when XFCE starts. How can I make it always start with it on?

Offline

#2 2007-03-22 05:11:30

SimonJ
Member
From: Perth
Registered: 2006-09-06
Posts: 135
Website

Re: How [to] make NumLock be on at start?

I run a program called numlockx which starts with the X server.

Ubuntu: sudo apt-get install numlockx


Works every time.

hth,


Simon.                                                         (^_^)

TIP: Proofread carefully to see if you any words out.
=====================================================================

Offline

#3 2007-03-22 12:06:34

fatcat
Member
From: FI
Registered: 2004-05-11
Posts: 32

Re: How [to] make NumLock be on at start?

http://wiki.xfce.org/faq

How do I get numlock to start on login?

There are two possibilities to achieve this.  You should use a display manager that turns the numlock on (eg. gdm, check the settings) or you can use a little program called numlockx, adding numlockx on in your .xinitrc will do the job.

Offline

#4 2007-03-22 23:18:16

blackdisk
Member
Registered: 2006-03-30
Posts: 21

Re: How [to] make NumLock be on at start?

Already using gdm but i don't see any numlock setting. But numlockx did the trick.

Thanks.

Offline

#5 2008-08-07 20:22:32

Oli Gophren
Member
Registered: 2008-08-07
Posts: 2

Re: How [to] make NumLock be on at start?

Okay, obviously I am too stupid for this.  :razz:

I am using Xubuntu 8.04. I don't see any numlock setting in Xfce configuration. And numlockx does not work for me:

I inserted the following line
   /usr/X11R6/bin/numlockx on
into these two files
   /./etc/X11/xinit/xinitrc
   /./etc/xdg/xfce4/xinitrc
at different positions, but nothing happened to numlock. Calling numlockx via Terminal does not show any light effects, with or without sudo. And yes, the path of numlock is correct.

Please help to led my fire - thank you!

Offline

#6 2008-08-22 22:08:06

Oli Gophren
Member
Registered: 2008-08-07
Posts: 2

Re: How [to] make NumLock be on at start?

Thanks for not answering.
I AM too stupid for this.  :-|

Here is the solution for those like me:

The numlock and so the numberblock IS working, but the numlock LED is still OFF.

...therefore, my problem is * SOLVED * (except of the visual feedback).

Offline

#7 2008-09-06 16:15:59

edward
Member
From: Boston
Registered: 2008-03-23
Posts: 11

Re: How [to] make NumLock be on at start?

The issue has been reported with more than one Linux distribution and it appears to be related to the X server.  It is functioning as if the system is a laptop.  X is supposed to turn the numlock light off for a laptop, but keep it on for a desktop.  What is happening is that it is turning the light off for a desktop, which is incorrect.  Some have said it's also hardware-dependent.

On my two desktops both running Mandriva, the issue is intermittent, sometimes the numlock light will correctly remain on, other times when X starts, the light goes out.  But when the light is out, the keypad still works normally, type 123 on the keypad, you will see 123.

If you see the numlock light go out when X starts, if you are able to press the Num Lock key fast enough right after the light goes out, to bring the light back on, it should remain on for that entire Linux session.


[img]http://img.userbars.pl/135/26800.png[/img]
Xubuntu 9.10

Offline

Board footer

Powered by FluxBB