Xfce Forum

Sub domains
 

You are not logged in.

#1 2011-01-18 20:25:12

lphilpot
Member
From: Louisiana, USA
Registered: 2011-01-07
Posts: 11
Website

[Solved] Upgrading from 4.6 to 4.8 (FAQ?)

(I looked over the site and docs, but didn't see the answer to my (probably) dumb questions)

I'd like to upgrade my 4.6.2 installation to 4.8. 4.6 was built and installed from the fat tarball (I still have all the unpacked / built source). Is the process as simple as 'make uninstall' in each of the 4.6 source directories, followed by building each of 4.8 packages in the regular manner? If so, do I need to be logged out of 4.6 when I uninstall it or can it happen from a live Xfce session?

Thanks in advance for the help.

Offline

#2 2011-01-21 21:37:48

jeromeg
Moderator
From: France
Registered: 2010-11-11
Posts: 131
Website

Re: [Solved] Upgrading from 4.6 to 4.8 (FAQ?)

It's better if you uninstall 4.6 yes, we do not support having several versions of Xfce installed in parallel. And installing from a console sounds like a better idea, you could run into weird stuff if you run a session for which you just uninstalled everything.

Offline

#3 2011-01-22 00:08:17

lphilpot
Member
From: Louisiana, USA
Registered: 2011-01-07
Posts: 11
Website

Re: [Solved] Upgrading from 4.6 to 4.8 (FAQ?)

I upgraded this afternoon, from KDE4 (no irony intended :-)

I had to find garcon(-devel) rpms since they weren't in the tarball, but other than that it seems to have gone OK, so far. I added a symlink to one of the libexo libraries so that terminal would run since (in the limited time I had at the moment) I didn't have a matching libexe-devel package. Of course, there appears to be a bug in the version of VTE used by terminal, causing the cursor to be invisible. For now, I'll just use gnome-terminal instead.

Thanks.

Offline

Board footer

Powered by FluxBB