Xfce Forum

Sub domains
 

You are not logged in.

#1 2009-12-29 15:05:52

Hammett
Member
Registered: 2009-12-28
Posts: 4

Dual monitors, one wallpaper

Hi all!!

I was wondering if it is possible to have 1 wallpaper spanned across the 2 monitors instead of having 2 different wallpapers for each monitor.
I have tried to use Esetroot to draw the wallpaper, but right after i press enter, the wallpaper changes to what i have selected in the desktop preferences.

I would really like to have this option enabled if possible.

Thanks!

EDIT - SOLUTION:

Run the settings editor (in the menu under Settings->Settings Editor, or xfce4-settings-editor from the command line if you can't find it in the menu). Go to the "xfce4-desktop" channel. Click the "New property" button and enter:
  Name: /backdrop/screen0/xinerama-stretch
  Type: Boolean        (it's a dropdown)
  Value: [ ] Enabled   (check the box to turn on stretched wallpaper, uncheck to turn off stretched wallpaper)
and click Save.

Offline

#2 2010-01-02 03:52:13

etnlWings
Member
Registered: 2007-10-30
Posts: 218

Re: Dual monitors, one wallpaper

Just open the wallpaper file up in an image editor and split each half into separate files.

Offline

#3 2010-01-02 14:03:35

Hammett
Member
Registered: 2009-12-28
Posts: 4

Re: Dual monitors, one wallpaper

Well, this is a non valid option for me. I can't split every single dualhead wallpaper I have into 2. This is more like a workaround and not a solution

Since I can set the wallpaper to the root window with Esetroot, is there a way to disable the wallpapers from Xfce?

Offline

#4 2010-01-10 12:09:10

etnlWings
Member
Registered: 2007-10-30
Posts: 218

Re: Dual monitors, one wallpaper

Just remove xfdesktop from your session.

Offline

#5 2010-01-11 21:41:55

dylix
Member
Registered: 2010-01-11
Posts: 4

Re: Dual monitors, one wallpaper

so here's something that helps a little bit..

http://plutonic.mine.nu/?page=misc#split-wall

to make it even easier, with thunar choose 'open with' then select my script... browse wallpapers with ristretto, when u find one u like click 'open with.. split-wall.sh'...

not perfect, but it atleast makes life a little easier, for me atleast   lol

Offline

#6 2010-01-17 18:57:08

Hammett
Member
Registered: 2009-12-28
Posts: 4

Re: Dual monitors, one wallpaper

etnlWings wrote:

Just remove xfdesktop from your session.

This does not solve my problem at all, as when I kill xfdesktop my transparent aterms and background is totally unusuable.

dylix wrote:

so here's something that helps a little bit..

http://plutonic.mine.nu/?page=misc#split-wall

to make it even easier, with thunar choose 'open with' then select my script... browse wallpapers with ristretto, when u find one u like click 'open with.. split-wall.sh'...

not perfect, but it atleast makes life a little easier, for me atleast   lol

That's a wonderful solution! Even though it is not perfect and I really thing Xfce developers should give the choice to the user (single wallpaper spanned or 2 wallpapers) instead of having to do this workarounds.

Thanks very much for this little script!

Offline

#7 2011-08-30 04:13:38

longshanks197
Member
Registered: 2011-08-30
Posts: 2

Re: Dual monitors, one wallpaper

Hammett,

Came across your post in a similar search. Just installed a new machine with a fresh configuration and found the setting was missing in xfce 4.8.0. I couldn't find an answer either but luckily I had saved my configurations from a prior install that was upgraded from a pre-4.6 install. The setting was migrated but a new install will not have it. i found an interesting setting for xineramastretch in the prior install. A search for this setting identified a migration path from the old MCS configuration to the Xfconf in the code. I created a property using the xfconf settings editor.

Under xfce4-desktop create a new property with the following settings:

Name: /backdrop/screen0/xinerama-stretch
Type: BOOL
Value: TRUE|1|Enabled

The screen setting (screen0) may be unique to your install, not sure but use what makes sense under the backdrop property, but this setting forced the background to stretch across both monitors using the setting for monitor0. Hopefully this helps!

Edit: Updated type from Int to BOOL. There was some weirdness with Compiz when the value was Int with the windows not sizing correctly. Not sure if it was from this setting or not using xfwm4 with this setting (if that makes sense). Nevertheless, using BOOL is working just as good if not better. Let me know if this works for you. Thanks!

Last edited by longshanks197 (2011-08-30 20:50:00)

Offline

#8 2011-09-19 01:45:56

thisisquitealongname
Member
Registered: 2011-09-19
Posts: 1

Re: Dual monitors, one wallpaper

Under xfce4-desktop create a new property with the following settings:

Name: /backdrop/screen0/xinerama-stretch
Type: BOOL
Value: TRUE|1|Enabled

Oh-ho, that's brilliant! It worked instantly for me. Thanks!

[The setting is evidently unrelated, but isn't "xinerama" a term specific to the catalyst driver?]

Offline

#9 2011-10-22 14:30:55

zryder
Member
Registered: 2011-10-22
Posts: 1

Re: Dual monitors, one wallpaper

longshanks197 wrote:

Hammett,
Under xfce4-desktop create a new property with the following settings:

Name: /backdrop/screen0/xinerama-stretch
Type: BOOL
Value: TRUE|1|Enabled

I am new to XFCE, so forgive me for being a noob, but where do I make this file?

Arch64 with ATI proprietary drivers.

Thanks.

Offline

#10 2011-12-29 05:57:54

lhand
Member
Registered: 2011-12-29
Posts: 1

Re: Dual monitors, one wallpaper

Hi zryder. In case you haven't figured it out yet...

zryder wrote:
longshanks197 wrote:

Under xfce4-desktop create a new property with the following settings:

Name: /backdrop/screen0/xinerama-stretch
Type: BOOL
Value: TRUE|1|Enabled

I am new to XFCE, so forgive me for being a noob, but where do I make this file?

Run the settings editor (in the menu under Settings->Settings Editor, or xfce4-settings-editor from the command line if you can't find it in the menu). Go to the "xfce4-desktop" channel. Click the "New property" button and enter:
  Name: /backdrop/screen0/xinerama-stretch
  Type: Boolean        (it's a dropdown)
  Value: [ ] Enabled   (check the box to turn on stretched wallpaper, uncheck to turn off stretched wallpaper)
and click Save.

Offline

#11 2012-02-10 03:40:34

longshanks197
Member
Registered: 2011-08-30
Posts: 2

Re: Dual monitors, one wallpaper

Wow, I totally forgot that I posted this. I just got an update on a bug post about this issue so I stopped back.

@thisisquitealongname - glad this did the trick

@lhand - thanks for helping out zryder by giving some better step by step instructions

Just FYI on this issue, there is a patch that got posted by one of the devs (thanks Eric) that should make this a bit easier
https://bugzilla.xfce.org/show_bug.cgi?id=5690

Offline

#12 2012-03-29 20:25:17

kryliss
Member
Registered: 2012-03-29
Posts: 1

Re: Dual monitors, one wallpaper

I have the same issue but when I go into the Settings Editor the New Property button remains grayed out no matter what channel I go into. Got a fix for that?

Offline

#13 2012-04-26 21:03:46

sick
Member
From: Deutschland
Registered: 2012-04-25
Posts: 7

Re: Dual monitors, one wallpaper

Hi folks,

how can i install the patch?

I'm new to XFCE so i have no clue?!?!

thanks in advance..

Andi

Edit:
"New property" button and enter:
  Name: /backdrop/screen0/xinerama-stretch
  Type: Boolean        (it's a dropdown)
  Value: [ ] Enabled   (check the box to turn on stretched wallpaper, uncheck to turn off stretched wallpaper)

did the trick for me.

thanks...

Last edited by sick (2012-04-26 21:41:02)

Offline

Board footer

Powered by FluxBB