Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-01-18 03:52:18

Digger
Member
Registered: 2012-01-18
Posts: 21
Website

How Do I Disable Screen Lock Altogether?

Hi all,

Sorta new to Linux....been researching my problem for a few days now...

I'm running Debian Squeeze.  My desktop is xfce4.  My window manager is gdm.

I am trying to figure out a way to disable the screen lock function altogether, as I have no use for such.

Let me tell you how I can get the screen to become locked without commanding it to do so:

Let's say I've got a user session open on the desktop.  I go to the task bar and click the "User switching" icon, and then log into my wife's desktop.  Now, when I leave her desktop (so that I can return to mine) via a "Log Out" or "switch user" action, I get the xscreensaver splash screen on a black background, asking for my user password.  This is not what I want.

I've fooled around with the xflock4 and xdg-screensaver scripts to no avail.

How can I disable the screen lock altogether?

TIA!


Xfce 4.6.2; Debian Squeeze

Offline

#2 2012-01-18 19:04:18

stqn
Member
Registered: 2010-10-11
Posts: 168

Re: How Do I Disable Screen Lock Altogether?

Have you tried deselecting "Lock screen" in the (X)ScreenSaver preferences?

I have a similar problem with my Debian LXDE installation: the screen is locked after sleep/hibernation.
I followed the instructions on this page: http://onlyubuntu.blogspot.com/2008/06/ … after.html
Now my netbook does sleep when I close the lid, doesn't lock the screen when I switch it back on, BUT for some reason does still lock the screen if I use the shutdown panel applet to put it to sleep. Maybe it's an LXDE-thing...

(Edit: I know my experiments with Debian LXDE have nothing to do with Xfce; I'm just mentionning it in case it's useful to the OP...)

Last edited by stqn (2012-01-18 19:08:56)

Offline

Board footer

Powered by FluxBB