Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-04-01 17:15:58

Ritmo2k
Member
Registered: 2012-04-01
Posts: 6

Some windows start under panel in Xubuntu 11.10

Running xfce4 4.8.0.2 package, some windows get stuck under the main panel, and apps like cssh always start terminals under this panel. Anyone know how to prevent this?

Thanks!

Offline

#2 2012-04-01 21:36:05

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,059

Re: Some windows start under panel in Xubuntu 11.10

Make sure you have the disable-struts property set to false. To check:

xfconf-query -c xfce4-panel -p /panels/panel-0/disable-struts

...change panel-0 to panel-1,panel-2,panel-3,etc as required.

It should be set to false to prevent windows from underlapping the panel. To set the property:

xfconf-query -c xfce4-panel -p /panels/panel-0/disable-struts -t bool -n -s false

...again, changing panel-0 for each panel that you have.

Offline

#3 2012-04-01 21:55:22

Ritmo2k
Member
Registered: 2012-04-01
Posts: 6

Re: Some windows start under panel in Xubuntu 11.10

Hi,
I looked at several posts sugegsting this but wasn't sure it was applicable, I tried it anyway (for all panels) and it didnt make a difference with cssh at least.

Any other ideas?

Thanks!

Offline

#4 2012-04-01 22:37:03

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,059

Re: Some windows start under panel in Xubuntu 11.10

I'm also running Xubuntu 11.10 and the window opens in the middle of the screen as per the setting in "Window Manager Tweaks->Placement tab". I also notice that there is "console_position" parameter in ~/.csshrc that is supposed to control the placement of the window (in the format of "console_position=+10+10"). Unfortunately, I cannot get this setting to work (regardless of the values, it always opens in the top-left corner beside, not under, the panel).

Offline

#5 2012-12-07 23:08:59

nbartolome
Member
Registered: 2012-12-07
Posts: 1

Re: Some windows start under panel in Xubuntu 11.10

I found this thread because I ran into the same thing.

Edit ~/.csshrc and change the value of "screen_reserve_top"

Mine looks like this:

screen_reserve_top=30

It's actually listed in the man page for cssh.   Search for "reserve"

Offline

Board footer

Powered by FluxBB