Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-08-14 21:30:16

®om
Member
Registered: 2012-08-14
Posts: 3

[Solved] XFCE theme don't work

Hello,

I need help for a very simple thing : installing a theme.
I went to xfce-look, downloaded the highest rated (for testing), axiom. I downloaded 90145-axiom.tar.gz.

$ tar tf 90145-axiom.tar.gz | grep /$
axiom/
axiom/gtk-2.0/
axiom/xfwm4/
axiomd/
axiomd/gtk-2.0/
axiomd/xfwm4/

I extracted it in ~/.themes (for having axiom and axiomd):

~$ find .themes/axiom{,d} -type d
.themes/axiom
.themes/axiom/xfwm4
.themes/axiom/gtk-2.0
.themes/axiomd
.themes/axiomd/xfwm4
.themes/axiomd/gtk-2.0

I open Sessings, Appaerence (my own translation, in French it's "Paramètres, Apparence"), and in the first tab ("Style"), the list contains "axiom" and "axiomd". Great.
Now I click on axiom : it only changes the decoration, and set the same as Xfce-4.6 (not the axiom decoration I can see in screenshots).
Now I click on axiomd : exactly the same.

How does it work ? Is something missing?

I am using xfce 4.8 on Debian wheezy (testing).

Thank you for your help.

Offline

#2 2012-08-14 22:37:14

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,335

Re: [Solved] XFCE theme don't work

This particular theme has both a gtk and an xfwm component. To change the gtk appearance, go to Settings Manger -> Appearance (like you did). To change the xfwm (Window Manager) appearance, go to Settings Manager -> Window Manager.

Online

#3 2012-08-15 08:50:08

®om
Member
Registered: 2012-08-14
Posts: 3

Re: [Solved] XFCE theme don't work

Thank you for your answer, it solves the problem.

But I still have many problems with themes: almost all have one problem or another.

With axiom dark version, only the decoration is dark :
1159685946.png

I tried BSM Simple. It contains:
- BSM Simple
- BSM Simple Dark
- BSM Simple Dark Menu
- BSM Simple Dark Panel

When I apply "BSM Simple Dark", it does not do what expected:
1159685771.png

And how to apply the theme on menu and panel ?

Then I tried MoreDots which should look like this:
51125-1.png
But when I apply it, I don't have the same colors (the colors seems to depend on GTK theme):
1159686091.png
How to get the same result?

Thank you for your help.

Last edited by ®om (2012-08-15 08:50:43)

Offline

#4 2012-08-15 12:05:03

®om
Member
Registered: 2012-08-14
Posts: 3

Re: [Solved] XFCE theme don't work

I found: I had a file ~/.gtkrc-2.0 containing:

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Xfce-4.6/gtk-2.0/gtkrc"

include "/home/rom/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT

I renamed it:

mv .gtkrc-2.0{,.old}

Now it works ;-)

Offline

Board footer

Powered by FluxBB