Xfce Forum

Sub domains
 

You are not logged in.

#26 2011-11-19 20:11:33

GridCube
Member
Registered: 2011-11-19
Posts: 1

Re: xfce4-kbdleds-plugin

Hello, oco, Im a contributor to Xubuntu, mainly on bug testing, reporting and user support, lately some people have come asking for a keyboard led indicator and I found your plugin, it works as intended so I'm promoting it to be included on the next release of Xubuntu, Precise Pangolin, which will be an LTS release, however, because of this fact of being an LTS release, your plugin is being evaluated by the fact, and i quote, that " it's a big mess inside =]".

So I feel its my obligation to ask if you would please clean the code a bit so it might be considered for inclusion?

Sorry for the inconvenience i might cause to you, but i feel this is a rather important add-on for non-led-keyboard users.

Thank you very much.

Offline

#27 2011-12-11 22:41:45

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

Hello!
I have already cleaned up the plugin several weeks ago, but I can do some more cleaning if you wish. Show me, where messy things are?

Offline

#28 2012-03-24 00:56:53

StephenH
Member
From: Wake Forest, North Carolina
Registered: 2011-09-10
Posts: 16
Website

Re: xfce4-kbdleds-plugin

It has been a while since I checked. Has there been any progress toward making this available as a plug-in for 32 and for 64 bit systems that can be installed through a system's package manager (yum in my case)? Having to download not only a source file but also all of the development parts needed to compile it means that it probably is not accesible to many who might otherwise use this plug-in. The http://goodies.xfce.org/projects/panel- … eds-plugin page does not indicate any changes in status beyond last October.

Thanks.

Last edited by StephenH (2012-03-24 00:57:31)


StephenH

"We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach
http://pilgrim-wanderings.blogspot.com

Offline

#29 2012-03-24 08:26:12

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

Yes, there were no changes since last year.

Offline

#30 2012-09-12 10:07:17

loux
Member
Registered: 2012-09-12
Posts: 2

Re: xfce4-kbdleds-plugin

Hello,
Using daily a netbook (adding or not external keyboard), this plugin would be very usefull to me. My system is Xubuntu 12.04 (i'm just an advanced user, not a programmer).
The installation worked after adding some -dev packages, but the applet doesn't appear in the panel plugin list (using the graphical interface). I tried to add the plugin via xfce4-settings-editor as so:
xfce-panel>plugins>plugin-50 type=string value=kbdleds
...but nothing changed.
how can i find and add it to my panel?

Offline

#31 2012-09-12 21:16:23

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

loux wrote:

Hello,
Using daily a netbook (adding or not external keyboard), this plugin would be very usefull to me. My system is Xubuntu 12.04 (i'm just an advanced user, not a programmer).
The installation worked after adding some -dev packages, but the applet doesn't appear in the panel plugin list (using the graphical interface). I tried to add the plugin via xfce4-settings-editor as so:
xfce-panel>plugins>plugin-50 type=string value=kbdleds
...but nothing changed.
how can i find and add it to my panel?

You must use

./configure --prefix=/usr
make
sudo make install

I have Xubuntu 12.04 too, recompiled plugin from scratch and it works!

Last edited by oco (2012-09-12 21:17:55)

Offline

#32 2012-09-19 14:14:27

loux
Member
Registered: 2012-09-12
Posts: 2

Re: xfce4-kbdleds-plugin

all wright, it works.
thanks very much !

Offline

#33 2012-11-06 05:15:05

weronika
Member
Registered: 2012-11-06
Posts: 2

Re: xfce4-kbdleds-plugin

I'm having trouble installing kbdleds...

Running "sudo ./configure --prefix=/usr" exits with the following:

    checking for gtk+-2.0 >= 2.20.0... not found
    *** The required package gtk+-2.0 was not found on your system.
    *** Please install gtk+-2.0 (atleast version 2.20.0) or adjust
    *** the PKG_CONFIG_PATH environment variable if you
    *** installed the package in a nonstandard prefix so that
    *** pkg-config is able to find it.

I'm pretty sure I do have gtk+-2.0 version - Synaptic shows that package gtk2-engines is installed, version 1:2.20.2-1ubuntu1, whatever exactly that means.  Or is there some other package I should install?  $PKG_CONFIG_PATH is empty.

Offline

#34 2012-11-06 06:24:30

weronika
Member
Registered: 2012-11-06
Posts: 2

Re: xfce4-kbdleds-plugin

Update: the problem seems to have been solved by installing xfce-panel-dev and libxfce4ui-1-dev (they're not what ./configure was asking for, but I found them mentioned on another thread and gave it a try).  Works now, very useful little plugin!  (Things like color/font/etc configuration would be nice, but probably too much to ask)

Offline

#35 2012-11-07 22:46:57

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

weronika wrote:

Things like color/font/etc configuration would be nice, but probably too much to ask

I'm not familiar with creating GTK+ dialogs, maybe someone could help me!

Offline

#36 2014-03-19 23:14:20

garrigues
Member
Registered: 2014-03-19
Posts: 1

Re: xfce4-kbdleds-plugin

Hi, (i'm FRench, so be fun with my english)
I'm in the same problem (a keyboard without num-caps) in debian 7-2; i have both "modules", but i have this LONG message !
it's my first time i do this kind of mission; so i'm blind and i jusr do ctrl c ctrl v of what you explain ...
Here is my message :
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for ANSI C header files... (cached) yes
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking stdio.h usability... yes
checking stdio.h presence... yes
checking for stdio.h... yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking for string.h... (cached) yes
checking math.h usability... yes
checking math.h presence... yes
checking for math.h... yes
checking for sys/types.h... (cached) yes
checking sys/wait.h usability... yes
checking sys/wait.h presence... yes
checking for sys/wait.h... yes
checking for memory.h... (cached) yes
checking signal.h usability... yes
checking signal.h presence... yes
checking for signal.h... yes
checking sys/prctl.h usability... yes
checking sys/prctl.h presence... yes
checking for sys/prctl.h... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for bind_textdomain_codeset... yes
checking for locale.h... (cached) yes
checking for LC_MESSAGES... yes
checking for libintl.h... (cached) yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... (cached) yes
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for catalogs to be installed...  ru uk
checking for bind_textdomain_codeset... (cached) yes
checking for locales directory... ${datarootdir}/locale
checking for additional xgettext flags... --keyword=Q_ --from-code=UTF-8
checking for X... libraries , headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for main in -lX11... yes
checking for pkg-config... /usr/bin/pkg-config
checking for pkg-config >= 0.9.0... 0.26
checking for gtk+-2.0 >= 2.20.0... 2.24.10
checking GTK_CFLAGS... -pthread -I/usr/include/gtk-2.0 -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 
checking GTK_LIBS... -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 
checking for libxfce4ui-1 >= 4.6.0... not found
*** The required package libxfce4ui-1 was not found on your system.
*** Please install libxfce4ui-1 (atleast version 4.6.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
root@debian:/home/garrigues/Téléchargements/xfce4-kbdleds-plugin-0/xfce4-kbdleds-plugin-0.0.6#
Could you help me, explain what to do ?
it will be VERY nice.
Thank's
Waiting
(philippe@garrigues.me)

Offline

#37 2014-03-20 00:10:58

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,244

Re: xfce4-kbdleds-plugin

checking for libxfce4ui-1 >= 4.6.0... not found
*** The required package libxfce4ui-1 was not found on your system.
*** Please install libxfce4ui-1 (atleast version 4.6.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

See post #34 above - you need to install some development packages.

Online

#38 2014-03-20 14:47:39

oco
Member
Registered: 2011-05-13
Posts: 18

Re: xfce4-kbdleds-plugin

ToZ wrote:

See post #34 above - you need to install some development packages.

Yes, you should install xfce4-panel-dev and libxfce4ui-1-dev packages.

Offline

Board footer

Powered by FluxBB