Xfce Forum

Sub domains
 

You are not logged in.

#1 2012-11-11 02:50:47

Pedroski
Member
Registered: 2012-11-11
Posts: 2

enable touchpad scrolling in Fedora using xfce

Fedora comes with gnome, but I find the colour scheme, light grey, bad for my eyes. I can't seem to change it. Someone said try xfce. I can change the window themes a bit, but there is no touchpad scrolling, and nowhere to set it. Settings>Mouse has no radio button 'allow touchpad scrolling' gnome has this.

How do I set touchpad scrolling in xfce??

Offline

#2 2012-11-11 11:53:15

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: enable touchpad scrolling in Fedora using xfce

Hi.
I don't have a touchpad but I think Xfce 4.10 has better management for it. You can upgrade Xfce from 4.8 to 4.10 with this repo:
http://repos.fedorapeople.org/repos/kevin/xfce-4.10/
Just put fedora-xfce-4.10.repo in /etc/yum.repos.d/ and run 'yum upgrade'.

As for GNOME, we pray that they don't get back all the nuisance they caused on people's lives but AFAIK you can change the theme with a tool called gnome-tweak-tool ('yum install gnome-tweak-tool'). Then you find themes in gnome-look.org (Fedora 17 uses GTK 3.4 so you need themes for that specific version as they break with every GTK version update).

Another option would be trying the Cinnamon desktop with 'yum install cinnamon': http://forums.fedoraforum.org/showthread.php?t=274611

But as long as your touchpad works then Xfce is still by far the least troublesome*.

* semi-rant: at least until it switches to GTK3 which at this point maybe it would be better that it never did.

Offline

#3 2012-11-11 13:16:41

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: enable touchpad scrolling in Fedora using xfce

Note: if you upgrade Xfce I recommend you do like this:
- download and put fedora-xfce-4.10.repo in /etc/yum.repos.d/
- logout
- ctrl+alt+f2
- login as root
- yum upgrade
- after it's complete, run: rm -rf /home/<replace this with your username>/.cache/sessions
- ctrl+d
- ctrl+alt+f1
- login into Xfce
Your configuration, specially the panel's, might be messed up a bit. Just re-configure it again.

Xfce 4.10 has in its Settings menu a 'Mouse and Touchpad' entry that might solve your issue.

Regardless of that, even if you stay with Xfce 4.8, you can google 'synaptics xorg touchpad' and you may find a synaptics (touchpad driver) configuration that you can place in /etc/X11/xorg.conf.d/00-synaptics.conf

Offline

#4 2012-11-11 22:49:18

Pedroski
Member
Registered: 2012-11-11
Posts: 2

Re: enable touchpad scrolling in Fedora using xfce

Thanks. I updated xfce. There is a tab for touchpad. It doesn't work properly. Two finger scrolling works, so half the battle is won! Edge scrolling doesn't work. If I check the radio button, it does nothing.

But two fingers is better than one!

Offline

#5 2012-11-12 10:56:27

secipolla
Member
Registered: 2012-01-15
Posts: 393

Re: enable touchpad scrolling in Fedora using xfce

Good to know it progressed. Let's see if someone that has a touchpad can help.
Have you looked at the synaptics configuration method?

Offline

#6 2012-12-15 19:20:08

unimatrixoverload
Member
Registered: 2012-12-11
Posts: 5

Re: enable touchpad scrolling in Fedora using xfce

Since your using Fedora it is not an identical setup. But for what its worth I'm running Ubuntu Studio 12.10 and have a synaptics touchpad on a Dell XPS. Edge scrolling works. Two finger works. But it is either or. It does not allow both to be enabled at the same time.

==========

$ uname -a
Linux sparkles 3.5.0-18-lowlatency #18-Ubuntu SMP PREEMPT Fri Oct 19 22:17:40 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ dpkg -l 'xfce4'
xfce4          4.10.0       all

$ dpkg -l 'xfce4-settings'
xfce4-settings 4.10.0-1ubun amd64

$ lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 12.10
Release:    12.10
Codename:    quantal

Offline

#7 2013-01-25 05:57:57

jhvh1
Member
Registered: 2013-01-25
Posts: 3

Re: enable touchpad scrolling in Fedora using xfce

Does fedora have a synclient package? I put this simple bash script in my Xfce settings Session and Startup/Application Autostart and call it a day.

#! /bin/bash
synclient VertEdgeScroll=1
synclient HorizEdgeScroll=1
synclient TapButton1=1

There are a lot more options in synclient, but this is all I want/need for my own use. I know it supports two-finger scroll and pressure, among other things.
(I know it's almost a zombie thread, but this works...)

Last edited by jhvh1 (2013-01-25 05:59:11)


Debian GNU/Linux

Offline

#8 2013-01-25 06:09:29

ozjd
Member
From: Hawkesbury NSW Australia
Registered: 2012-02-05
Posts: 220
Website

Re: enable touchpad scrolling in Fedora using xfce

In Fedora 17 with 4.10 you can select either edge or 2 finger scrolling but not both. Either work on my old Dell laptop. I guess F18 is the same as it has the same version of Xfce.

The synclient option worked for me in previous verisons but isn't needed now.

Last edited by ozjd (2013-01-25 06:09:54)

Offline

Board footer

Powered by FluxBB