Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-01-05 17:26:30

V10lator
Member
From: Germany
Registered: 2012-08-16
Posts: 9
Website

Volumes disappeared

Since my last system update (included a xfce update) some volumes are disappeared from thunar/the desktop. As one of this volumes is my DVD drive it's really sad (I can't simply mount CDs/DVDs anymore).
The weird thing is that root sees all devices.

Thunar as normal user:
thunarnormal.png
Thunar as root:
thunarroot.png

Last edited by V10lator (2013-01-05 17:27:08)

Offline

#2 2013-01-07 17:16:33

wilker
Member
Registered: 2012-11-16
Posts: 27

Re: Volumes disappeared

hi!

maybe it has something to do with your permissions to open such devices?
i think i have seen something similar before, but with nautilus...so it might not be exclusively a thunar problem.
this is my guess

kind regards

Offline

#3 2013-01-07 17:47:30

V10lator
Member
From: Germany
Registered: 2012-08-16
Posts: 9
Website

Re: Volumes disappeared

Well, it worked before the system update and I didn't change any permissions...

//EDIT: Also USB drives work like a charm.

Last edited by V10lator (2013-01-07 17:48:43)

Offline

#4 2013-01-07 19:59:02

wilker
Member
Registered: 2012-11-16
Posts: 27

Re: Volumes disappeared

V10lator wrote:

Well, it worked before the system update and I didn't change any permissions...

//EDIT: Also USB drives work like a charm.

what update you mean? did you update the xfce version, for example?

regards

Offline

#5 2013-01-07 21:16:04

wilker
Member
Registered: 2012-11-16
Posts: 27

Re: Volumes disappeared

which desktop manager are you using?
i think it could have something to do with your .xinitrc file.
look at the 6th post in this thread.
i am trying to use xdm at the moment, and i cant mount USB volumes or see the shutdown/restart dialog when i run xfce4-session-logout
i am still learning how to configure it...

Offline

#6 2013-01-07 22:21:08

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: Volumes disappeared

What Thunar version do you have?

Offline

#7 2013-01-08 03:42:01

V10lator
Member
From: Germany
Registered: 2012-08-16
Posts: 9
Website

Re: Volumes disappeared

wilker wrote:

what update you mean? did you update the xfce version, for example?

I don't really remember, but it was a minor update (no bige jump like from XFCE 4.8 to 4.10). IIRC at least Thunar was updated.

wilker wrote:

i am trying to use xdm at the moment

I'm using lightdm. I don't think we have the same problem.

Nick wrote:

What Thunar version do you have?

1.6.2

Offline

#8 2013-01-08 08:25:16

Nick
Dev
From: ~
Registered: 2005-02-17
Posts: 1,144
Website

Re: Volumes disappeared

By default not all volumes are visible. If you cannot (un)mount, eject or remove the device, it is not listed. In other words, if you don't have privileges to do anything with the mount/disk/volume, its not shown.

Offline

#9 2013-01-08 10:20:56

V10lator
Member
From: Germany
Registered: 2012-08-16
Posts: 9
Website

Re: Volumes disappeared

Nick wrote:

By default not all volumes are visible. If you cannot (un)mount, eject or remove the device, it is not listed. In other words, if you don't have privileges to do anything with the mount/disk/volume, its not shown.

$ mount /mnt/cdrom
$ ls /mnt/cdrom
KNOPPIX  autorun.bat  autorun.inf  autorun.pif  boot  cdrom.ico  index.html
$ umount /mnt/cdrom
$ eject /dev/sr0

Works like a charm (as user). I don't think permissions are the problem here.

Last edited by V10lator (2013-01-08 10:21:09)

Offline

#10 2013-01-08 11:00:53

wilker
Member
Registered: 2012-11-16
Posts: 27

Re: Volumes disappeared

V10lator wrote:
Nick wrote:

By default not all volumes are visible. If you cannot (un)mount, eject or remove the device, it is not listed. In other words, if you don't have privileges to do anything with the mount/disk/volume, its not shown.

$ mount /mnt/cdrom
$ ls /mnt/cdrom
KNOPPIX  autorun.bat  autorun.inf  autorun.pif  boot  cdrom.ico  index.html
$ umount /mnt/cdrom
$ eject /dev/sr0

Works like a charm (as user). I don't think permissions are the problem here.

indeed.
did you had a look at thunar > edit > preferences > advanced > configure
and checked if somethings weird?
i also found http://crunchbang.org/forums/viewtopic.php?id=4349/ old thread describing a similar problem (you said when you plug a USB volume it mounts, right?)
would be strange if they didnt have this option before, then provided it, then removed it again.

Nick wrote:

By default not all volumes are visible. If you cannot (un)mount, eject or remove the device, it is not listed. In other words, if you don't have privileges to do anything with the mount/disk/volume, its not shown.

how come i never did any configuration and i mount CDs for example just okay?

Last edited by wilker (2013-01-08 11:02:06)

Offline

#11 2013-01-08 12:14:23

Clio
Member
Registered: 2011-01-25
Posts: 35

Re: Volumes disappeared

Normally, CD/DVD are automaticly mounted to /media, not to /mnt.
Change your fstab or use the thunar-volman, thats mounted automaticly without fstab.

Offline

#12 2013-01-18 01:07:35

gfontaine
Member
From: Québec, Canada
Registered: 2008-06-15
Posts: 20
Website

Re: Volumes disappeared

I have the same problem here. I don't remember which update generated that issue. When I insert a USB stick, I see it in Thunar left pane. When I insert a CD-DVD, I don't. I'm running Funtoo.

qlist -Iv thunar udev
sys-fs/udev-171-r8
virtual/udev-171
xfce-base/thunar-1.6.2
xfce-extra/thunar-volman-0.8.0

I've never changed settings neither thunar nor thunar-volman.

Offline

#13 2013-01-18 01:34:06

gfontaine
Member
From: Québec, Canada
Registered: 2008-06-15
Posts: 20
Website

Re: Volumes disappeared

This could be source of problems :

https://bugzilla.xfce.org/show_bug.cgi?id=9657

Offline

#14 2013-01-18 05:05:58

V10lator
Member
From: Germany
Registered: 2012-08-16
Posts: 9
Website

Re: Volumes disappeared

Clio wrote:

Normally, CD/DVD are automaticly mounted to /media, not to /mnt.
Change your fstab or use the thunar-volman, thats mounted automaticly without fstab.

If I remove the entry from fstab (hence use thunar-volman) not even root can mount it anymore.

gfontaine wrote:

This could be source of problems :

https://bugzilla.xfce.org/show_bug.cgi?id=9657

Sounds like a different issue.

Offline

#15 2013-01-18 14:16:28

gfontaine
Member
From: Québec, Canada
Registered: 2008-06-15
Posts: 20
Website

Re: Volumes disappeared

Yes it's a different issue but something is evident.... no CD or DVD show in thunar 1.6.2 and volman doesn't mount it on insertion as it does with USB.

Anyway... if Xfce doesn't fix it... there are other files managers and desktops as well.

Offline

#16 2014-05-04 15:47:12

hariskar
Member
From: Greece/Kavala
Registered: 2012-10-22
Posts: 9
Website

Re: Volumes disappeared

I have the same problem with CD/DVD player not showing. Still not fixed?

Last edited by hariskar (2014-05-04 15:47:34)

Offline

Board footer

Powered by FluxBB