Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-03-16 11:28:29

dclement
Member
Registered: 2013-03-15
Posts: 7

No network drive icon in 4.10

Hello,

I have just tried a new distro with XFCE 4.10 (mine is still at 4.8).

I noticed this difference: in Thunar, the network drives no longer had their usual drive icon, but instead a "blank document" icon.

It's only cosmetic; the network's still working OK. But if there was a way to fix that, I'd be glad to apply it.

TIA - best regards, Daniel

Offline

#2 2013-03-16 15:18:33

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 936

Re: No network drive icon in 4.10

What icon theme are you using? It could be that the icon theme doesn't include the proper network icon. Try another icon theme and see if it displays something other than a blank document icon.

Offline

#3 2013-03-16 15:51:00

dclement
Member
Registered: 2013-03-15
Posts: 7

Re: No network drive icon in 4.10

Thank you for replying.

I tried two themes, the default one and then I switched to Tango. The icon does change a little, but it's still a generic/blank icon (becomes a blank page with top right corner folded).

There are other themes available which I'll test, but it will take some time as I'm doing this under a live-usb system.

Offline

#4 2013-03-17 15:10:45

dclement
Member
Registered: 2013-03-15
Posts: 7

Re: No network drive icon in 4.10

Here is more test report. I have tested all the icon themes provided, Elementary Xubuntu dark, Gnome, High contrast, High contrast inverse, Low contrast, Oxygen-gtk and Tango. All have the problem, network drive icon replaced by blank document icon.

Oddly enough, _inside_ the network drives, the folders do have correct network folder icons.

Is it possible that the network drive icon has been forgotten or wrongly renamed in XFCE 4.10? I'll try and compare with XFCE 4.8, but it will take some time...

Regards, Daniel

Offline

#5 2013-03-17 17:02:06

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 936

Re: No network drive icon in 4.10

Which distro are you testing?

Offline

#6 2013-03-17 17:32:26

dclement
Member
Registered: 2013-03-15
Posts: 7

Re: No network drive icon in 4.10

My current distro is Linux Mint Debian XFCE (4.8) (-> no icon problem).

I've tested Linux Mint Debian "unofficial", which has evolved into Solydx, which I'm testing these days. Both have the icon problem.

I plan to test Debian Wheezy when it's available, just out of curiosity. I'm not especially fan of any distro., I'm just looking for a way to get a more recent XFCE version.

The trouble is, I don't even know _where_ are these network drive icons in XFCE 4.8, to try and check where they have gone in 4.10...

Offline

#7 2013-03-17 21:30:52

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 936

Re: No network drive icon in 4.10

It looks like the icon that is uses is called gtk-network.svg. I can change the icon by creating a gtk-network.svg file in /usr/share/icons/<theme>/apps/scalable/ where <theme> is the icon theme name.

Offline

#8 2013-03-18 13:41:10

dclement
Member
Registered: 2013-03-15
Posts: 7

Re: No network drive icon in 4.10

Hmm... Thanks to your reply I've spotted the right icon, but I have a few differences here. The icon I'm missing is not quite gtk-network, but instead network-server. I can see it in my XFCE 4.8. It's under usr/share/icons/gnome/256x256/places/ (and other sizes, but not scalable). ("gnome" is a bit weird, because it's not the icon theme selected -- sort of fallback?)

Now, under my live Solydx (XFCE 4.10)... Well, under just every /usr/share/icons/<theme>/<size>/places there is a network-server icon!

So the required icons are there but never appear under network:/// Where to look then? Perhaps in the index.theme files? It's puzzling, because only this icon has a problem, while all the others are fine hmm

Offline

#9 2013-03-19 03:03:24

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 936

Re: No network drive icon in 4.10

Now, under my live Solydx (XFCE 4.10)... Well, under just every /usr/share/icons/<theme>/<size>/places there is a network-server icon!

What happens if you copy the network-server icon to gtk-network in each of those directories?

Interestingly, according to the freedesktop icon namming spec (http://standards.freedesktop.org/icon-n … atest.html), network-server should be the proper icon name. Hmmm.

Offline

#10 2013-03-19 12:16:03

dclement
Member
Registered: 2013-03-15
Posts: 7

Re: No network drive icon in 4.10

I've tested what you suggest but for one theme only (oxygen). But it didn't change anything, no matter how hard I tried (switching from and back to this icon theme, logging out in between...).

BTW, what distro. are you using? Hasn't it his icon problem? I'd gladly give it a try; as I told, I don't feel tied to a particular distro.!

Offline

#11 2013-03-19 14:18:17

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 936

Re: No network drive icon in 4.10

I'm currently running Xubuntu 13.04 (currently in beta), but I've seen similar in previous versions of Xubuntu (12.04 is the current LTS and 12.10 is the current release). The icon theme I am using is Faenza (https://launchpad.net/~tiheum/+archive/equinox) with the Xfce add-on (http://xfce-look.org/content/show.php/F … ent=142885)

fm34.png

Offline

#12 2013-03-20 11:10:25

dclement
Member
Registered: 2013-03-15
Posts: 7

Re: No network drive icon in 4.10

Thanks for the screenshot. I feel I have to tell a little more about my case. I used Ubuntu before I switched to Linux Mint Debian, a "semi-rolling" distro. I liked this idea, as well as the XFCE desktop which I have selected.

Now, Linux Mint are abandoning the XFCE desktop in their Debian edition. I suppose I will still get updates, but it worries me.

So I was considering Solydx as the natural successor. But the issues I have are not only cosmetic, like icons (e.g. sound, too, is not working OOTB <-- [EDIT: this is no longer true with the latest iso]). They seem unreasonably complicated to solve!

So I'm still searching for any (semi-)rolling XFCE distro, not necessarily Solydx. Thank you again for your help.

Best regards, Daniel

Last edited by dclement (2013-06-10 05:53:17)

Offline

#13 2013-03-20 11:36:26

ToZ
Member
From: Toronto, Canada
Registered: 2011-06-02
Posts: 936

Re: No network drive icon in 4.10

Not sure if this makes a difference, but have a look here: http://fridge.ubuntu.com/2013/03/19/ubu … thodology/
It looks like the *buntus are heading to a semi-rolling type of release structure.

Edit: As for sounds, we got them to work in xubuntu (See: http://forum.xfce.org/viewtopic.php?id=7780 and http://ubuntuforums.org/showthread.php? … erra+sound). Perhaps you can modify the instructions for the distro you are using. YMMV.

Last edited by ToZ (2013-03-20 11:40:13)

Offline

Board footer

Powered by FluxBB