Xfce Forum

Sub domains
 

You are not logged in.

#1 2013-10-03 13:43:09

lw1471
Member
Registered: 2013-09-11
Posts: 10

Panel behaviour

Hello. I'm wondering if I can do anything about this.

I like to set margins of 0, 0, 0 and 30 px on the Xfce desktop else I seem to lose a bit off the bottom of Firefox for example. But then when I watch a video in VLC I'll usually want fullscreen, at which point I get a big VLC window but with the panel visible below it. If I change the 30 px margin to 0 VLC gives me a true fullscreen viewing but as I say then some other program windows lose area that I'll often need, e.g. where a form or button is.

I suppose I'm asking if the panel can be set to have some sort of 'intellihide' properties or forced to stay under any fullscreen windows. I remember LXDE despite its modesty being very useful in that its panel could be set to be out of the way when needed (and maybe this is why Peppermint uses LXDE with Xfwm). I can't say that the Gnome, KDE or LXDE panels have been awkward like this, although on my desktop rather than my netbook I do like the above-mentioned but seemingly seldom-used margins feature and am overall now a committed Xfce user.

Thanks.

(Xubuntu 13.04 64 bit, Xfce 4.10.0)

Offline

#2 2013-10-03 17:34:32

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,241

Re: Panel behaviour

If I'm understanding this correctly.....
Have a look at this thread for information on how to use wmctrl to drop the panel to the desktop level. The thread also talks about disabling struts, but in Xfce 4.10, this can also be done via the "Don't reserve space on borders" property in the Panel Properties.

Offline

#3 2013-10-04 05:53:30

lw1471
Member
Registered: 2013-09-11
Posts: 10

Re: Panel behaviour

Good, in Xubuntu that 'Don't reserve...' option you mention solved things. I'm very likely to move to Debian 7 Xfce today though and that box isn't there in its version of Xfce - is there a way of making the same change?

Thanks.

Offline

#4 2013-10-04 10:29:48

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,241

Re: Panel behaviour

lw1471 wrote:

Good, in Xubuntu that 'Don't reserve...' option you mention solved things. I'm very likely to move to Debian 7 Xfce today though and that box isn't there in its version of Xfce - is there a way of making the same change?

Thanks.

Try disabling struts via:

xfconf-query -c xfce4-panel -p /panels/panel-2/disable-struts -t bool -n -s true

...make sure to replace "panel-2" with the name(s) of the panels you want to drop to the desktop level.

Offline

Board footer

Powered by FluxBB