Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-03-22 10:36:18

ayakout
Member
Registered: 2014-03-22
Posts: 3

Hide Suspend and hibernate options

Hi there,

I'm running Peppermint55 and the suspend option was about to break my hard disk. When selected, it turns off my computer and instantly back on.
I'm not really looking to make it work as I don't usually use suspend.. I'm just trying now to remove it from the power off menu so that I don't choose it again by mistake!

I tried suggestions using xfconf but nothing seems to work.

# xfconf-query -c xfce4-session -np '/shutdown/ShowSuspend' -t 'bool' -s 'false'
nor
# xfconf-query -c xfce4-session -p /shutdown/ShowSuspend --create --set false --type bool

# xfconf-query -V
.. 4.10.0

Any idea how to remove the suspend from the power off menu?



BR

Offline

#2 2014-03-22 12:09:47

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,385

Re: Hide Suspend and hibernate options

xfconf-query -c xfce4-session -p /shutdown/ShowSuspend --create --set false --type bool 

...works for me with 4.10. You can double-check its value by running:

xfconf-query -c xfce4-session -p /shutdown/ShowSuspend 

...to ensure that it is set to false.

-----

What exactly are you calling the "power off menu"? The one from the Action buttons plugin or the Xfce applications menu plugin?

-----

Is xfce4-session your session manager:

ps -ef | grep session

Offline

#3 2014-03-22 13:00:52

ayakout
Member
Registered: 2014-03-22
Posts: 3

Re: Hide Suspend and hibernate options

Hi

Here is the output of the commands

ali@ali-Home-PC ~/.config/xfce4 $ xfconf-query -c xfce4-session -p /shutdown/ShowSuspend
Property "/shutdown/ShowSuspend" does not exist on channel "xfce4-session".

ali@ali-Home-PC ~/.config/xfce4 $ ps -ef | grep session
root      1052   995  0 mar21 ?        00:00:00 lightdm --session-child 12 15
ali       1285  1052  0 mar21 ?        00:00:01 /usr/bin/lxsession -s Peppermint -e LXDE
ali       1330  1285  0 mar21 ?        00:00:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/bin/im-launch /usr/bin/startpeppermint
ali       1333     1  0 mar21 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/im-launch /usr/bin/startpeppermint
ali       1334     1  0 mar21 ?        00:00:00 //bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
ali       1484     1  0 mar21 ?        00:00:00 /usr/lib/at-spi2-core/at-spi2-registryd --use-gnome-session
root      6200     1  0 02:57 ?        00:00:00 //bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
ali      11534 10399  0 13:44 pts/2    00:00:00 grep --colour=auto session

In the main menu (the one that looks like windows start menu) there is a "Logout" option that has several choices
- Shutdown
- Reboot
- Suspend
- Hibernate
...

Offline

#4 2014-03-22 14:33:05

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 1,385

Re: Hide Suspend and hibernate options

ali       1285  1052  0 mar21 ?        00:00:01 /usr/bin/lxsession -s Peppermint -e LXDE

You're not using xfce4-session, but rather LXDE's session manager (lxsession). I'm not at all familiar with lxsession and its capabilities and it is not a component of Xfce. It would probably be best to ask at some LXDE forums for a solution.

Offline

#5 2014-03-22 14:45:03

ayakout
Member
Registered: 2014-03-22
Posts: 3

Re: Hide Suspend and hibernate options

Thanks for pointing that out!

Offline

Board footer

Powered by FluxBB