Xfce Forum

Sub domains
 

You are not logged in.

#1 2014-06-11 00:27:09

bark50
Member
Registered: 2014-03-04
Posts: 5

[Solved] Volume of event sounds not controlled by Pavucontrol

I've got a fresh, 3-day-old install of SolydX.  And thanks to ToZ's post here -> http://forum.xfce.org/viewtopic.php?id=8618 I've got event sounds working with the Borealis sound theme.  But the volume of the event sounds is the same regardless of where I put the volume slider in the Playback tab of Pavucontrol.  Even if I press the mute button, the event sounds volume remains the same.  I tried resetting the volume and logging out and back in.  Still the same. The only thing that seems to change the event sounds volume is Audio Mixer in the panel.  Can anyone help so the event sounds volume will be controlled in Pavucontrol?  Thanks.

Offline

#2 2014-06-11 02:00:13

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 956

Re: [Solved] Volume of event sounds not controlled by Pavucontrol

On every install where I've setup system sounds, in pavucontrol, on the playback tab, there is a section for "System Sounds". That slider has always controlled the volume of the system sounds.

Do you have a "System Sounds" entry?

Does sound otherwise work okay on your system?

Offline

#3 2014-06-11 03:21:38

bark50
Member
Registered: 2014-03-04
Posts: 5

Re: [Solved] Volume of event sounds not controlled by Pavucontrol

Hey, thanks for the reply, ToZ.  And thanks for the tutorial on getting event sounds to work.  This isn't a big deal.  If this thing can't be worked out, I could probably use Audacity to decrease Borealis' sounds to a level I like.

Anyway, I do indeed have that System Sounds entry.  Here's a screenshot: http://imgur.com/XRs0FRs.  The volume slider in the pic is at 71%, but it doesn't matter what percent it's at or if it's muted -- the event sounds volume is constant.

Yep, sound is working great on this system.

Offline

#4 2014-06-11 16:49:24

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 956

Re: [Solved] Volume of event sounds not controlled by Pavucontrol

Open up alsamixer in a terminal window and see if any of the other volume sliders control the system sounds.

The screenshot that you linked looks a lot like KDE. Did you theme your install to look like kde or do you run components from both DEs?

Offline

#5 2014-06-12 03:01:54

bark50
Member
Registered: 2014-03-04
Posts: 5

Re: [Solved] Volume of event sounds not controlled by Pavucontrol

In alsamixer I have 5 listings under Sound Card.  These are:
- (default)
0 HDA ATI SB
1 HDA NVidia
2 C-Media CMI8762
3 HD Webcam C525

The "- (default)" setting says "Card" is PulseAudio and "Chip" is PulseAudio.  It has just one control which is labeled as "Master".  Fiddling with this control increases and decreases the volume of event sounds.  It also increases and decreases the volume of Audio Mixer in the panel.  For the way sound is working right now on my pc, 50% in Audio Mixer is about a perfect setting as far as the media players I run.  But at 50%, the event sounds are louder than I would like.

I think the sound card that sends sound to my stereo receiver is the one labeled "2 C-Media CMI8762".  In alsamixer this card's "Card" is called C-Media CMI8762 and "Chip" is listed as "CMedia PCI".  Fiddling with the controls labeled as "Master", "PCM", "Synth", or "CD" has no effect on the volume of event sounds or on the volume range of Audio Mixer.

Nor does changing any of the sliders in any of the remaining sound cards (0 HDA ATI SB, 1 HDA NVidia, 3 HD Webcam C525) have any effect on event sounds or my system's sound volume.

Under the "Output Devices" tab of Pavucontrol I have two listings: "GF 116 High Definition Audio Controller Digital Stereo (HDMI)" and "Striker 7.1 Digital Stereo (IEC958)"  I have "GF 116" muted.  The volume slider for Striker 7.1 goes up and down in tandem with the volume control of Audio Mixer and the "- (default)" volume slider in alsamixer.

Doing a search in Synaptic for "kde" I do have numerous hits for what's installed.  It would take me a month of Sundays to type out all I'm seeing, but the first few are kdelibs5-plugins, libknotifyconfig4, libkcompactdisc4, and kde-runtime-data4.  I have Amarok installed.  Maybe these were brought in as dependencies...??

The only KDE-like theme I installed is the Betelgeuse icon set (which doesn't work -- changing any icon themes under Appearance/Icons does nothing in this install.  But that's a subject for a separate post...)

Phew!  Sound in linux is hard!  lol

Last edited by bark50 (2014-06-12 03:07:38)

Offline

#6 2014-06-12 14:07:54

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 956

Re: [Solved] Volume of event sounds not controlled by Pavucontrol

I think the answer may lie in your sound setup. Unfortunately, I don't have a lot of experience with sound to be helpful.

Offline

#7 2014-06-15 06:59:07

bark50
Member
Registered: 2014-03-04
Posts: 5

Re: [Solved] Volume of event sounds not controlled by Pavucontrol

This is embarrassing.  All I needed to do was install libcanberra-pulse.  It's listed in ToZ's instructions, but I installed sox and gnome-session-canberra thinking this Debian-based OS I'm running is more akin to Xubuntu than Arch.  Anyway, libcanberra-pulse is the key.

Offline

Board footer

Powered by FluxBB