Xfce Forum

Sub domains
 

You are not logged in.

#1 2016-11-19 01:38:36

mikkqu
Member
Registered: 2016-08-08
Posts: 12

CTRL+SHIFT shortcut from overlapping with itself other programs

I totally prefer to change keyboard layout by "LCtrl + LShift", as it seem to be the only convenient way for me.
Thus, the following setting take place in my XFCE setting manager: Keyboard -> Layout -> Change layout option: "LCtrl + LShift"

However, I noticed that if that set, I can't use "LCtrl + LShift + X" in other programs, i.e. xfce4-terminal.
Something like "Preferences - Ctrl+Shift+P" is not going to work anymore.

Another strange thing is that my "accelerators" are no longer editable, despite "Enable editable accelerators" enabled.
I remember it was working at some point, so I could just hover my mouse over some menu item and input new shortcut.
But now I couldn't do that, setting "Enable editable accelerators" on and off don't help either.

Am I doing anything wrong or it is a bug?
Can I workaround these two issues somehow?

Last edited by mikkqu (2016-11-19 01:40:05)

Offline

#2 2016-11-19 02:07:35

ToZ
Moderator
From: Toronto, Canada
Registered: 2011-06-02
Posts: 3,378

Re: CTRL+SHIFT shortcut from overlapping with itself other programs

mikkqu wrote:

I totally prefer to change keyboard layout by "LCtrl + LShift", as it seem to be the only convenient way for me.
Thus, the following setting take place in my XFCE setting manager: Keyboard -> Layout -> Change layout option: "LCtrl + LShift"
However, I noticed that if that set, I can't use "LCtrl + LShift + X" in other programs, i.e. xfce4-terminal.
Something like "Preferences - Ctrl+Shift+P" is not going to work anymore.

I believe this is the result of a long-standing issue where shortcuts are processed when the keys are pressed and not released. In this case, Ctrl+Shift is processed and the remaining key ignored. Same happens if you want to use Super-only for the menu, other Super+ shortcuts don't work. See this bug report.

Another strange thing is that my "accelerators" are no longer editable, despite "Enable editable accelerators" enabled.
I remember it was working at some point, so I could just hover my mouse over some menu item and input new shortcut.
But now I couldn't do that, setting "Enable editable accelerators" on and off don't help either.

The old method doesn't work with the gtk3 version of xfce4-terminal. You need to manually edit the ~/.config/xfce4/terminal/accels.scm file to change the accelerators. (bug report)


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

Board footer

Powered by FluxBB