Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-12-16 13:00:50

fern
Member
Registered: 2017-01-22
Posts: 23

The panel this running in kiosk mode, failed to start session Xfce!

Hello community!

For what that message is displayed automatically  in small windows at each start of Xfce session? And the taskbar is not displayed.

   

No instance found of xfce4-panel in execution
Modification of the panel is not allowed. 

Panel is running in kiosk mode. You are not allowed to make changes to panel settings.

Offline

#2 2017-12-16 19:36:48

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,262

Re: The panel this running in kiosk mode, failed to start session Xfce!

Can you provide a little more information?

Is this a new install?
Did you make some configuration changes?
Which distro and which version of Xfce?
Does it happen for all users or just one?
Are the permissions correct on your ~/.config and ~/.config/xfce4/xfconf/xfce-perchannel-xml directories and files?

As a possible resolution suggestion, while logged out, try deleting the ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel file.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2017-12-17 01:39:28

fern
Member
Registered: 2017-01-22
Posts: 23

Re: The panel this running in kiosk mode, failed to start session Xfce!

ToZ wrote:

Can you provide a little more information?

Is this a new install?
Did you make some configuration changes?
Which distro and which version of Xfce?
Does it happen for all users or just one?
Are the permissions correct on your ~/.config and ~/.config/xfce4/xfconf/xfce-perchannel-xml directories and files?

As a possible resolution suggestion, while logged out, try deleting the ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel file.


I didn't do anything to the default Xfce configuration that for the first time launched everything perfect on the desktop. But when I restarted the system, he gave me that error displaying those little windows with those messages.

I remember adding a file for the keyboard language, but after those bugs I deleted that file and restarted the system   what continues with those bugs at the beginning of each session.

The Xfce version is 4.12 and I only have the FreeBSD system for one user.  In the xfce-perchannel-xml folder directory are these files as:

keyboards.xml, thunar.xml...xfce4-appfinder.xml...xfce4-desktop.xml....xfce4-keyboard-shortcuts.xml

xfce4-notifyd.xml ....xfce4-panel.xml ....xfce4-session.xml....xfce4-settings-manager.xml

xfwm4.xml......xsettings.xml

Last edited by fern (2017-12-17 01:46:49)

Offline

#4 2017-12-17 10:28:40

sixsixfive
Member
From: behind you
Registered: 2012-04-08
Posts: 578
Website

Re: The panel this running in kiosk mode, failed to start session Xfce!

fern wrote:
Panel is running in kiosk mode. You are not allowed to make changes to panel settings.

you still have the /etc/xdg/xfce4/kiosk/kioskrc file(otherwise the panel wouldnt start in kiosk mode), also in this file there should be a line like:

[xfce4-panel]
CustomizePanel=%$GROUP,$USER

were you can customize who is able to modify the panel

Offline

#5 2017-12-17 14:59:27

fern
Member
Registered: 2017-01-22
Posts: 23

Re: The panel this running in kiosk mode, failed to start session Xfce!

Hello community!

I've solved that problem, it's more or less as ToZ  say at the end, delete the xfce4-panel.xml file  from the xfce-perchannel-xml/ directory and also remove everything that was inside the "sessions" folder of the .cache directory, and restart the system. smile

Last edited by fern (2017-12-17 15:00:48)

Offline

Board footer

Powered by FluxBB