Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-01-22 16:52:15

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Changing the desktop icons text colour ? (SOLVED)

I am developing for a customer, who wants a desktop which is mainly white.

As the desktop icons labels are also mainly white, it makes for difficult reading, and I have been unable to find where to configure the font colour for those.

Any idea ?

Last edited by rolgiati (2018-02-03 20:20:14)

Offline

#2 2018-01-22 17:21:45

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,262

Re: Changing the desktop icons text colour ? (SOLVED)


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Online

#3 2018-01-22 19:16:19

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Changing the desktop icons text colour ? (SOLVED)

Gateful thanks; I just need to replace  #000000 with #ffffff in the three fg lines of ~/.gtkrc-2.0 !

Offline

#4 2018-01-22 21:13:37

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Changing the desktop icons text colour ? (SOLVED)

rolgiati wrote:

Gateful thanks; I just need to replace  #000000 with #ffffff in the three fg lines of ~/.gtkrc-2.0 !

except that, sadly, it does not work, my icons labels still come out in white with grey shadows...

Offline

#5 2018-01-23 00:13:55

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,262

Re: Changing the desktop icons text colour ? (SOLVED)

Just to confirm, you are using xfdesktop 4.12.x (gtk2) version?

If so, try this snippet:

style "xfdesktop-icon-view" {
    XfdesktopIconView::shadow-x-offset = 0
    XfdesktopIconView::shadow-y-offset = 0
    XfdesktopIconView::shadow-color = "#000000"

    XfdesktopIconView::selected-shadow-x-offset = 0
    XfdesktopIconView::selected-shadow-y-offset = 0
    XfdesktopIconView::selected-shadow-color = "#000000"

    base[NORMAL] = "#b5b5b4"
    base[SELECTED] = "#b5b5b4"
    base[ACTIVE] = "#b5b5b4"

    fg[NORMAL] = "#000000"
    fg[SELECTED] = "#000000"
    fg[ACTIVE] = "#000000"
}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

...or if you want a transparent text background, try:

style "xfdesktop-icon-view" {
    XfdesktopIconView::label-alpha = 0 
    XfdesktopIconView::selected-label-alpha = 0

    XfdesktopIconView::shadow-x-offset = 0
    XfdesktopIconView::shadow-y-offset = 0
    XfdesktopIconView::shadow-color = "#000000"

    XfdesktopIconView::selected-shadow-x-offset = 0
    XfdesktopIconView::selected-shadow-y-offset = 0
    XfdesktopIconView::selected-shadow-color = "#000000"

    base[NORMAL] = "#b5b5b4"
    base[SELECTED] = "#b5b5b4"
    base[ACTIVE] = "#b5b5b4"

    fg[NORMAL] = "#000000"
    fg[SELECTED] = "#000000"
    fg[ACTIVE] = "#000000"
}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

You'll need to restart xfdesktop (pkill xfdesktop) or log out and back in again to see the change.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Online

#6 2018-01-23 11:04:42

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Changing the desktop icons text colour ? (SOLVED)

ToZ wrote:

Just to confirm, you are using xfdesktop 4.12.x (gtk2) version?

[ron@localhost ~]$ xfdesktop -V
This is xfdesktop version 4.12.4, running on Xfce 4.12.
Built with GTK+ 2.24.31, linked with GTK+ 2.24.31.
Build options:
    Desktop Menu:        enabled
    Desktop Icons:       enabled
    Desktop File Icons:  enabled

ToZ wrote:

If so, try this snippet:(SNIP)
You'll need to restart xfdesktop (pkill xfdesktop) or log out and back in again to see the change.

Thank you for your kind help.
Sadly, the snippet did not work either.  ;-3(

Offline

#7 2018-01-23 11:16:52

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,262

Re: Changing the desktop icons text colour ? (SOLVED)

Can you post back the results of:

cat $HOME/.gtkrc-2.0

...and:

ls -al $HOME | grep gtk

...and:

ps -ef | grep -i desktop

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Online

#8 2018-01-23 13:48:14

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Changing the desktop icons text colour ? (SOLVED)

ToZ wrote:

Can you post back the results of:

cat $HOME/.gtkrc-2.0

[ron@localhost ~]$ cat $HOME/.gtkrc-2.0
style "xfdesktop-icon-view" {
    XfdesktopIconView::shadow-x-offset = 0
    XfdesktopIconView::shadow-y-offset = 0
    XfdesktopIconView::shadow-color = "#000000"

    XfdesktopIconView::selected-shadow-x-offset = 0
    XfdesktopIconView::selected-shadow-y-offset = 0
    XfdesktopIconView::selected-shadow-color = "#000000"

    base[NORMAL] = "#b5b5b4"
    base[SELECTED] = "#b5b5b4"
    base[ACTIVE] = "#b5b5b4"

    fg[NORMAL] = "#000000"
    fg[SELECTED] = "#000000"
    fg[ACTIVE] = "#000000"
}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

ToZ wrote:

...and:

ls -al $HOME | grep gtk

[ron@localhost ~]$ ls -al $HOME | grep gtk
-rw-r--r--  1 ron  ron     565 janv. 23 03:54 .gtkrc-2.0

ToZ wrote:

...and:

ps -ef | grep -i desktop

[ron@localhost ~]$ ps -ef | grep -i desktop
ron       2634     1  0 07:24 ?        00:00:01 xfdesktop
ron       3631  3568  0 07:29 pts/0    00:00:00 grep --color -i desktop

Offline

#9 2018-01-23 16:08:45

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,262

Re: Changing the desktop icons text colour ? (SOLVED)

That should work. Which appearance (gtk2) theme are you using?

Also try changing the last line:

widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

...to this:

widget_class "*XfdesktopIconView*" style:highest "xfdesktop-icon-view"

How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Online

#10 2018-01-23 17:31:45

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Changing the desktop icons text colour ? (SOLVED)

ToZ wrote:

That should work. Which appearance (gtk2) theme are you using?

Sorry, have no idea where to find that information.

ToZ wrote:

Also try changing the last line to this:

widget_class "*XfdesktopIconView*" style:highest "xfdesktop-icon-view"

Tried it, no change  ;-3(

Offline

#11 2018-01-23 18:17:12

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,262

Re: Changing the desktop icons text colour ? (SOLVED)

Here is an easy way to get the theme name:

xfconf-query -c xsettings -p /Net/ThemeName

Are you logging in and out again to test it?

Also, can you create a second account on your computer and try this snippet with that account?


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Online

#12 2018-01-24 12:48:21

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Changing the desktop icons text colour ? (SOLVED)

ToZ wrote:

Here is an easy way to get the theme name:

xfconf-query -c xsettings -p /Net/ThemeName

Got it: Blue-Submarine

ToZ wrote:

Are you logging in and out again to test it?

Yes, tried with both pkill xfdesktop and logout - login

ToZ wrote:

Also, can you create a second account on your computer and try this snippet with that account?

Tried the snippet in another account, no change ;-3(

Offline

#13 2018-01-24 13:17:26

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,262

Re: Changing the desktop icons text colour ? (SOLVED)

Does changing the appearance theme (Settings Manager > Appearance > Style) and restart xfdesktop (pkill xxfdesktop) make that snippet work?

Try this version:

style "my-xfdesktop-icon-view" {
    XfdesktopIconView::label-alpha = 0
    XfdesktopIconView::selected-label-alpha = 100
    XfdesktopIconVIew::ellipsize-icon-labels = 1

    XfdesktopIconView::shadow-x-offset = 1
    XfdesktopIconView::shadow-y-offset = 1
    XfdesktopIconView::shadow-color = "#000000"
    XfdesktopIconView::selected-shadow-x-offset = 1
    XfdesktopIconView::selected-shadow-y-offset = 1
    XfdesktopIconView::selected-shadow-color = "#000000"

    XfdesktopIconView::cell-spacing = 0
    XfdesktopIconView::cell-padding = 0
    XfdesktopIconView::cell-text-width-proportion = 2

    base[NORMAL]   	= "#b5b5b4"
    base[SELECTED] 	= "#b5b5b4"
    base[ACTIVE]   	= "#b5b5b4"

    fg[NORMAL]      = "#000000"
    fg[SELECTED]    = "#000000"
    fg[ACTIVE]      = "#000000"
}

widget_class "*XfdesktopIconView*" style "my-xfdesktop-icon-view"

Last edited by ToZ (2018-01-24 13:22:00)


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Online

#14 2018-02-03 20:19:40

rolgiati
Member
From: Asuncion, Paraguay
Registered: 2013-06-08
Posts: 22

Re: Changing the desktop icons text colour ? (SOLVED)

ToZ wrote:

Does changing the appearance theme (Settings Manager > Appearance > Style) and restart xfdesktop (pkill xxfdesktop) make that snippet work?

Try this version:

style "my-xfdesktop-icon-view" {
    XfdesktopIconView::label-alpha = 0
    XfdesktopIconView::selected-label-alpha = 100
    XfdesktopIconVIew::ellipsize-icon-labels = 1

    XfdesktopIconView::shadow-x-offset = 1
    XfdesktopIconView::shadow-y-offset = 1
    XfdesktopIconView::shadow-color = "#000000"
    XfdesktopIconView::selected-shadow-x-offset = 1
    XfdesktopIconView::selected-shadow-y-offset = 1
    XfdesktopIconView::selected-shadow-color = "#000000"

    XfdesktopIconView::cell-spacing = 0
    XfdesktopIconView::cell-padding = 0
    XfdesktopIconView::cell-text-width-proportion = 2

    base[NORMAL]   	= "#b5b5b4"
    base[SELECTED] 	= "#b5b5b4"
    base[ACTIVE]   	= "#b5b5b4"

    fg[NORMAL]      = "#000000"
    fg[SELECTED]    = "#000000"
    fg[ACTIVE]      = "#000000"
}

widget_class "*XfdesktopIconView*" style "my-xfdesktop-icon-view"

Sorry for the delay; HD on the box where I test PCLOS went belly-up, took couple week to have another sent to Darkest Paraguay.
Tried the above, it worked !
My thanks to all who gave their time to help me out.

Offline

Board footer

Powered by FluxBB