Xfce Forum

Sub domains
 

You are not logged in.

#1 2018-07-11 15:19:30

dlwilson88
Member
From: Virginia
Registered: 2018-06-27
Posts: 3

problems starting gparted

I just installed gparted using the terminal to download the package by executing the command 

~$ sudo apt install gparted

   after it installed I then went to the Applications Folder and also used the Application Finder to locate and run the program from a GUI.
   After selecting the file and then clicking the launch button...... nothing happens.
   When I open the terminal and entered the command

~$ gparted-pkexec

   I was asked to enter in my user password.

 (xenial)dlwilson88@localhost:~$ gparted-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.gparted ===
Authentication is required to run the GParted Partition Editor
Authenticating as: dlwilson88
Password:

    Upon entering my password I then received this error message: 

polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
]Error executing command as another user: Not authorized

This incident has been reported.
(xenial)dlwilson88@localhost:~$ 

    Does anyone have any idea why it's asking for my user password and then saying

Not authorized

    and why it won't open after clicking the launch
    button from within the Application Menu?
   This is what I get if I enter the command:

~$ sudo gparted
[sudo] password for dlwilson88:
======================
libparted : 3.2
======================

    and the program still refuses to launch??

   here is my os version:

~$ lsb_release -a
LSB Version:	core-9.20160110ubuntu0.2-amd64
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.4 LTS
Release:	16.04
Codename:	xenial

Last edited by dlwilson88 (2018-07-11 15:29:22)

Offline

#2 2018-07-11 16:20:43

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,421

Re: problems starting gparted

I believe there is an active bug report about this issue (authentication not working without a Gui agent). Make sure you have a policykit agent installed and running. For ubuntu, I believe its in the "policykit-1-gnome" package and the authentication agent is "/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1".

If it's not currently running, start it up and try again. If it works, check that it's enabled in Settings Manager > Session and Startup > Startup Applications.


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

#3 2018-07-11 17:40:21

dlwilson88
Member
From: Virginia
Registered: 2018-06-27
Posts: 3

Re: problems starting gparted

~$ whereis policykit-1-gnome
policykit-1-gnome:

    Not sure what this output means?

~$ sudo apt-get install policykit-1-gnome
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  policykit-1-gnome
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 24.0 kB of archives.
After this operation, 139 kB of additional disk space will be used.
Err:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 policykit-1-gnome amd64 0.105-2ubuntu2
  Temporary failure resolving 'archive.ubuntu.com'
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/policykit-1-gnome/policykit-1-gnome_0.105-2ubuntu2_amd64.deb  Temporary failure resolving 'archive.ubuntu.com'
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
~$ sudo apt-get update && sudo apt-get upgrade
Err:1 http://archive.ubuntu.com/ubuntu xenial InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:2 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:3 http://dl.google.com/linux/chrome/deb stable InRelease
  Temporary failure resolving 'dl.google.com'
Err:4 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu xenial InRelease
  Temporary failure resolving 'ppa.launchpad.net'
Err:5 http://archive.ubuntu.com/ubuntu xenial-security InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:6 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
  Temporary failure resolving 'archive.ubuntu.com'
Err:7 https://packagecloud.io/AtomEditor/atom/ubuntu xenial InRelease
  Could not resolve host: packagecloud.io
Err:8 https://packagecloud.io/AtomEditor/atom/any any InRelease
  Could not resolve host: packagecloud.io
Reading package lists... Done
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/xenial/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/xenial-security/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/xenial-backports/InRelease  Temporary failure resolving 'archive.ubuntu.com'
W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/InRelease  Temporary failure resolving 'dl.google.com'
W: Failed to fetch https://packagecloud.io/AtomEditor/atom/ubuntu/dists/xenial/InRelease  Could not resolve host: packagecloud.io
W: Failed to fetch https://packagecloud.io/AtomEditor/atom/any/dists/any/InRelease  Could not resolve host: packagecloud.io
W: Failed to fetch http://ppa.launchpad.net/gezakovacs/ppa/ubuntu/dists/xenial/InRelease  Temporary failure resolving 'ppa.launchpad.net'
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

     Any idea why all or most all of the files failed to download? Should I try getting a tar.gz or some version
     of a physical copy of the actual file? Or does the failed apt-get update mean there is an issue with my operating system?

Offline

#4 2018-07-11 20:14:27

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,421

Re: problems starting gparted

Temporary failure resolving 'archive.ubuntu.com'

Is everything okay with your network connection? Can you connect to: http://archive.ubuntu.com/ubuntu/dists/?


How To Ask For Help           Xfce FAQ                            Xfce Release Information
The Xfce Community          Xfce Tips and Tricks

Offline

Board footer

Powered by FluxBB