Xfce Forum

Sub domains
 

You are not logged in.

#1 2017-05-21 00:05:54

xfdevin98
Member
Registered: 2017-05-20
Posts: 3

[Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

Okay, so I recently updated to the latest version of the PulseAudio plugin for Xfce4 that was pushed to Arch's stable repos, and this is now how the icon appears on my panel. Current panel size is 32; the icon seems to go back to its size that was present in the previous version when I drop the panel's length to 26, but this is far too small for me.

Prjo2Ut.png

If this info may help:
- icon theme: Paper
- GTK+ theme: Adapta

Offline

#2 2017-05-21 00:54:12

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

Hello and welcome.

Try something like the following in ~/.config/gtk-3.0/gtk.css:

#pulseaudio-button { padding: 3px; }

...adjust the 3px to suit.

Restart the panel to see the effect:

xfce4-panel -r

Offline

#3 2017-05-21 11:15:04

matthieumota
Member
Registered: 2017-05-21
Posts: 2

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

Hello,

I've the same problem since update xfce4-pulseaudio-plugin in 2.5.1 on Arch Linux stable. CSS doesn't change anything because it's the button size who is not correct and we can't change that by css but only in library code.

I started to look where the problem came from. I've checked the git repo and i think the problem is by this commit

Especially how is calculate the icon size. If I have the time, I would try to modify the package and recompile it. Else, I think contributors will correct the bug.

Last edited by matthieumota (2017-05-21 11:18:36)

Offline

#4 2017-05-21 13:43:50

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

On my Arch system, with Adapta as the GTK theme and Paper icons, panel size set to 34, I get the following (clipman, power-manager, pulseaudio, actions plugins):
1e5d1af82cf4f254fce84790f18e9e173.png

With "#pulseaudio-button { padding: 3px; }" in my ~/.config/gtk-3.0/gtk.css file, I get:
2268364775cdb7c9d125718682db4dacc.png

And to fix all of them, using the following:

#pulseaudio-button { padding: 3px; }
#xfce4-clipman-plugin { padding: 4px; }
#xfce4-power-manager-plugin { padding: 3px; }

...I get:
5ee594778a37f5b8b34f3a121c7286dbb.png

@matthieumota, which GTK theme and icon set are you using?

Offline

#5 2017-05-21 13:59:48

matthieumota
Member
Registered: 2017-05-21
Posts: 2

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

I also use Adapta and Paper.
My panel size is to 30. And before the update (2.4.1), icon was in good size.
If i reduce panel size to 24, it's okay. CSS doesn't change anything for me. I've purposed a patch for that.

Offline

#6 2017-05-21 14:17:21

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

Your patch has been accepted. Thanks for contributing.

Offline

#7 2017-05-21 19:40:42

xfdevin98
Member
Registered: 2017-05-20
Posts: 3

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

matthieumota wrote:

I also use Adapta and Paper.
My panel size is to 30. And before the update (2.4.1), icon was in good size.
If i reduce panel size to 24, it's okay. CSS doesn't change anything for me. I've purposed a patch for that.

Thank you so much for submitting a patch. smile

ToZ, I appreciate you telling us a way to change the size of the symbolic icons. Fixed my issue with the Clipman plugin, too! The issue with the PA plugin still stands, sadly, but I can live with it until a bugfix release gets pushed out. If not, I'll submit a bug report to find out if the package maintainer can implement the upstream patch.

Xfce is the best DE ever! big_smile

Last edited by xfdevin98 (2017-05-21 19:59:13)

Offline

#8 2018-09-14 06:15:15

Podesta
Member
Registered: 2018-09-14
Posts: 2

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

Hey guys, sorry to necro an old post, but I'm having the same issue. If preferable I can start a new thread.
The icon seems to stay the 'correct' size as long as the panel is 35 or smaller, but anything over 35 and it becomes the giant icon.
Here is how it looks, a bit out of touch with the rest: 4hXArCB.png


The proposed tweak of adding padding doesn't work because it simply clips the icon out, without actually reducing the size. With a padding of 13px just to demonstrate what I mean: Zc7lZXO.png


xubuntu 18.04
xfce4-panel version 4.12.2
xfce-pulseaudio-plugin 0.4.1
xfce4-dockbarx-applet

Offline

#9 2018-09-14 11:23:53

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

Try this setting instead:

#pulseaudio-button * {
    -gtk-icon-transform: scale(.7);
}

...and change the ".7" to a value that suits.

Offline

#10 2018-09-14 11:38:26

Podesta
Member
Registered: 2018-09-14
Posts: 2

Re: [Arch Linux] xfce4-pulseaudio-plugin's icon is too large! Help?

Works perfectly! Thanks a bunch ToZ!
Edit: Also resized the whiskermenu-button with that, since it also looked a bit too big. If you don't mind me asking, is there any place to see the names/attributes from each icon if I wanted to change them?

Last edited by Podesta (2018-09-14 11:52:49)

Offline

Board footer

Powered by FluxBB