Xfce Forum

Sub domains
 

You are not logged in.

#1 2015-12-15 18:38:55

qandak
Member
Registered: 2015-12-15
Posts: 5

[Solved] One more time about that ugly grey background of loading xfwm.

According to dedicated forums and bug trackers the issue of "Gray Background Before Desktop Loads" is 3 (or more) years old.
So, I'm pretty sure there is no need to explain what the topic is about.

I really like Xfce. Lightweight, fast and extremely customizable. But the way it's starting on "high-performance" PC reminds me my old i386 and windows 3.1... 2-3 seconds of grey background while xfdesktop and xfce4-panel are loading.
There are suggestions about rebuilding Xfwm with enabled MONITOR_ROOT_PIXMAP, which is disabled by default.
There is even a bug report with "Fix Released" status: https://bugs.launchpad.net/xfwm4/+bug/1232804

However, I don't have any idea what to do, neither how to do, if the question is about rebuilding Xfwm.

In case if there is no chance for now to get rid of that annoying grey background, how can I simply change that grey colour to black, for example?
That would be better than nothing. Otherwise I'll have no choice but to buy one more SSD to speedup Xfce loading a little at least:)


System:  Arch(fresh installed), Xfce/Xfwm, LightDM/Lightdm-GTK-Greeter(Autologin)
Session:  xfwm4, Thunar, xfce4-panel, Xfsettingsd, xfdesktop, Power Manager
Autostart:  nm-applet, polkit, xfce4-power-manager, light-locker, xfce4-volumed-pulse, xfsettingsd

Offline

#2 2015-12-15 19:49:45

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Solved] One more time about that ugly grey background of loading xfwm.

According to that bug report, two pieces were required for the fix (lightdm-gtk-greeter and xfwm4).

The lightdm-gtk-greeter fix was added to version 1.7. Currently, the Arch version is 2.0.1, so it should be included.

With respect to the xfwm4 fix, the Xubuntu team custom-compiled the package to enable MONITOR_ROOT_PIXMAP. In this commit, MONITOR_ROOT_PIXMAP was set to default enabled in the xfwm4 code. However, this commit has not yet been officially released and is sitting in the git tree.

So to fix it, you'll need to build xfwm4 from git. The easiest way to do this on arch would be to use the xfwm4-git AUR package. More info on the AUR here.

Offline

#3 2015-12-15 20:20:13

qandak
Member
Registered: 2015-12-15
Posts: 5

Re: [Solved] One more time about that ugly grey background of loading xfwm.

Thank you for the quick reply, ToZ!

I'll try to do that AUR build tomorrow, and let you know how it works.

Am I right to assume that it's OK to install the new package from git over the installed official release, or maybe the old one must be removed before?

Offline

#4 2015-12-15 20:37:00

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Solved] One more time about that ugly grey background of loading xfwm.

The AUR package will replace the installed package. To revert, simply re-install xfwm4.

Offline

#5 2015-12-16 09:57:02

qandak
Member
Registered: 2015-12-15
Posts: 5

Re: [Solved] One more time about that ugly grey background of loading xfwm.

I installed xfwm4-git from AUR. Yaourt asked about conflict with xfwm, as expected, and I remove it.

Unfortunately nothing changed at start:/

Honestly I would be happy if I could just change grey colour. I didn't find any information about file and setting responsible for that grey.

Offline

#6 2015-12-16 11:40:43

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Solved] One more time about that ugly grey background of loading xfwm.

qandak wrote:

Honestly I would be happy if I could just change grey colour. I didn't find any information about file and setting responsible for that grey.

I am unaware of a setting that will change this default colour.

I just updated a test system to xfwm4-git and it works - the grey colour is no longer displayed. Can you confirm the xfwm4 version in use:

xfwm4 -V

Also, try clearing your sessions cache (Settings Manager > Session and Startup > Session > Clear saved sessions), then log out and back in again.

Edit:
Can you confirm that you have the compositor enabled?

Last edited by ToZ (2015-12-16 11:47:20)

Offline

#7 2015-12-16 18:20:42

qandak
Member
Registered: 2015-12-15
Posts: 5

Re: [Solved] One more time about that ugly grey background of loading xfwm.

After couple of reboot a kind of "broken graphic card" image is briefly appearing in place of the greeter (hidden with autologin), right before grey background and xfdesktop start.

I thought something was going wrong with lightdm-gtk-greeter and LightDM's autologin.
I tried to disable autologin (which was enabled regarding ArchWiki) and everything worked fine! Just as it should be!

So, do I have to choose now what is more preferable for every session start - Login prompt or grey background?:)


xfwm4 -V

This is xfwm4 version 4.12.0git.7f107ee (revision 7f107ee) for Xfce 4.12
	Released under the terms of the GNU General Public License.
	Compiled against GTK+-2.24.29, using GTK+-2.24.29.

	Build configuration and supported features:
	- Startup notification support:                 Yes
	- XSync support:                                Yes
	- Render support:                               Yes
	- Xrandr support:                               Yes
	- Xpresent support:                             No
	- Embedded compositor:                          Yes
	- Epoxy support:                                Yes
	- KDE systray proxy (deprecated):               No

Compositor is enabled.

Offline

#8 2015-12-16 23:13:39

ToZ
Moderator
From: Canada
Registered: 2011-06-02
Posts: 4,660

Re: [Solved] One more time about that ugly grey background of loading xfwm.

Ok, I see. When I enable autologin, then the grey screen happens to me as well. Perhaps lightdm is doing something differently when autologin is enabled?

Offline

#9 2015-12-17 14:41:19

qandak
Member
Registered: 2015-12-15
Posts: 5

Re: [Solved] One more time about that ugly grey background of loading xfwm.

I suppose, in case of xfwm4's MONITOR_ROOT_PIXMAP fix, lighdm-gtk-greeter (which is related to this fix) must be started in usual login prompt way.

However, I'll try to understand what is wrong with LighDM autologin, and maybe create a special topic in a dedicated forum.

Thank you so much for your help, ToZ!

Offline

Board footer

Powered by FluxBB